Results 1 to 6 of 6

Thread: [SOLVED] Still no fix ... " is only avaliable with the XS version at" issue

  1. #1
    wcbenyip is offline Senior Member
    Join Date
    Jun 2007
    Location
    Hong Kong
    Posts
    62
    Rep Power
    8

    Question [SOLVED] Still no fix ... " is only avaliable with the XS version at" issue

    Hi,

    During the migration of my zcs os edition v5.0.9 from the platform of openSUSE 10.3 to Ubuntu 8.04LTS, everything seems OK including the data integrity; however, an error msg found at the end and the process stopped....

    Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
    HOSTNAME=mail.abc.com
    LDAPHOST=mail.abc.com
    LDAPPORT=389
    SNMPTRAPHOST=mail.abc.com
    SMTPSOURCE=admin@mail.abc.com
    SMTPDEST=admin@mail.abc.com
    SNMPNOTIFY=yes
    SMTPNOTIFY=yes
    LDAPROOTPW=NsJBwEcZ
    LDAPZIMBRAPW=NsJBwEcZ
    LDAPPOSTPW=NsJBwEcZ
    LDAPREPPW=NsJBwEcZ
    LDAPAMAVISPW=NsJBwEcZ
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
    Operations logged to /tmp/zmsetup.01001900-0000138985260.log
    Starting ldap...done.
    Setting defaults...done.
    Setting defaults from existing config...done.
    Checking for port conflicts
    Setting defaults from ldap...done.
    is only avaliable with the XS version at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 30.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 991.


    #Remark: I am performing the migration procedure following this guide.


    Even I have searching this well-known issue with some suggestion to fix (including manually download the Scalar::Util component and install it, and manually set the $PERLLIB & $PERL5LIB environment variables based on ~zimbra/.bashrc, I have re-do the install.sh for many times as well), the issue is still out there and it really make me frustrated !!!

    Does anyone has any idea on this issue? I am tried in finding the solutions which are totally not working... Please HELP!!
    OS=Ubuntu 8.04 LTS
    Current: Release 5.0.10_GA_2638.UBUNTU8 UBUNTU8 FOSS edition
    OS=openSUSE 10.3
    Current: Release 5.0.2_GA_1975.openSUSE_10.2_20080130231825 UNKNOWN FOSS edition
    Prior: Release 4.5.6_GA_1044.SuSE10_20070706142147 openSUSE_10.2 FOSS edition

  2. #2
    wcbenyip is offline Senior Member
    Join Date
    Jun 2007
    Location
    Hong Kong
    Posts
    62
    Rep Power
    8

    Question

    After the zcs is upgraded to oss ver 5.0.20, the result is the same but a little bit difference...

    dualvar is only available with the XS version of Scalar::Util at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 38
    BEGIN failed--compilation aborted at /opt/zimbra/zimbramon/lib/IO/Socket/SSL.pm line 38.
    Compilation failed in require at /opt/zimbra/zimbramon/lib/Net/LDAP.pm line 998.


    Seems lots of the ppl reached this issue but without the exact solution yet.... I don't know why even the latest version of zimbra is still keep this known issue.....

    Anyone could help??
    OS=Ubuntu 8.04 LTS
    Current: Release 5.0.10_GA_2638.UBUNTU8 UBUNTU8 FOSS edition
    OS=openSUSE 10.3
    Current: Release 5.0.2_GA_1975.openSUSE_10.2_20080130231825 UNKNOWN FOSS edition
    Prior: Release 4.5.6_GA_1044.SuSE10_20070706142147 openSUSE_10.2 FOSS edition

  3. #3
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,493
    Rep Power
    56

    Default

    This problem doesn't exist with current versions of Zimbra as the Scalar::Util is shipped with Zimbra. The reasons it failed in the past wer because a) people changed their version of Perl from that shipped with that originally supplied with their distribution and b) people installed a different version of Scalar::Util from that originally shipped with their distribution.

    Zimbra is tested and verified to install correctly on the specified supported operating systems.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    wcbenyip is offline Senior Member
    Join Date
    Jun 2007
    Location
    Hong Kong
    Posts
    62
    Rep Power
    8

    Default

    Oh... really?

    It's so strange.. as I am just installing a fresh installed copy of Ubuntu 8.04LTS server with latest update ONLY and didn't changed any component version... also just install the zcs oss 5.0.9 or the another try 5.0.20 with the backup folder '/opt/zimbra' for replacement!

    Actually, we have upgraded the 5.0.9 to 5.0.20 on the opensuse 10.3 platform in the original server, the result is positive even needs re-install for few times before success. And then, I backup the folder, and move it to the another server which is running the Ubuntu 8.04LTS server (fresh install) + SAME version of the zcs~ I never considered to change the perl version or even upgrade or manually install the Scalar::Util component before found some wiki saying this issue and suggested this approach....

    So, up to this moment, this issue seems still there and lots of questions are not yet fixed in the forum... even you said this issue doesn't exist with current version~ Which version do you mean? I am facing this issue in 5.0.9 and 5.0.20 anyway.... with the same result. I will try ver 6 on tomorrow...
    OS=Ubuntu 8.04 LTS
    Current: Release 5.0.10_GA_2638.UBUNTU8 UBUNTU8 FOSS edition
    OS=openSUSE 10.3
    Current: Release 5.0.2_GA_1975.openSUSE_10.2_20080130231825 UNKNOWN FOSS edition
    Prior: Release 4.5.6_GA_1044.SuSE10_20070706142147 openSUSE_10.2 FOSS edition

  5. #5
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,493
    Rep Power
    56

    Default

    Quote Originally Posted by wcbenyip View Post
    Oh... really?
    Yes, really. This was fixed in Zimbra 5.0.2 (it's not actually a problem in Zimbra and you can check the Release Notes for that version if you choose), I've also just done a clean install on a new copy of 8.0.4 LTS and Zimbra installs and works without the problem you're describing.

    Quote Originally Posted by wcbenyip View Post
    So, up to this moment, this issue seems still there and lots of questions are not yet fixed in the forum... even you said this issue doesn't exist with current version~ Which version do you mean? I am facing this issue in 5.0.9 and 5.0.20 anyway.... with the same result. I will try ver 6 on tomorrow...
    So are you actually saying that after a clean install of Ubuntu 8.04 LTS and then install Zimbra you have this problem?

    If the problem occurs after you've copied across the directory from your openSUSE machine then you will have an incompatibility with the libraries in the /opt/zimbra directories (they would have been built for a different platform than the server you're moving to). You need to search the wiki and/or the forums about how to change platforms when you do the server move.
    Last edited by phoenix; 07-25-2011 at 08:20 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    wcbenyip is offline Senior Member
    Join Date
    Jun 2007
    Location
    Hong Kong
    Posts
    62
    Rep Power
    8

    Lightbulb [SOLVED] Still no fix ... " is only avaliable with the XS version at" issue!!

    I reached this issue in the moving of the existing zimbra folder to a new server with the SAME zcs version. Anyway, after few times retry with the same error yesterday, it works suddenly this morning... and every services are running properly~

    There is another issue during the upgrade from 5.0.20 to 6.0.2, but I created another new thread to address it, this case should be closed. Thanks for any help given so far~
    OS=Ubuntu 8.04 LTS
    Current: Release 5.0.10_GA_2638.UBUNTU8 UBUNTU8 FOSS edition
    OS=openSUSE 10.3
    Current: Release 5.0.2_GA_1975.openSUSE_10.2_20080130231825 UNKNOWN FOSS edition
    Prior: Release 4.5.6_GA_1044.SuSE10_20070706142147 openSUSE_10.2 FOSS edition

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Internal Server Error on Advanced Version
    By vnit in forum Administrators
    Replies: 4
    Last Post: 09-15-2009, 12:20 AM
  2. Zimbra 3.1 Postfix Issue
    By csyperski in forum Installation
    Replies: 2
    Last Post: 05-23-2006, 06:35 AM
  3. Intermittent issue (issue# 5852) ?
    By nick20 in forum Installation
    Replies: 1
    Last Post: 02-08-2006, 02:47 PM
  4. Issue with recent version of rpmbuild
    By thomas_mangin in forum Developers
    Replies: 2
    Last Post: 10-25-2005, 09:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •