Results 1 to 7 of 7

Thread: Sent folder To & From headers

  1. #1
    swrightsls is offline Senior Member
    Join Date
    Feb 2009
    Location
    Shawnigan Lake, BC, Canada
    Posts
    66
    Rep Power
    6

    Default Sent folder To & From headers

    We are planning a migration of 650 accounts from a Mercury/Pegasus system to Zimbra using imapsync, but the Sent folder is not working as expected.

    Items in the Pegasus 'copies to self' folder are moved to the Zimbra 'Sent' folder using an imapsync regex, but once there, Zimbra shows the From header in the To column for each migrated message. New messages sent from within Zimbra display the correct To header value in the folder list. Comparing the message source between a migrated message to Sent vs one placed there by sending in Zimbra show no difference in the To/From headers or anything obvious, so I assume some magic is done in the db when sending a message that is not done when simply moving a message to Sent via imap.

    Is there some way to correct this?
    We're using ZCS 6.0beta2 OSS, although we are licensed for the NE - we are just waiting for the 6.0 NE to come out...

  2. #2
    fowler is offline Trained Alumni
    Join Date
    Jan 2009
    Location
    Fresno
    Posts
    31
    Rep Power
    6

    Default

    We have an opened ticket for this, but are using 5.0.16. After the imapsync, two users had their from header appear in the to field for the sent mail folder. What was more strange, is that the To header was properly shown for the first entry on the page. For the remaining 24, 49 or 99 entries, it reflected the from header. If you click forward to the next page of sent mail, the problem repeated itself. Can you confirm seeing the same thing? This only appears to be an issue for sync'd mail. Newly sent mail is behaving properly.

  3. #3
    swrightsls is offline Senior Member
    Join Date
    Feb 2009
    Location
    Shawnigan Lake, BC, Canada
    Posts
    66
    Rep Power
    6

    Default Confirmed - only first message in folder works

    I have checked again, and the behaviour you describe also applies to our ZCS 6.0 beta 2 OSS test server. Only the first migrated message of each 'page' in Sent shows the correct To header, the rest show From. But all messages sent from Zimbra and placed in 'Sent' display correctly.

    Have you had any indication of when this might be fixed? I wonder if I should also open a ticket...

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,484
    Rep Power
    56

    Default

    Quote Originally Posted by swrightsls View Post
    Have you had any indication of when this might be fixed? I wonder if I should also open a ticket...
    The Beta versions of Zimbra are only supported via the forums, you could check in bugzilla to see if this has been reported.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    fowler is offline Trained Alumni
    Join Date
    Jan 2009
    Location
    Fresno
    Posts
    31
    Rep Power
    6

    Default

    We have support case 00040422 opened for this and are running 5.0.16_GA_2921 (2009-05-01). This seems to describe it: Bug 28760 – 'To' field shows 'From' address in conversation view in 'Sent' folder
    Last edited by fowler; 07-10-2009 at 09:52 AM.

  6. #6
    swrightsls is offline Senior Member
    Join Date
    Feb 2009
    Location
    Shawnigan Lake, BC, Canada
    Posts
    66
    Rep Power
    6

    Default

    Quote Originally Posted by phoenix View Post
    The Beta versions of Zimbra are only supported via the forums, you could check in bugzilla to see if this has been reported.
    Yes, here it is:

    Bug 28760 – 'To' field shows 'From' address in conversation view in 'Sent' folder

    I've added my notes, since this is also confirmed on GA versions.

    *It seems we were adding to the bug at the same time... :-)

  7. #7
    swrightsls is offline Senior Member
    Join Date
    Feb 2009
    Location
    Shawnigan Lake, BC, Canada
    Posts
    66
    Rep Power
    6

    Default How to set 'sent by me' flag?

    Ok, no response on bugzilla yet, so I'll try here. We are now back to using 5.0.18 Network Edition since 6.0 isn't going to make it for our deployment timeline.

    On Bug 28760 – 'To' field shows 'From' address in conversation view in 'Sent' folder,

    Comments #20-23 on that page verify that the bug was reproducible. Dan Karp says
    "If you want the server to treat imported messages as "sent by me" -- and
    thus return the "t" addresses when you request recip:1 -- then you have to add
    them with the "s"ent by me flag on. We may want to tweak zmmailbox in this
    respect.

    ====
    So I asked:

    I am attempting to migrate all of our users via imapsync, and hope to a
    regexflag to set this 'sent by me' flag mentioned by Dan Karp, but it appears
    it is not settable via imap, as these are the flags listed:

    [PERMANENTFLAGS (\Answered \Deleted \Draft \Flagged \Seen $Forwarded $MDNSent
    Forwarded \*)]

    Please advise if there another way to achieve setting this "sent by me" flag
    for all messages placed in the sent folder via imapsync.
    =====

    This affects not only migrations from any other system, but also any imap clients used with ZCS, where mail placed in the sent folder will not appear the same as mail placed there using ZCS itself.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 'Couldn't access Yahoo! Zimbra Desktop server"
    By chirag1 in forum Error Reports
    Replies: 37
    Last Post: 06-12-2011, 05:14 PM
  2. Zimbra + Funambol Sync4j Code
    By KevinH in forum Mobility
    Replies: 563
    Last Post: 01-16-2010, 02:20 AM
  3. .pst migration issues
    By jimklein in forum Migration
    Replies: 13
    Last Post: 02-16-2009, 01:55 AM
  4. Error when Using Outlook PST Importer
    By chh in forum Zimbra Connector for Outlook
    Replies: 1
    Last Post: 01-19-2009, 05:20 AM
  5. Replies: 3
    Last Post: 08-11-2007, 12:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •