Hi guys, i just got a successful migration from 4.5.6 to 5.0.2, here are the steps i followed:

First my platform:

OS: Suse Enterprise Edition 10.1
Zimbra: Zimbra Open Source Edition 4.5.6

1st: Migration from 4.5.6 to 4.5.11

- Make sure you got the exact 4.5.11 version for your platform, download it and untar it on a directory

- For your old server make a zmcontrol stop

- Make sure all zimbra's processes are down by using

ps aw | grep zimbra to see the processes and kill 9 to kill them all

- Make sure anything is been sending on the smtp by using

netstat -a

search for any process that is using any of the mail ports, use

tcpkill to kill them or service network restart (this one works better)

- Stop any process on port 80 like apache (in my case it happends because i got an apache on http and zimbra on https)

- go to the zcs directory and execute ./install.sh it will check all pre-requisites and stuff installed, read carefully, and type yes on the upgrade option.

- after rpms are unpacked and configuration is saved, open another shell and type

chmod 640 /etc/sudoers (This prevents zimbra ldap to make error 256 while is starting)

- then go for a cup of coffee because many configurations are being done

- Finally upgrade is done and saved on many files, try to keep them because many cause of errors cold be founs in there (i found all my problems there :s)

- now do a zmcontrol start and see if all services starts

- check if you can access any email account and if this account can send and recieve mails

2nd Migrating from 4.5.11 to 5.0.2

- same as before:

- zmcontrol stop
- kill zimbra processes
- kill tcp connections

- go to zcs directory and execute ./install.sh

- it verifyes the same as the version before
- you say yes to upgrade option
- after rpms and saved configuration you:

chmod 640 /etc/sudoers

- and then another cup of coffee haha
- finaly you got all up runnung and saved, again save any file that zimbra told you on the instalation, it will save you tons of minutes looking for an inexact question in the forum :s

- again zmcontrol start

- and log into an account, you'll find out you got more functionality hahah

- send recieve mails, and check all works fine, calendars, your documents. etc

- finaly restart all services on port 80 (in my case apache)

and that's it, good luck with this one more thing make sure syslog is running in all process otherwise you will be prompted for an upgrade faliure message many times :s