did you try with "--authmech1 PLAIN" and "--authmech2 PLAIN" options?