Results 1 to 6 of 6

Thread: Amavisd going crazy - best way to restart it?

  1. #1
    Yann2 is offline Active Member
    Join Date
    May 2007
    Posts
    43
    Rep Power
    7

    Default Amavisd going crazy - best way to restart it?

    Hello,

    it seems that the antivirus just went crazy at 1pm today - it is using 100% of the cpu for nearly 3 hours now. What is the best way to restart it? I am not sure about just killing the process...

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Hi Yann-
    I'm sorry you're having difficulty. Have you tried restarting the clamd process, or bringing Zimbra down and restarting it?

    There is a known issue with clamav in 4.5.6, and you can find out more about the work around here:
    [SOLVED] Clamav problem ? What's happening ?

    Let me know if this helps. . if not, we can try some different stuff.

    Best,
    john

  3. #3
    Yann2 is offline Active Member
    Join Date
    May 2007
    Posts
    43
    Rep Power
    7

    Default

    I did :
    zimbra@mail:/home/yann$ zmamavisdctl restart

    But it didn't seem to help... I found this additional error:

    zimbra@mail:/home/yann$ zmantivirusctl restart
    /opt/zimbra/bin/zmantivirusctl start|stop|reload|status
    zimbra@mail:/home/yann$ zmantivirusctl reload
    Usage: /opt/zimbra/bin/zmmtaconfigctl start|stop|kill|restart|status
    Usage: /opt/zimbra/bin/zmamavisdctl start|stop|kill|restart|status
    Usage: /opt/zimbra/bin/zmclamdctl start|stop|kill|restart|status


    Then as root I tried a /etc/init.d/zimbra restarted which froze the complete system... I then logged in as zimbra and zmcontrol stop and startd, and it is up again, but I got 3 minutes of unwarned downtime /o\

    Concerning the post you refered before, I am running 4.5.6.1044, the timeout setting is on 120 already - should i put it on 180?

    [Edit] Btw, it is not the first time I encounter that reload/restart confusion in the CLI interface, I think other tools are also affected. I will check into bugzilla if there is already a bug filed for that

  4. #4
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Quote Originally Posted by Yann2 View Post
    I did :
    zimbra@mail:/home/yann$ zmamavisdctl restart

    But it didn't seem to help... I found this additional error:

    zimbra@mail:/home/yann$ zmantivirusctl restart
    /opt/zimbra/bin/zmantivirusctl start|stop|reload|status
    zimbra@mail:/home/yann$ zmantivirusctl reload
    Usage: /opt/zimbra/bin/zmmtaconfigctl start|stop|kill|restart|status
    Usage: /opt/zimbra/bin/zmamavisdctl start|stop|kill|restart|status
    Usage: /opt/zimbra/bin/zmclamdctl start|stop|kill|restart|status


    Then as root I tried a /etc/init.d/zimbra restarted which froze the complete system... I then logged in as zimbra and zmcontrol stop and startd, and it is up again, but I got 3 minutes of unwarned downtime /o\

    Concerning the post you refered before, I am running 4.5.6.1044, the timeout setting is on 120 already - should i put it on 180?

    [Edit] Btw, it is not the first time I encounter that reload/restart confusion in the CLI interface, I think other tools are also affected. I will check into bugzilla if there is already a bug filed for that
    Yeah-
    I'd increase it to 240.

    So are you still getting defferred mail?

  5. #5
    Yann2 is offline Active Member
    Join Date
    May 2007
    Posts
    43
    Rep Power
    7

    Default

    Just changed that value to 240. Which deferred messages are you speaking from? I had a problem with amavis using 100%^of the cpu

  6. #6
    mmorse's Avatar
    mmorse is offline Moderator
    Join Date
    May 2006
    Location
    USA
    Posts
    6,242
    Rep Power
    20

    Default

    Usually the cpu thing is related to the startup of clamav, it's a good idea to check your queue's because if you had any mail at that time it'll be in the deferred queue. Yes they'll eventually deliver on their own-but you might want to send them through now instead of waiting.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 12
    Last Post: 02-24-2008, 12:16 AM
  2. Building SVN for CentOS 4.4 (mysql)
    By GrepACE in forum Developers
    Replies: 3
    Last Post: 12-29-2006, 10:54 PM
  3. amavisd logs
    By Storm16 in forum Administrators
    Replies: 0
    Last Post: 11-09-2006, 09:25 AM
  4. Extremely High Memory Usage for Amavisd
    By atomicfission in forum Installation
    Replies: 4
    Last Post: 10-02-2006, 02:23 PM
  5. /dev/shm full due to amavisd
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 09-21-2006, 01:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •