Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: zimbra e la pec

  1. #1
    maumar is offline Elite Member
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    8

    Default zimbra e la pec

    In teoria ci si potrebbe riuscire usando il:

    Configuring Sender-Dependent SASL authentication


    tuttavia io sto avendo problemi di questo tipo:

    Code:
    postfix/smtp[26647]: CLIENT wrappermode (port smtps/465) is unimplemented
    ho un account aruba e aruba accetta solo 465, non 587; con 587 zimbra e' felice di spedire, con il 465 no

  2. #2
    maumar is offline Elite Member
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    8

    Default

    anche usando stunnel:


    Postfix TLS Support

    continua da avere problemi:
    Code:
    Aug  6 15:12:30 webmail postfix/smtp[20687]: 73AFE3C0A4F: to=<cost@pec.aruba.it>, relay=127.0.0.1[127.0.0.1]:10024, delay=16, delays=0.04/0/0.01/16, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=21161-02, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 0DD2D3C0A63)
    Aug  6 15:12:30 webmail postfix/qmgr[26636]: 73AFE3C0A4F: removed
    Aug  6 15:12:30 webmail postfix/smtp[21855]: 0DD2D3C0A63: to=<cost@pec.aruba.it>, relay=127.0.0.1[127.0.0.1]:11125, delay=0.08, delays=0.01/0.03/0.04/0, dsn=4.4.2, status=deferred (lost connection with 127.0.0.1[127.0.0.1] while receiving the initial server greeting)

    il telnet e' ok:


    Code:
    telnet 127.0.0.1 11125
    Trying 127.0.0.1...
    Connected to localhost.localdomain (127.0.0.1).
    Escape character is '^]'.
    220 smtps.pec.aruba.it ESMTP Postfix
    helo webmail.cost.it
    250 smtps.pec.aruba.it

  3. #3
    maxxer's Avatar
    maxxer is offline Trained Alumni
    Join Date
    Feb 2009
    Location
    Lecco, Italy
    Posts
    553
    Rep Power
    7

    Default

    interessante, ci guarderò!
    ma hai configurato l'account PEC come aggiuntivo all'account Zimbra?
    YetOpen S.r.l. ~ Your open source partner
    Lecco (LC) - ITALY
    http://www.yetopen.it

  4. #4
    maumar is offline Elite Member
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    8

    Default

    si, ho un primary account:

    quacosa @ apservice.biz

    e come external e come secondary:
    apservice at pec.cost.it



    ho fatto un po' di lavori, in parte li trovi documentati qua:

    Sono a un punto morto: aruba non mi accetta in submission, altrimenti avrei risolto

  5. #5
    anteos's Avatar
    anteos is online now Project Contributor
    Join Date
    Jun 2006
    Location
    Italy
    Posts
    56
    Rep Power
    9

    Default

    Noi avevamo provato questa soluzione e funzionava anche con Aruba, farò verificare se è cambiato qualcosa nel frattempo. Il problema di questa soluzione è che obbliga a salvare la password della casella PEC, in chiaro, in un file; questo va ad inficiare tutto il sistema di trusting per garantire la validità legale della PEC.....

    Bisognerebbe fare una zimlet che chiada la pwd al momento dell'invio di una email pec.
    Stefano Pampaloni
    www.seacom.it

  6. #6
    maumar is offline Elite Member
    Join Date
    Mar 2007
    Location
    Small village in the center of Italy
    Posts
    350
    Rep Power
    8

    Default

    io mi sono rifatto a questa pagina:
    se poi esiste un server ArubaPec che accetta submission sulla 587...non lo so proprio

    X il problema della password, si, in effetti nella conf di postfix e' in chiaro, sadly..

  7. #7
    maxxer's Avatar
    maxxer is offline Trained Alumni
    Join Date
    Feb 2009
    Location
    Lecco, Italy
    Posts
    553
    Rep Power
    7

    Default

    sei poi riuscito? a breve dovrei fare delle prove anche io...
    ciao grazie
    YetOpen S.r.l. ~ Your open source partner
    Lecco (LC) - ITALY
    http://www.yetopen.it

  8. #8
    maxxer's Avatar
    maxxer is offline Trained Alumni
    Join Date
    Feb 2009
    Location
    Lecco, Italy
    Posts
    553
    Rep Power
    7

    Default

    Quote Originally Posted by maumar View Post
    si, ho un primary account:

    quacosa @ apservice.biz

    e come external e come secondary:
    apservice at pec.cost.it



    ho fatto un po' di lavori, in parte li trovi documentati qua
    sto provando a configurare la PEC come account esterno in Zimbra, ma mi incaglio ben prima.
    Diciamo che la configurazione di postfix dovrebbe esserci, perché dall'account spedisce verso l'SMTP corretto. Il problema è che come facevi notare tu, Zimbra spedisce la mail con l'indirizzo email dell'account principale, quindi l'smtp me la rimbalza.

    Code:
    Oct 14 10:35:32 quaglia postfix/smtp[10395]: 90D732138A: to=<test@pec.yetopen.it>, relay=127.0.0.1[127.0.0.1]:11465, delay=335, delays=334/0/0.46/0.22, dsn=5.7.1, status=bounced (host 127.0.0.1[127.0.0.1] said: 553 5.7.1 <testpec@yetopen.it>: Sender address rejected: not owned by user test@pec.yetopen.it (in reply to RCPT TO command))
    Sei poi andato avanti?
    Ciao, grazie
    YetOpen S.r.l. ~ Your open source partner
    Lecco (LC) - ITALY
    http://www.yetopen.it

  9. #9
    enrico.lorenzoni is offline Junior Member
    Join Date
    Dec 2011
    Posts
    7
    Rep Power
    3

    Default

    salve a tutti, dopo un pomeriggio sono riuscito con twt, penso che con aruba sia lo stesso visto che ricevevo il messaggio lost connection ecc

    ecco i settaggi giusti

    ---- stunnel.conf ----

    [smtp-tls-wrapper]
    accept = 127.0.0.1:11125
    client = yes
    connect = mail.twtcert.it:smtps


    --- main.cf -----

    smtp_sender_dependent_authentication = yes
    sender_dependent_relayhost_maps = hash:/opt/zimbra/conf/relayhost_map
    smtp_sasl_auth_enable = yes
    smtp_sasl_security_options =
    smtp_sasl_mechanism_filter = login
    smtp_sasl_password_maps = hash:/opt/zimbra/conf/relay_password

    [...]


    ---- relayhost_map -----

    test@dominiopec.it 127.0.0.1:11125

    ---- relay_password -----

    test@dominiopec.it test@dominiopec.itassword


    ----------------------------

    in particolare la differenza con cio` che leggevo in giro e` la riga

    smtp_sasl_mechanism_filter = login

    fatemi sapere se riuscite cosi` o vi servono piu` dettagli.

  10. #10
    BigGeorge is offline Member
    Join Date
    Mar 2013
    Posts
    13
    Rep Power
    2

    Default

    Ciao a tutti!
    Siete riusciti a risolvere il problema?
    Sto cercando di configurare il tutto su Zimbra 8.0.3 e sarebbe di conforto avere qualche riscontro positivo

    Grazie!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra Admin Interface issue
    By Jack_Redington in forum Administrators
    Replies: 9
    Last Post: 08-04-2012, 04:51 AM
  2. Old Backup stay in TO_DELETE status and no clearing..
    By bartounet in forum Administrators
    Replies: 0
    Last Post: 10-05-2010, 07:40 AM
  3. [SOLVED] Clamav problem ? What's happening ?
    By aNt1X in forum Installation
    Replies: 23
    Last Post: 02-14-2008, 05:43 AM
  4. Can't start Zimbra!
    By zibra in forum Administrators
    Replies: 5
    Last Post: 03-22-2007, 11:34 AM
  5. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •