Results 1 to 7 of 7

Thread: $DSPAM Variable in 4.5.6

  1. #1
    hlribeiro is offline Project Contributor
    Join Date
    Feb 2007
    Location
    Maringá, PR, Brasil
    Posts
    67
    Rep Power
    8

    Default $DSPAM Variable in 4.5.6

    Hi,

    I've updated today from 4.5.5GA to 4.5.6GA, all went as expected. When I was reactivating DSPAM (I think there is no performance problems for me), I realized that the new zmtrainsa script now "test" $DSPAM variable (I'm not exactly sure, don't understand shell script 100%), and run the dspam portion if necessary:

    Code:
      if [ x"$DSPAM" = "xenabled" ]; then
        echo "Training DSPAM"
        if [ $MODE == "ham" ]; then
                MODE="innocent"
        fi
    
        ${zimbra_home}/dspam/bin/dspam --user zimbra --class=${MODE} --source=corpus --mode=teft \
          --feature=chained,noise --stdout
    
        ${zimbra_home}/dspam/bin/dspam_clean -p0 $USER
      fi
    The problem is that I ran zmtrainsa with no parameters, and the script have just ignored the dspam part. I have already uncommented dspam path in amavisd.conf.in and restarted amavisd. What can be wrong?

    Thanks


    PS: Sorry for my english, I didn't speak so much.
    hugo ribeiro

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Can you paste your output? Also, the spamtrain log would be helpful.

  3. #3
    hlribeiro is offline Project Contributor
    Join Date
    Feb 2007
    Location
    Maringá, PR, Brasil
    Posts
    67
    Rep Power
    8

    Default

    Sorry for the late reply

    from zmtrainsa:

    [zimbra@mail ~]$ zmtrainsa
    [] INFO: Total messages processed: 11
    [] INFO: Total messages processed: 0
    netset: illegal network address given: '192.168.76.0/23,'
    netset: illegal network address given: '127.0.0.0/8,'
    Learned from 11 message(s) (11 message(s) examined).
    netset: illegal network address given: '192.168.76.0/23,'
    netset: illegal network address given: '127.0.0.0/8,'
    Learned from 0 message(s) (0 message(s) examined).
    netset: illegal network address given: '192.168.76.0/23,'
    netset: illegal network address given: '127.0.0.0/8,'
    bayes: synced databases from journal in 2 seconds: 5646 unique entries (8033 total entries)
    [zimbra@mail ~]$

    You will find that there are only few dspam lines in the attached logfile, but this is normal. I had it running just a few days before upgrade to 4.5.6. Aditionally, I found a strange thing on the log: the last 2 entries are from 4.5.6 already, so the last 4.5.5 entry was this:

    bayes: synced databases from journal in 4 seconds: 13753 unique entries (13753 total entries)

    And the first 4.5.6:

    bayes: synced databases from journal in 0 seconds: 446 unique entries (790 total entries)

    What happened to the "old" database? Cleaned?
    Sorry, I know that is another question, but is in the same log
    Attached Files Attached Files
    hugo ribeiro

  4. #4
    hlribeiro is offline Project Contributor
    Join Date
    Feb 2007
    Location
    Maringá, PR, Brasil
    Posts
    67
    Rep Power
    8

    Default

    Just for information, I filled a bug in bugzilla suggesting add timestamps to the spamtrain.log file. I found nothing about this on bugzilla, but already saw people complaining about

    Bug 18084 - add timestamps to spamtrain.log
    hugo ribeiro

  5. #5
    hlribeiro is offline Project Contributor
    Join Date
    Feb 2007
    Location
    Maringá, PR, Brasil
    Posts
    67
    Rep Power
    8

    Unhappy Anyone?

    Anyone please?

    I just want to know where the related $DSPAM variable used in the new zmtrainsa is set.
    hugo ribeiro

  6. #6
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    I swear I replied to this thread.

    Sorry!

    Can you file a bug, and say that zmtrainsa isn't learning from dspam when it's enabled?

    Be sure to cc me on it.

    Thanks
    john

  7. #7
    hlribeiro is offline Project Contributor
    Join Date
    Feb 2007
    Location
    Maringá, PR, Brasil
    Posts
    67
    Rep Power
    8

    Default

    Done!

    Bug 18153 - zmtrainsa not learning from dspam when it's enabled

    I hope that can be resolved soon

    Thanks
    hugo ribeiro

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Upgrading from 4.0.0 RC1 to 4.5.6 GA
    By richard-hdd in forum Installation
    Replies: 2
    Last Post: 08-08-2007, 07:25 AM
  2. 4.5.6 Upgrade Results
    By LMStone in forum Installation
    Replies: 5
    Last Post: 07-08-2007, 11:36 PM
  3. upgrade to 4.5.6 failed
    By dmore73 in forum Installation
    Replies: 1
    Last Post: 07-03-2007, 01:26 AM
  4. ZCS 4.5.6 Has Been Released
    By jholder in forum Announcements
    Replies: 1
    Last Post: 06-28-2007, 06:45 PM
  5. 4.5.6 Release Timetable?
    By LMStone in forum Administrators
    Replies: 1
    Last Post: 06-26-2007, 03:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •