Results 1 to 5 of 5

Thread: Best way to move users from old Zimbra to Zimbra new machine

  1. #1
    bobway54 is offline New Member
    Join Date
    May 2007
    Posts
    3
    Rep Power
    8

    Default Best way to move users from old Zimbra to Zimbra new machine

    I need to move my Zimbra users and email from an old server running ZCS 4.5.5 OS on Fedora Core 5 to a new server running ZCS 4.5.5 OS on Centos 5 (thanks for the install guide demminal ).

    The reason for the move is the FC5 server randomly locks up and we have to do a hard reboot then a normal shutdown and restart to get it working. I think it is a hardware issue but can't pinpoint it. The logs show nothing relating to it. It locked up during install but seemed to straighten out for a while but now the lock ups come daily.

    Anyway I digress. My new machine installed with Centos 5 went without a hitch and I would like to move all of my configs, users etc. to the new one. Can I do it by a backup and restore? Or do I do an export / import scenario?

    I've gotten a headache reading all of the available stuff in the forums and wiki and still can't decide which way to go. I seached for "move Zimbra to new server" and it didn't return anything so I've been reading the "backup and restore" threads which if I were using the same OS on the new one would be a no brainer but since it's different hence the apprension

    Any suggestion or pointers would be greatly appreciated.

    Thanks
    Last edited by bobway54; 06-17-2007 at 12:23 PM. Reason: Ignore, I was in the wrong forum. Sorry bout that!

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Welcome to the forums.

    Backup the /opt/zimbra directory on your current server (check the gid & uid of zimbra and make a note of it) then disconnect it from your LAN. Install the same release on the new Zimbra server as you had on the old server, make sure it's all working the shutdown zimbra and copy the backup-up files from your old server to the new one, make sure the uid & gid is changed to the ones you had on the old server - run zmfixperms and also make sure the LDAP password is set (check the wiki or forum for details). Do an upgrade install on the new server and you should be good to go. I'm assuming that your new server will have the same IP & FQDN as the old server. That should be about it.
    Last edited by phoenix; 06-17-2007 at 12:48 PM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    bobway54 is offline New Member
    Join Date
    May 2007
    Posts
    3
    Rep Power
    8

    Default thanks

    Thanks for reply even though I posted in the wrong forum.

    Yes everything from fqdn to IP address is exactly the same. The only change was the OS.

    I will do this and let you know the out come in a later post.

    Thanks again,
    Bob

  4. #4
    fajarpri's Avatar
    fajarpri is offline Loyal Member
    Join Date
    Jul 2007
    Posts
    98
    Rep Power
    8

    Red face

    Hello Bob,
    How was the backup and restore process?
    Was it successful? Was there any pitfall that we should be aware of?
    Thanks.

  5. #5
    bobway54 is offline New Member
    Join Date
    May 2007
    Posts
    3
    Rep Power
    8

    Default

    Sorry for the delay in getting back to you all. I've been on the road the last few weeks and got behind in my email.

    Unfortunately it didn't work. All of the users and settings restored but the it wouldn't deliver any incoming mail to the users. Sending was fine though. I couldn't figure out what was causing it.

    So we took down the new server and plugged the old one back in. I uninstalled ZCS and then changed the name and IP address of the new server. I then plugged it back back into the network, setup my internal DNS server to reflect the new names needed for the server and reloaded ZCS. We then manually entered each user then used fetchmail in the ZCS web client to download the users inbox. Next we set up a Thunderbird profile for each user and set up the old sever and new server on IMAP. We then copied each users folders from the old server to the new server using the T-bird profiles.

    I tried to use IMAPsync to do this but I couldn't get it to work.
    I'm an intermediate user of Linux so I'm lousy with syntax and command line parameters.

    I do this email server as a hobby for a friend who has a 25-30 employee real estate office. My full time job is designing electronic and physical security and access control systems for banks and financial institutions.

    After the transfer to new hardware, we haven't had any more issues and everyone loves it. We had been using Scalix before this and it got to be a full time job keeping it running. And since I don't do this full time, we needed to find a more reliable email server.

    My commendations to the Zimbra team for making such a useful product.

    Thanks,
    Bob

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. QUE Failure
    By tbullock in forum Administrators
    Replies: 31
    Last Post: 07-30-2008, 12:17 PM
  2. Replies: 16
    Last Post: 09-07-2006, 06:39 AM
  3. Zimbra server crashed
    By goetzi in forum Administrators
    Replies: 6
    Last Post: 03-25-2006, 01:00 PM
  4. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 10:47 AM
  5. FC3 Install and no zimbra ?
    By aws in forum Installation
    Replies: 10
    Last Post: 10-09-2005, 04:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •