Results 1 to 3 of 3

Thread: Installation problem on Debian 4.0

  1. #1
    gaijin is offline Starter Member
    Join Date
    May 2007
    Posts
    2
    Rep Power
    7

    Default Installation problem on Debian 4.0

    Hello,

    I'm trying to install a Zimbra (latest version) on a Dedian 4.0 freshly installed in a vmware.
    But when running, the install script I've :

    could not stat config file "/opt/zimbra/conf/slapd.conf": No such file or directory (2)
    slapcat: bad configuration file!


    and finally :
    Starting ldap...Done
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)


    It seems ldap is not started at this point...
    I've tried everything posted on this forum,...

    Someone have an idea on why ldap does not start properly ?

    Best regards

    Following, the complete install script output :
    zimbra:~/zcs# sh install.sh

    Operations logged to /tmp/install.log.3367
    Checking for existing installation...
    zimbra-ldap...FOUND zimbra-ldap-4.5.5_GA_838.DEBIAN3.1
    zimbra-logger...FOUND zimbra-logger-4.5.5_GA_838.DEBIAN3.1
    zimbra-mta...FOUND zimbra-mta-4.5.5_GA_838.DEBIAN3.1
    zimbra-snmp...FOUND zimbra-snmp-4.5.5_GA_838.DEBIAN3.1
    zimbra-store...FOUND zimbra-store-4.5.5_GA_838.DEBIAN3.1
    zimbra-apache...FOUND zimbra-apache-4.5.5_GA_838.DEBIAN3.1
    zimbra-spell...FOUND zimbra-spell-4.5.5_GA_838.DEBIAN3.1
    zimbra-core...FOUND zimbra-core-4.5.5_GA_838.DEBIAN3.1

    Saving existing configuration file to /opt/zimbra/.saveconfig


    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

    License Terms for the Zimbra Collaboration Suite:
    http://www.zimbra.com/license/collab...cense_1.0.html


    Press Return to continue

    Checking for prerequisites...
    NPTL...FOUND
    sudo...FOUND sudo-1.6.8p12-4
    libidn11...FOUND libidn11-0.6.5-1
    curl...FOUND curl-7.15.5-1
    fetchmail...FOUND fetchmail-6.3.6-1
    libpcre3...FOUND libpcre3-6.7-1
    libgmp3c2...FOUND libgmp3c2-2:4.2.1+dfsg-4
    libexpat1...FOUND libexpat1-1.95.8-3.4
    libxml2...FOUND libxml2-2.6.27.dfsg-1
    libstdc++6...FOUND libstdc++6-4.1.1-21
    libstdc++5...FOUND libstdc++5-1:3.3.6-15
    openssl...FOUND openssl-0.9.8c-4
    Checking for required space...

    Checking for installable packages

    Found zimbra-core
    Found zimbra-ldap
    Found zimbra-logger
    Found zimbra-mta
    Found zimbra-snmp
    Found zimbra-store
    Found zimbra-apache
    Found zimbra-spell


    The Zimbra Collaboration Suite appears already to be installed.
    It can be upgraded with no effect on existing accounts,
    or the current installation can be completely removed prior
    to installation for a clean install.

    Do you wish to upgrade? [Y]

    Select the packages to install
    Upgrading zimbra-core
    Upgrading zimbra-ldap
    Upgrading zimbra-logger
    Upgrading zimbra-mta
    Upgrading zimbra-snmp
    Upgrading zimbra-store
    Upgrading zimbra-apache
    Upgrading zimbra-spell
    Installing:
    zimbra-core
    zimbra-ldap
    zimbra-logger
    zimbra-mta
    zimbra-snmp
    zimbra-store
    zimbra-apache
    zimbra-spell

    The system will be modified. Continue? [N] Y

    Shutting down zimbra mail

    Backing up ldap

    could not stat config file "/opt/zimbra/conf/slapd.conf": No such file or directory (2)
    slapcat: bad configuration file!

    Removing existing packages
    zimbra-ldap...done
    zimbra-logger...done
    zimbra-mta...done
    zimbra-snmp...done
    zimbra-store...done
    zimbra-spell...done
    zimbra-apache...done
    zimbra-core...done

    Removing deployed webapp directories
    Installing packages

    zimbra-core......zimbra-core_4.5.5_GA_838.DEBIAN3.1_i386.deb...done
    zimbra-ldap......zimbra-ldap_4.5.5_GA_838.DEBIAN3.1_i386.deb...done
    zimbra-logger......zimbra-logger_4.5.5_GA_838.DEBIAN3.1_i386.deb...done
    zimbra-mta......zimbra-mta_4.5.5_GA_838.DEBIAN3.1_i386.deb...done
    zimbra-snmp......zimbra-snmp_4.5.5_GA_838.DEBIAN3.1_i386.deb...done
    zimbra-store......zimbra-store_4.5.5_GA_838.DEBIAN3.1_i386.deb...done
    zimbra-apache......zimbra-apache_4.5.5_GA_838.DEBIAN3.1_i386.deb...done
    zimbra-spell......zimbra-spell_4.5.5_GA_838.DEBIAN3.1_i386.deb...done

    Setting defaults from saved config in /opt/zimbra/.saveconfig/config.save
    HOSTNAME=zimbra.caciis.net
    LDAPHOST=
    LDAPPORT=
    SNMPTRAPHOST=
    SMTPSOURCE=
    SMTPDEST=
    SNMPNOTIFY=0
    SMTPNOTIFY=0
    LDAPROOTPW=zimbra
    LDAPZIMBRAPW=zimbra
    Restoring existing configuration file from /opt/zimbra/.saveconfig/config.save...done
    chown: ne peut accéder `/opt/zimbra/tomcat/conf/keystore': Aucun fichier ou répertoire de ce type
    chown: ne peut accéder `/opt/zimbra/conf/smtpd.key': Aucun fichier ou répertoire de ce type
    chown: ne peut accéder `/opt/zimbra/conf/smtpd.crt': Aucun fichier ou répertoire de ce type
    chown: ne peut accéder `/opt/zimbra/conf/slapd.crt': Aucun fichier ou répertoire de ce type
    chown: ne peut accéder `/opt/zimbra/conf/perdition.pem': Aucun fichier ou répertoire de ce type
    chown: ne peut accéder `/opt/zimbra/conf/perdition.key': Aucun fichier ou répertoire de ce type
    Operations logged to /tmp/zmsetup.log.6570
    Starting ldap...Done
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    Setting defaults...Done
    Setting defaults from existing config...Warning: null valued key 'mysql_logger_root_password'
    Upgrading from to 4.5.5_GA_838
    Stopping zimbra services
    Stop failed - exiting
    UPGRADE FAILED - exiting
    Last edited by gaijin; 05-23-2007 at 09:07 AM. Reason: complete install log

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    You do realise that you're installing Zimbra on the wrong (and unsupported) version of Debian, don't you?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    DVan is offline Active Member
    Join Date
    Mar 2007
    Posts
    44
    Rep Power
    8

    Default

    LDAP isn't running becuase you do not have a configuration file for it.

    Normally there should be a slapd.conf and a slapd.conf.in in your /opt/zimbra/conf folder

    The other issue is your configuration file for zimbra seems to be missing all of the LDAP settings normally these would be set to something like:

    Code:
    ldap_host='yourhost.domain.com'
    ldap_is_master='true'
    ldap_log_level='0'
    ldap_master_url='ldap://yourhost.domain.com:389'
    ldap_port='389'
    ldap_root_password='$password$'
    ldap_url='ldap://yourhost.domain.com:389'
    This would be in the master zimbra config file you should be able to see the backup of this in /opt/zimbra/.saveconfig/config.save

    You may want to manually set the LDAP host and port when you run the install.sh installation script and that might fix it. Other wise you might want to edit the config.save file add those above lines modified for your specific hostname and LDAP password try to edit the current config.#### file in your opt/zimbra/conf folder.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. INSTALLATION PROBLEM ON Centos 4.3 x_86-64Bit.
    By jawad@cogilent.com in forum Installation
    Replies: 11
    Last Post: 07-09-2007, 08:09 AM
  2. Debian Installation Problem
    By l-deep in forum Installation
    Replies: 6
    Last Post: 05-06-2006, 03:42 AM
  3. Replies: 1
    Last Post: 02-17-2006, 07:59 PM
  4. Installation problem
    By sywong70 in forum Installation
    Replies: 5
    Last Post: 11-07-2005, 09:01 PM
  5. Installation problem
    By charlie in forum Administrators
    Replies: 1
    Last Post: 10-14-2005, 08:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •