Results 1 to 3 of 3

Thread: Can't Deploy Zimlets after upgrade to 4.5.5

  1. #1
    ajsp's Avatar
    ajsp is offline Junior Member
    Join Date
    Sep 2006
    Posts
    5
    Rep Power
    8

    Default Can't Deploy Zimlets after upgrade to 4.5.5

    Hello I just upgraded from 4.5.2 to 4.5.5. The installation was successful minus an error about initializing documents. But I can't for the life of me get new zimlets to work properly.

    I have read through the forums and restarted tomcat (and the set of processes'). Attempted zmzimletctl deploy /opt/zimbra/zimlets-extra/com_zimbra_bugz.zip . I have also done it the long way as described in the manual ( install; ldapDeploy ; acl ; enable ). I will say that gets me much further than deploy which just says this:

    zimbra@love:~/zimlets-extra> zmzimletctl deploy com_zimbra_bugz.zip
    [] INFO: Deploying on blah.blah.blah
    Error: system failure: Unable to deploy Zimlet com_zimbra_bugz.zip on blah.blah.blah

    Undeploy gives basically the same error, but with 'undeploy'.

    I can see the zimlet in the list

    Installed Zimlet files on this host:
    com_zimbra_arcade
    com_zimbra_bugz
    com_zimbra_date
    com_zimbra_email
    com_zimbra_phone
    com_zimbra_photo
    com_zimbra_search
    com_zimbra_tracking
    com_zimbra_travelagent
    com_zimbra_url
    com_zimbra_wikipedia
    Installed Zimlets in LDAP:
    com_zimbra_amzn
    com_zimbra_arcade
    com_zimbra_bugz
    com_zimbra_date
    com_zimbra_email
    com_zimbra_evite
    com_zimbra_phone
    com_zimbra_photo
    com_zimbra_po
    com_zimbra_search
    com_zimbra_sforce
    com_zimbra_tracking
    com_zimbra_travelagent
    com_zimbra_url
    com_zimbra_wikipedia
    com_zimbra_xslt
    com_zimbra_ymaps
    Available Zimlets in COS:
    default:
    com_zimbra_amzn
    com_zimbra_arcade
    com_zimbra_bugz
    com_zimbra_date
    com_zimbra_email
    com_zimbra_evite
    com_zimbra_phone
    com_zimbra_photo
    com_zimbra_po
    com_zimbra_search
    com_zimbra_sforce
    com_zimbra_tracking
    com_zimbra_travelagent
    com_zimbra_url
    com_zimbra_wikipedia
    com_zimbra_xslt
    com_zimbra_ymaps

    But for some reason when I login I don't see the zimlets in the zimlet list.

    The only two that I was able to get to work were arcade, and wikipedia. Any help would be really appreciated! Thanks again for the great work!

    Release 4.5.5_GA_838.SuSE10_20070503170511 SuSE10 FOSS edition

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Hi and Welcome to the forums.
    There is a bug which causes "extra" zimlets to be undeployed upon and upgrade. You typically have to redeploy them.

    Of course, that's where you issue is.

    When ever a user logs in, the zimlets are loaded and logged. Also, if you perform any activity regarding deploying/undeploying zimlets, that is also logged.

    Take a look at /opt/zimbra/mailbox.log -
    In particular look for when a user is logging in.

    What's the error?

    (Thanks for the kind words. We appreciate that!)

  3. #3
    ajsp's Avatar
    ajsp is offline Junior Member
    Join Date
    Sep 2006
    Posts
    5
    Rep Power
    8

    Default :)

    Ahhh that is where it gets logged... . Sure enough this is what I get after a fresh login

    2007-05-17 10:15:58,102 INFO [http-80-Processor96] [mid=2;ua=ZimbraWebClient - FF2.0 (Win)/4.5.5_GA_838.SuSE10;ip=1.1.1.1;name=someone@somewh ere.net;] zimlet - Zimlet not found: /opt/zimbra/tomcat/webapps/service/zimlet/com_zimbra_amzn
    2007-05-17 10:15:58,115 INFO [http-80-Processor96] [mid=2;ua=ZimbraWebClient - FF2.0 (Win)/4.5.5_GA_838.SuSE10;ip=1.1.1.1;name=someone@somewh ere.net;] zimlet - Zimlet not found: /opt/zimbra/tomcat/webapps/service/zimlet/com_zimbra_po
    2007-05-17 10:15:58,122 INFO [http-80-Processor96] [mid=2;ua=ZimbraWebClient - FF2.0 (Win)/4.5.5_GA_838.SuSE10;ip=1.1.1.1;name=someone@somewh ere.net;] zimlet - Zimlet not found: /opt/zimbra/tomcat/webapps/service/zimlet/com_zimbra_sforce
    2007-05-17 10:15:58,124 INFO [http-80-Processor96] [mid=2;ua=ZimbraWebClient - FF2.0 (Win)/4.5.5_GA_838.SuSE10;ip=1.1.1.1;name=someone@somewh ere.net;] zimlet - Zimlet not found: /opt/zimbra/tomcat/webapps/service/zimlet/com_zimbra_ymaps
    2007-05-17 10:15:58,132 INFO [http-80-Processor96] [mid=2;ua=ZimbraWebClient - FF2.0 (Win)/4.5.5_GA_838.SuSE10;ip=1.1.1.1;name=someone@somewh ere.net;] zimlet - Zimlet not found: /opt/zimbra/tomcat/webapps/service/zimlet/com_zimbra_xslt
    2007-05-17 10:15:58,152 INFO [http-80-Processor96] [mid=2;ua=ZimbraWebClient - FF2.0 (Win)/4.5.5_GA_838.SuSE10;ip=1.1.1.1;name=someone@somewh ere.net;] zimlet - Zimlet not found: /opt/zimbra/tomcat/webapps/service/zimlet/com_zimbra_evite
    2007-05-17 10:15:58,171 INFO [http-80-Processor96] [mid=2;ua=ZimbraWebClient - FF2.0 (Win)/4.5.5_GA_838.SuSE10;ip=1.1.1.1;name=someone@somewh ere.net;] zimlet - cannot find zimlet com_zimbra_xslt
    2007-05-17 10:15:58,214 INFO [http-80-Processor96] [mid=2;ua=ZimbraWebClient - FF2.0 (Win)/4.5.5_GA_838.SuSE10;ip=1.1.1.1;name=someone@somewh ere.net;] zimlet - cannot find zimlet com_zimbra_evite
    2007-05-17 10:15:58,229 INFO [http-80-Processor96] [mid=2;ua=ZimbraWebClient - FF2.0 (Win)/4.5.5_GA_838.SuSE10;ip=1.1.1.1;name=someone@somewh ere.net;] zimlet - cannot find zimlet com_zimbra_amzn
    2007-05-17 10:15:58,240 INFO [http-80-Processor96] [mid=2;ua=ZimbraWebClient - FF2.0 (Win)/4.5.5_GA_838.SuSE10;ip=1.1.1.1;name=someone@somewh ere.net;] zimlet - cannot find zimlet com_zimbra_po
    2007-05-17 10:15:58,241 INFO [http-80-Processor96] [mid=2;ua=ZimbraWebClient - FF2.0 (Win)/4.5.5_GA_838.SuSE10;ip=1.1.1.1;name=someone@somewh ere.net;] zimlet - cannot find zimlet com_zimbra_sforce
    2007-05-17 10:15:58,241 INFO [http-80-Processor96] [mid=2;ua=ZimbraWebClient - FF2.0 (Win)/4.5.5_GA_838.SuSE10;ip=1.1.1.1;name=someone@somewh ere.net;] zimlet - cannot find zimlet com_zimbra_ymaps

    The contents of /opt/zimbra/tomcat/webapps/service/zimlet

    .
    ..
    com_zimbra_arcade
    com_zimbra_bugz
    com_zimbra_date
    com_zimbra_email
    com_zimbra_phone
    com_zimbra_photo
    com_zimbra_search
    com_zimbra_tracking
    com_zimbra_travelagent
    com_zimbra_url
    com_zimbra_wikipedia

    So that makes sense to me since all of the zimlets it is complaining about are not actually there! I should probably just admit that I am not a hundred percent but I would assume that travelagent and bugz would have list elements in the zimlets list to be acted upon (in the user view)?

    Thanks again!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 06-11-2007, 06:30 PM
  2. where are my zimlets ?
    By santo in forum Zimlets
    Replies: 21
    Last Post: 06-05-2007, 07:30 AM
  3. Upgrade from Zimbra 3.1.3 to Latest edition (4.5.5)
    By jeemeekay in forum Administrators
    Replies: 1
    Last Post: 05-16-2007, 03:55 AM
  4. Upgrade (4.5.4 to 4.5.5)
    By SpEnTBoY in forum Zimbra Success Stories
    Replies: 0
    Last Post: 05-14-2007, 06:43 AM
  5. Upgrade 4.5.4 to 4.5.5 questions
    By dlochart in forum Zimbra Connector for Outlook
    Replies: 11
    Last Post: 05-14-2007, 02:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •