Results 1 to 5 of 5

Thread: zmlogprocess error on aggregates

  1. #1
    hlandgar is offline Junior Member
    Join Date
    Apr 2007
    Posts
    9
    Rep Power
    8

    Angry zmlogprocess error on aggregates

    I am running debian OSS 4.54
    zmlogprocess is inserting data into mta but nothing is being inserted into mta_aggregate.

    zmlogprocess is showing errors about host being NULL.

    I have already rm -rf logger/db and run zmloggerinit.

    zmmsgtrace works but daily reports show no activity.

  2. #2
    hlandgar is offline Junior Member
    Join Date
    Apr 2007
    Posts
    9
    Rep Power
    8

    Default This is the output of zmlogprocess

    zimbra@localhost:~$ libexec/zmlogprocess
    Pruning service/server entries older then 2007-04-18 21:31:43
    Processing mta entries from 475
    Found 10 messages
    Inserted 10 rows
    Saving ID 697
    Deleting processed postfix logs from raw_logs...Done
    Processing clamd entries from 558
    Found 1 entries
    Saving ID 666
    Deleting processed clamd logs from raw_logs...Done
    Processing amavis entries from 555
    Found 8 entries
    Saving ID 693
    Deleting processed amavis logs from raw_logs...Done
    Processing sendmail entries from 0
    Found 0 entries
    Deleting processed sendmail logs from raw_logs...Done
    Processing zimbramon entries from 206
    Found 0 entries
    Deleting processed zimbramon logs from raw_logs...Done
    Aggregating hour mta from 2007-04-18 20:00:00 to 2007-04-18 21:00:00
    Found 30 messages for localhost
    Found 202094 bytes for localhost
    DBD::mysql::st execute failed: Column 'host' cannot be null at libexec/zmlogprocess line 1020.
    Error executing insert into mta_aggregate (period_start, period_end, host, period, msg_count, msg_bytes) values (?,?,?,?,?,?) with 2007-04-18 20:00:00 2007-04-18 21:00:00 hour 30 202094
    Column 'host' cannot be null
    Column 'host' cannot be null at libexec/zmlogprocess line 1021.

    Aggregating day mta from 2007-04-17 00:00:00 to 2007-04-18 00:00:00
    Aggregating hour amavis from 2007-04-18 20:00:00 to 2007-04-18 21:00:00
    DBD::mysql::st execute failed: Column 'host' cannot be null at libexec/zmlogprocess line 1020.
    Error executing insert into amavis_aggregate (period_start, period_end, host, period, msg_count, spam_count, virus_count) values (?,?,?,?,?,?,?) with 2007-04-18 20:00:00 2007-04-18 21:00:00 hour 9 2 0
    Column 'host' cannot be null
    Column 'host' cannot be null at libexec/zmlogprocess line 1021.

    Aggregating day amavis from 2007-04-17 00:00:00 to 2007-04-18 00:00:00
    Aggregating hour disk from 2007-04-18 20:00:00 to 2007-04-18 21:00:00
    Aggregating day disk from 2007-04-17 00:00:00 to 2007-04-18 00:00:00
    Retaining 31 days worth of raw logs based on zimbraLogRawLifetime config.
    Retaining 730 days worth of summary logs based on zimbraLogSummaryLifetime config.
    Pruning raw mta logs from 2007-03-18 00:00:00
    Pruning raw amavis logs from 2007-03-18 00:00:00
    Pruning raw disk logs from 2007-03-18 00:00:00
    Pruning summary mta logs from 2005-04-18 00:00:00
    Pruning summary amavis logs from 2005-04-18 00:00:00
    Pruning summary disk logs from 2005-04-18 00:00:00
    Pruning other raw logs from 2007-03-18 00:00:00

  3. #3
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    looking into it.

  4. #4
    hlandgar is offline Junior Member
    Join Date
    Apr 2007
    Posts
    9
    Rep Power
    8

    Smile Solution to problem

    I traced the problem to the service_status table not being filled. I then found that cron was not running properly because a crontab for root had never been created. After creating an empty crontab for root and restarting cron, I now find that the service_status table is full and the aggregates are appearing in the db. I want to let everything run for a day to see if there are any other issues.

  5. #5
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    I reopened bug 14809 with regards to the Column host cannot be "null" error.
    Bugzilla - Wiki - Downloads - Before posting... Search!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zmlogprocess Error / mysql crash
    By 3RiversTechAdmin in forum Administrators
    Replies: 2
    Last Post: 04-09-2007, 06:31 AM
  2. Running zmlogprocess once a day vs. every 10 mins
    By scottnelson in forum Administrators
    Replies: 3
    Last Post: 08-11-2006, 07:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •