Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: To: johndevine

  1. #11
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,581
    Rep Power
    57

    Default

    You can train it for ham by using the same zmtrainsa and changing the option for 'spam' to 'ham' and obviously point the directory to the 'good' email. The command would be
    Code:
    zmtrainsa server user password ham cleanemailfolder
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  2. #12
    avisser is offline Active Member
    Join Date
    Oct 2005
    Posts
    29
    Rep Power
    9

    Default M2 spamassasin training question

    I'm using M2 and have modified the zmtrainsa script as instructed by the post (Problem with zmtrainsa, I ran it with the following result:

    [zimbra@mail ~]$ zmtrainsa server user password spam junk
    Option --remote is not supported with POP3
    fetchmail: Query status=5 (SYNTAX)
    synced Bayes databases from journal in 0 seconds: 114 unique entries (114 total entries)
    [zimbra@mail ~]$


    The POP3 message has me curious if the training worked?
    Does the zmtrainsa add to the existing training, or clear the old training?

  3. #13
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default training

    It doesn't look like it trained anything.

    In general, training is additive - after you train on a message, it remembers teh hash of the message, and skips it if it sees it again.

    So - after you train, you can purge your junk folder, to save time the next time you train.

  4. #14
    avisser is offline Active Member
    Join Date
    Oct 2005
    Posts
    29
    Rep Power
    9

    Default

    marcmac, do you have any suggestions on how to fix the training script so it will work?

  5. #15
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default pop3

    I'll take a look at it.

  6. #16
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default protocol

    I'm not giving a protocol specifier in the fetchmail rc, so it tries IMAP, POP3 and POP2 (in that order) skipping those for which there's no support compiled in.

    POP doesn't support the -r option (to specify a folder) which is generating the error.

    I've fixed zmtrainsa thusly:

    echo "server $SERVER protocol IMAP user $USER@$SERVER password $PASS keep" > ${zimbra_home}/conf/.fetchmailrc

    which should force IMAP - but the problem remains, why didn't it use IMAP to start with?

    Try fetchmail -V and see what it says. Mine says:
    This is fetchmail release 6.2.5+IMAP-GSS+RPA+NTLM+SDPS+SSL+INET6+NLS
    which seems to indicate IMAP support - does your version list IMAP?

  7. #17
    avisser is offline Active Member
    Join Date
    Oct 2005
    Posts
    29
    Rep Power
    9

    Talking looks like it worked

    I have the same version of fetchmail as you do.

    I ran it and it looks like it worked

    [zimbra@mail ~]$ zmtrainsa server user password spam junk
    fetchmail: Query status=2 (SOCKET)
    synced Bayes databases from journal in 3 seconds: 1076 unique entries (1437 total entries)
    [zimbra@mail ~]$


    thanks for all the hard work.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •