Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 44

Thread: Error install on Mac OS X

  1. #11
    pcoleman is offline Active Member
    Join Date
    Nov 2005
    Posts
    37
    Rep Power
    9

    Default error installing on Mac OS X

    No I don't see that file there.

    Just to be sure about things. What is the proper way to start Zimbra?

  2. #12
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default zmcontrol

    su - zimbra
    zmcontrol start

  3. #13
    pcoleman is offline Active Member
    Join Date
    Nov 2005
    Posts
    37
    Rep Power
    9

    Default error installing on Mac OS X

    Even though I did the upgrade to J2SE 5.0 and did a reboot to be sure I still get (when I try to start tomcat)??

    /opt/zimbra/libexec/zmtomcatstart
    zmtomcatstart:This release of Apache Tomcat was packaged to run on J2SE 5.0 or later. It can be run on earlier JVMs by downloading and
    installing a compatibility package from the Apache Tomcat
    binary download page.

  4. #14
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default java -version

    run java -version - does it return 1.5?

    If not - ls -l /usr/bin/java - where's the symlink pointing to? Make sure the java in /usr/bin is 1.5

  5. #15
    pcoleman is offline Active Member
    Join Date
    Nov 2005
    Posts
    37
    Rep Power
    9

    Default error installing on Mac OS X

    It's java version "1.4.2_09"

    I don't see a 1.5 version in the directory the present link is pointing to?

    Where does MAC install Java?

    By the way thanks for all the help.

  6. #16
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default MAC default java version - how to set.

    http://developer.apple.com/releaseno...3RN/index.html

    I think the right way to fix this is to run /Applications/Utilities/Java/J2SE 5.0/Java Preferences and set the default there.

  7. #17
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default symlink

    If that doesn't work, you can also move the symlink to

    /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Commands/java

  8. #18
    pcoleman is offline Active Member
    Join Date
    Nov 2005
    Posts
    37
    Rep Power
    9

    Default error installing on Mac OS X

    Got the right link in place and tried to start.

    When I run zmcontrol start I get..
    zimbra$ zmcontrol start
    Host patrick-colemans-powerbook.local
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting logger...Done.
    Starting mailbox...Done.
    Starting mta...FAILED
    DO: /opt/zimbra/postfix/sbin/postconf -e content_filter='smtp-amavis:[127.0.0.1]:10024'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_sasl_auth_enable='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_auth_only='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e disable_dns_lookups='no'
    DO: /opt/zimbra/postfix/sbin/postconf -e message_size_limit='10240000'
    DO: /opt/zimbra/postfix/sbin/postconf -e relayhost=''
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_recipient_restrictions='reject_non_fqdn_reci pient, permit_sasl_authenticated, permit_mynetworks, reject_invalid_hostname, reject_non_fqdn_hostname, reject_non_fqdn_sender, reject_unauth_destination, permit'
    saslauthd[2284] :detach_tty : Cannot start saslauthd
    saslauthd[2284] :detach_tty : Another instance of saslauthd is currently running


    Starting snmp...Done.
    Starting spell...Done.

    I check for saslauthd and see..
    1880 ?? Ss 0:00.01 /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/sbin/saslauthd -r -a zimbra
    1882 ?? S 0:00.00 /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/sbin/saslauthd -r -a zimbra
    1883 ?? S 0:00.00 /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/sbin/saslauthd -r -a zimbra
    1884 ?? S 0:00.00 /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/sbin/saslauthd -r -a zimbra
    1885 ?? S 0:00.00 /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/sbin/saslauthd -r -a zimbra

    In the catalina.out file I get...

    more /opt/zimbra/tomcat/logs/catalina.out
    zmtomcatstart: info: stale pid 1720 in pid file: No such process
    Nov 20, 2005 12:16:44 PM org.apache.coyote.http11.Http11Protocol init
    INFO: Initializing Coyote HTTP/1.1 on http-80
    Nov 20, 2005 12:16:58 PM org.apache.coyote.http11.Http11Protocol init
    INFO: Initializing Coyote HTTP/1.1 on http-7071
    Nov 20, 2005 12:16:58 PM org.apache.catalina.startup.Catalina load
    INFO: Initialization processed in 26337 ms
    Nov 20, 2005 12:16:58 PM org.apache.catalina.core.StandardService start
    INFO: Starting service Catalina
    Nov 20, 2005 12:16:58 PM org.apache.catalina.core.StandardEngine start
    INFO: Starting Servlet Engine: Apache Tomcat/5.5.7
    Nov 20, 2005 12:16:59 PM org.apache.catalina.core.StandardHost start
    INFO: XML validation disabled
    Nov 20, 2005 12:17:11 PM org.apache.catalina.startup.HostConfig deployWAR
    INFO: Deploying web application archive service.war
    log4j:WARN No appenders could be found for logger (org.apache.catalina.session.ManagerBase).
    log4j:WARN Please initialize the log4j system properly.
    Zimbra server reserving server socket port=110 bindaddr=null
    Zimbra server reserving server socket port=995 bindaddr=null
    Zimbra server reserving server socket port=143 bindaddr=null
    Zimbra server reserving server socket port=993 bindaddr=null
    Zimbra server process is running as root, changing to user=zimbra uid=502 gid502
    Zimbra server process, after change, is running with uid=502 euid=502 gid=502 egid=502


    I'm going to have to leave this for now, other things to do.
    Appreciate the help.

    Thanks.

    Pat.

  9. #19
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default sasl

    Sound like you had an old instance of sasl hanging around - ps will find it, then kill it - that sounds like the last problem left.

  10. #20
    pcoleman is offline Active Member
    Join Date
    Nov 2005
    Posts
    37
    Rep Power
    9

    Default error installing on Mac OS X

    Well I'm now at this point.
    I did a reboot to make sure I had no other sasl process running and
    I didn't

    Did..
    zmcontrol start
    Host patrick-colemans-powerbook.local
    Starting ldap...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting logger...Done.
    Starting mailbox...Done.
    Starting mta...Done.
    Starting snmp...Done.
    Starting spell...Done.


    Then checked catalina.out
    more /opt/zimbra/tomcat/logs/catalina.out
    zmtomcatstart: info: stale pid 2153 in pid file: No such process
    Nov 20, 2005 2:31:59 PM org.apache.coyote.http11.Http11Protocol init
    INFO: Initializing Coyote HTTP/1.1 on http-80
    Nov 20, 2005 2:32:09 PM org.apache.coyote.http11.Http11Protocol init
    INFO: Initializing Coyote HTTP/1.1 on http-7071
    Nov 20, 2005 2:32:09 PM org.apache.catalina.startup.Catalina load
    INFO: Initialization processed in 20176 ms
    Nov 20, 2005 2:32:09 PM org.apache.catalina.core.StandardService start
    INFO: Starting service Catalina
    Nov 20, 2005 2:32:09 PM org.apache.catalina.core.StandardEngine start
    INFO: Starting Servlet Engine: Apache Tomcat/5.5.7
    Nov 20, 2005 2:32:10 PM org.apache.catalina.core.StandardHost start
    INFO: XML validation disabled
    Nov 20, 2005 2:32:18 PM org.apache.catalina.startup.HostConfig deployWAR
    INFO: Deploying web application archive service.war
    log4j:WARN No appenders could be found for logger (org.apache.catalina.session.ManagerBase).
    log4j:WARN Please initialize the log4j system properly.
    Zimbra server reserving server socket port=110 bindaddr=null
    Zimbra server reserving server socket port=995 bindaddr=null
    Zimbra server reserving server socket port=143 bindaddr=null
    Zimbra server reserving server socket port=993 bindaddr=null
    Zimbra server process is running as root, changing to user=zimbra uid=502 gid502
    Zimbra server process, after change, is running with uid=502 euid=502 gid=502 egid=502


    What is that log4j warning??

    I did see this running for a little while
    /usr/bin/java -Dcatalina.base=/opt/zimbra/jakarta-tomcat-5.5.7 -Dcatalina.home=/opt/zimbra/jaka

    Then gone
    Tomcat is still not running?

    Pat

Page 2 of 5 FirstFirst 1234 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra with Open LDAP on MAC OS X
    By Andy in forum Installation
    Replies: 14
    Last Post: 09-17-2007, 09:25 PM
  2. Installed on Mac OS X client, host file question
    By McBurtnieks in forum Installation
    Replies: 1
    Last Post: 04-01-2007, 11:09 AM
  3. Mac OS X server setup
    By ericmiller74 in forum Installation
    Replies: 2
    Last Post: 10-16-2006, 11:29 AM
  4. Mac OS X + Zimbra + Apache 2
    By abetam in forum Installation
    Replies: 1
    Last Post: 10-06-2006, 10:16 PM
  5. Uninstall in Mac OS X?
    By avi4now in forum Installation
    Replies: 10
    Last Post: 01-09-2006, 12:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •