Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 31

Thread: DynDNS and Zimbra

  1. #21
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    remove the forwarders for time being, they're unnecessary and might confuse things. turn off recursion - add 'recursion no;' to your named.conf.options.
    now you should get clear answers from your dns servers.

    then, set your zone serial (sorry, i said SOA ID which was misnomer) to a standard format:
    yyyymmddxx where xx is a daily increment, so for instance
    2007033101
    and everytime you make a change to the zone, increment this number, eg
    2007033102
    or tomorrow
    2007040101
    etc

    Now turn your TTL down to 60secs (what you have called minimum), currently its set so high you'll never see any changes!

    These are more sensible values:
    hostmaster.mail.jzeller.com. (
    2007033101 ; Serial
    3600 ; Refresh
    3600 ; Retry
    86400 ; Expire
    60 ) ; Minimum

    Then make sure your local dns is set first in resolv order (/etc/resolv.conf)

  2. #22
    afterwego is offline Intermediate Member
    Join Date
    Mar 2007
    Posts
    18
    Rep Power
    8

    Default

    Alright with the settings changed here is my output from 'dig mail.jzeller.org'

    Sorry missed your other post output might be different.

    Also this isn't bind9
    Last edited by afterwego; 03-31-2007 at 02:34 PM.

  3. #23
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    BTW, your NS record should be an FQDN, not an IP address, otherwise you might unwittingly end up with a stealth master.
    so
    IN NS ns.jzeller.com.
    and thus you need to setup the A record:
    ns IN A 192.168.1.110
    convention is to make NS the first records, it doesn't really matter though.

    IN A 192.168.1.110 ; local ip
    ^^ this record inherits SOA space but I think should really be:
    @ IN A 192.168.1.110

    mail IN A 192.168.1.110
    IN MX 10 mail.jzeller.com. ;MXrecord
    ^^ these are fine.

    And if this is Bind9, you should have $TTL set:
    $TTL 1d
    this should be first line in the zone file
    while you're testing, reduce this:
    $TTL 60; i think this means 60sec?

  4. #24
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    Now turn your TTL down to 60secs (what you have called minimum), currently its set so high you'll never see any change
    sorry, this changed from bind8 to bind9 (i got fed up with bind9, use powerdns now!) so the minimum is actually the negative timeout. take both these values down to 60sec for now.

    look in your syslogs for *ANY* bind errors, it can be rather cryptic at times.

  5. #25
    afterwego is offline Intermediate Member
    Join Date
    Mar 2007
    Posts
    18
    Rep Power
    8

    Default

    My new /etc/bind/named.conf.options

    ;
    ; Addresses and other host information.
    ;
    @ IN SOA mail.jzeller.com.
    hostmaster.mail.jzeller.com. (
    2007033101 ; Serial
    3600 ; Refresh
    3600 ; Retry
    86400 ; Expire
    60 ) ; Minimum
    ; Define the nameservers and the mail servers
    IN NS ns.jzeller.com ; local ip
    ns IN A 192.168.1.110
    @ IN A 192.168.1.110 ; local ip
    mail IN A 192.168.1.110
    IN MX 10 mail.jzeller.com. ;MXrecord
    My /etc/resolv.conf

    nameserver 192.168.1.110
    search hsd1.mn.comcast.net.
    nameserver 68.87.77.130
    nameserver 68.87.72.130
    My output from 'dig mail.jzeller.com
    ; <<>> DiG 9.3.2 <<>> mail.jzeller.com
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17949
    ;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 13, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;mail.jzeller.com. IN A

    ;; AUTHORITY SECTION:
    . 518400 IN NS A.ROOT-SERVERS.NET.
    . 518400 IN NS B.ROOT-SERVERS.NET.
    . 518400 IN NS C.ROOT-SERVERS.NET.
    . 518400 IN NS D.ROOT-SERVERS.NET.
    . 518400 IN NS E.ROOT-SERVERS.NET.
    . 518400 IN NS F.ROOT-SERVERS.NET.
    . 518400 IN NS G.ROOT-SERVERS.NET.
    . 518400 IN NS H.ROOT-SERVERS.NET.
    . 518400 IN NS I.ROOT-SERVERS.NET.
    . 518400 IN NS J.ROOT-SERVERS.NET.
    . 518400 IN NS K.ROOT-SERVERS.NET.
    . 518400 IN NS L.ROOT-SERVERS.NET.
    . 518400 IN NS M.ROOT-SERVERS.NET.

    ;; Query time: 3 msec
    ;; SERVER: 192.168.1.110#53(192.168.1.110)
    ;; WHEN: Sat Mar 31 16:40:50 2007
    ;; MSG SIZE rcvd: 245
    Not exactly sure what all that in the Authority sections means. Ive gotta be doing something wrong.

    There are errors in my syslog. Not making any sense to me though
    Last edited by afterwego; 03-31-2007 at 02:47 PM.

  6. #26
    afterwego is offline Intermediate Member
    Join Date
    Mar 2007
    Posts
    18
    Rep Power
    8

    Default

    Here is a good chunk of the syslog. Hopefully its not too long.


    Mar 31 16:30:22 mail named[3180]: hint zone "" (IN) loaded (serial 0)
    Mar 31 16:30:22 mail named[3180]: master zone "localhost" (IN) loaded (serial 1)
    Mar 31 16:30:22 mail named[3180]: master zone "127.in-addr.arpa" (IN) loaded (serial 1)
    Mar 31 16:30:22 mail named[3180]: master zone "0.in-addr.arpa" (IN) loaded (serial 1)
    Mar 31 16:30:22 mail named[3180]: master zone "255.in-addr.arpa" (IN) loaded (serial 1)
    Mar 31 16:30:23 mail named[3180]: Zone "mail.jzeller.com" (file db.mail.jzeller.com): No default TTL ($TTL ) set, using SOA minimum instead
    Mar 31 16:30:23 mail named[3180]: db.mail.jzeller.com:4: Domain Name error near (mail.jzeller.com.)
    Mar 31 16:30:23 mail named[3180]: db.mail.jzeller.com: Line 5: Unknown type: (.
    Mar 31 16:30:23 mail named[3180]: db.mail.jzeller.com:5: Domain Name error near (()
    Mar 31 16:30:23 mail named[3180]: db.mail.jzeller.com:6: Domain Name error near ()
    Mar 31 16:30:23 mail named[3180]: db.mail.jzeller.com:7: Domain Name error near ()
    Mar 31 16:30:23 mail named[3180]: db.mail.jzeller.com:8: Domain Name error near ()
    Mar 31 16:30:23 mail named[3180]: db.mail.jzeller.com:9: Domain Name error near ()
    Mar 31 16:30:23 mail named[3180]: db.mail.jzeller.com: Line 10: Unknown type: ).
    Mar 31 16:30:23 mail named[3180]: db.mail.jzeller.com:10: Domain Name error near ())
    Mar 31 16:30:23 mail named[3180]: db.mail.jzeller.com: Line 14: Unknown type: mail.
    Mar 31 16:30:23 mail named[3180]: db.mail.jzeller.com:14: Domain Name error near (mail)
    Mar 31 16:30:23 mail named[3180]: Zone "mail.jzeller.com" (file db.mail.jzeller.com): no SOA RR found
    Mar 31 16:30:23 mail named[3180]: zone: mail.jzeller.com/IN: non-glue record at bottom of zone: 60.mail.jzeller.com/MX
    Mar 31 16:30:23 mail named[3180]: master zone "mail.jzeller.com" (IN) rejected due to errors (serial 0)
    Mar 31 16:30:23 mail named[3180]: listening on [127.0.0.1].53 (lo)
    Mar 31 16:30:23 mail named[3180]: listening on [192.168.1.110].53 (eth0)
    Mar 31 16:30:23 mail named[3180]: Forwarding source address is [::].32768
    Mar 31 16:30:23 mail named[3180]: Forwarding source address is [0.0.0.0].32769
    Mar 31 16:30:23 mail named[3181]: Ready to answer queries.
    Mar 31 16:30:23 mail /usr/sbin/cron[3229]: (CRON) INFO (pidfile fd = 3)
    Mar 31 16:30:23 mail /usr/sbin/cron[3230]: (CRON) STARTUP (fork ok)
    Mar 31 16:30:23 mail /usr/sbin/cron[3230]: (CRON) INFO (Running @reboot jobs)
    Mar 31 16:30:24 mail kernel: [42949398.610000] eth0: no IPv6 routers present
    Mar 31 16:30:26 mail zimbramon[3252]: 3252:info: Starting services
    Mar 31 16:38:26 mail named[3181]: named shutting down
    Mar 31 16:38:26 mail named[3181]: USAGE 1175377106 1175376623 CPU=0u/0s CHILDCPU=0u/0s
    Mar 31 16:38:26 mail named[3181]: NSTATS 1175377106 1175376623 A=4 PTR=1 ANY=1
    Mar 31 16:38:26 mail named[3181]: XSTATS 1175377106 1175376623 RR=0 RNXD=0 RFwdR=0 RDupR=0 RFail=0 RFErr=0 RErr=0 RAXFR=0 RLame=0 ROpts=0 SSysQ=0 SAns=6 SFwdQ=0 SDupQ=0 SErr=0 RQ=6 RIQ=0 RFwdQ=0 RDupQ=0 RTCP=0 SFwdR=0 SFail=0 SFErr=0 SNaAns=6 SNXD=0 RUQ=0 RURQ=0 RUXFR=0 RUUpd=0
    Mar 31 16:38:28 mail named[3364]: starting (/etc/bind/named.conf). named 8.4.6-REL-NOESW Tue Feb 1 10:10:48 UTC 2005 ^Ibuildd@rockhopper:/build/buildd/bind-8.4.6/src/bin/named
    Mar 31 16:38:28 mail named[3364]: hint zone "" (IN) loaded (serial 0)
    Mar 31 16:38:28 mail named[3364]: master zone "localhost" (IN) loaded (serial 1)
    Mar 31 16:38:28 mail named[3364]: master zone "127.in-addr.arpa" (IN) loaded (serial 1)
    Mar 31 16:38:28 mail named[3364]: master zone "0.in-addr.arpa" (IN) loaded (serial 1)
    Mar 31 16:38:28 mail named[3364]: master zone "255.in-addr.arpa" (IN) loaded (serial 1)
    Mar 31 16:38:28 mail named[3364]: Zone "mail.jzeller.com" (file db.mail.jzeller.com): No default TTL ($TTL ) set, using SOA minimum instead
    Mar 31 16:38:28 mail named[3364]: db.mail.jzeller.com:4: Domain Name error near (mail.jzeller.com.)
    Mar 31 16:38:28 mail named[3364]: db.mail.jzeller.com: Line 5: Unknown type: (.
    Mar 31 16:38:28 mail named[3364]: db.mail.jzeller.com:5: Domain Name error near (()
    Mar 31 16:38:28 mail named[3364]: db.mail.jzeller.com:6: Domain Name error near ()
    Mar 31 16:38:28 mail named[3364]: db.mail.jzeller.com:7: Domain Name error near ()
    Mar 31 16:38:28 mail named[3364]: db.mail.jzeller.com:8: Domain Name error near ()
    Mar 31 16:38:28 mail named[3364]: db.mail.jzeller.com:9: Domain Name error near ()
    Mar 31 16:38:28 mail named[3364]: db.mail.jzeller.com: Line 10: Unknown type: ).
    Mar 31 16:38:28 mail named[3364]: db.mail.jzeller.com:10: Domain Name error near ())
    Mar 31 16:38:28 mail named[3364]: db.mail.jzeller.com: Line 13: Unknown type: 192.168.1.110.
    Mar 31 16:38:28 mail named[3364]: db.mail.jzeller.com:13: Domain Name error near (192.168.1.110)
    Mar 31 16:38:28 mail named[3364]: db.mail.jzeller.com: Line 14: Unknown type: @.
    Mar 31 16:38:28 mail named[3364]: db.mail.jzeller.com:14: Domain Name error near (@)
    Mar 31 16:38:28 mail named[3364]: db.mail.jzeller.com: Line 15: Unknown type: mail.
    Mar 31 16:38:28 mail named[3364]: db.mail.jzeller.com:15: Domain Name error near (mail)
    Mar 31 16:38:28 mail named[3364]: Zone "mail.jzeller.com" (file db.mail.jzeller.com): no SOA RR found
    Mar 31 16:38:28 mail named[3364]: master zone "mail.jzeller.com" (IN) rejected due to errors (serial 0)
    Mar 31 16:38:28 mail named[3364]: listening on [127.0.0.1].53 (lo)
    Mar 31 16:38:28 mail named[3364]: listening on [192.168.1.110].53 (eth0)
    Mar 31 16:38:28 mail named[3364]: Forwarding source address is [::].32770
    Mar 31 16:38:28 mail named[3364]: Forwarding source address is [0.0.0.0].32771
    Mar 31 16:38:28 mail named[3365]: Ready to answer queries.
    Cryptic is right lol

  7. #27
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    Right, that helps! There were still numerous small errors. You've still got your hostname and domainnames confused, you've set your SOA origin to a hostname! Your email contact (@ is replaced with .) is set to the hostname, and remember to fully qualify FQDNs with a '.'. Also you've split the SOA across two lines, that's what is really upsetting it. Looks like $TTL came in randomly in Bind 8.4.2. Yes, the syntax is horrible, Bind is horrible. I've attached a corrected zone file, try it

    Bind is a nasty piece of work and truly awful with large numbers of domains. If you do any serious Dns work I recommend looking at djbdns (although that means dealing with djb who is bonkers, and his cryptic licensing policies - or lack thereof), or PowerDNS. PowerDNS is lovely, all hail.
    Attached Files Attached Files
    Last edited by dijichi2; 03-31-2007 at 04:14 PM.

  8. #28
    afterwego is offline Intermediate Member
    Join Date
    Mar 2007
    Posts
    18
    Rep Power
    8

    Default

    Ok mail.jzeller.com is correctly resolving now and on install Zimbra sees mail.jzeller.com and resolves it and continues in the setup, however, shouldn't the hostname be 'jzeller.com'? I tried to change it in the Zimbra config from mail.jzeller.com to jzeller.com and I got a DNS ERROR again.

    I'm not sure if this is supposed to happen and I should just ignore the error or if something needs to be addressed here.

    After setting it all up I am able to both send and recieve, so I assume my question above doesn't matter.

    Also when you go to www.jzeller.com or mail.jzeller.com you get the login. Is there an easy way to make it so that when someone goes to www.jzeller.com they don't see the login. I hope to run a webserver off of there at some point if thats a possibility


    Thanks for all your help.
    Last edited by afterwego; 04-01-2007 at 12:13 AM.

  9. #29
    dijichi2 is offline OpenSource Builder & Moderator
    Join Date
    Oct 2005
    Posts
    1,176
    Rep Power
    11

    Default

    No, sounds like you've got it set correctly. The *hostname* is 'mail.jzeller.com', the *domainname* is 'jzeller.com'.

    At the moment Zimbra by default binds to port 80 on all IP addresses, which is the same as your webserver will do by default. There are various methods of changing this, personally I think the easiest is to change Zimbra to port 85, then use Apache proxy module to assign a vhost to proxy port 85, so you end up with Zimbra appearing to be on, eg. http://mail.jzeller.com:80/, but it leaves http://www.jzeller.com:80/ free for web stuff. Alternatively you can use 'zmtlsctl' to switch zimbra to ssl mode which means you would use https://mail.jzeller.com/ for zimbra, fine if you don't have any other https sites. It's all covered comprehensively in the wiki and here in the forums.

    Good luck

  10. #30
    afterwego is offline Intermediate Member
    Join Date
    Mar 2007
    Posts
    18
    Rep Power
    8

    Default

    lol Im not sure if I will attempt the apache proxy thing. I don't want to start another 28 post thread.

Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. OS-X - start zimbra whitout DNS on localhost
    By sam75 in forum Installation
    Replies: 7
    Last Post: 06-03-2006, 11:34 AM
  2. Installing Zimbra on CENTOS
    By gapnet in forum Installation
    Replies: 2
    Last Post: 04-11-2006, 07:25 AM
  3. Question On Setup For Testing Zimbra At Home
    By freddy in forum Installation
    Replies: 4
    Last Post: 12-14-2005, 03:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •