Results 1 to 9 of 9

Thread: Admin Port Change

  1. #1
    amnz is offline Active Member
    Join Date
    Apr 2006
    Location
    Barcelona (SPAIN)
    Posts
    35
    Rep Power
    9

    Default Admin Port Change

    I've found info about how to change the http or https ports for Zimbra client (with the zmprov ms... command).
    But I need to change the admin 7071 port for another one (8443).
    How can I do that?

  2. #2
    amnz is offline Active Member
    Join Date
    Apr 2006
    Location
    Barcelona (SPAIN)
    Posts
    35
    Rep Power
    9

    Default Admin Port Change

    Anybody out there?...

    Is it posible to change port 70171 for another one?? ...is it hardcoded?

  3. #3
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    zmprov ms (domain here) zimrbaAdminPort (port # here)

  4. #4
    amnz is offline Active Member
    Join Date
    Apr 2006
    Location
    Barcelona (SPAIN)
    Posts
    35
    Rep Power
    9

    Default Admin Port Change

    Not worked....
    It continues to attend at port 7071.

    Must I change also the value at zimbra_admin_service_port shown by zmlocalconfig?

    I need to change this because the server has the port 7071 used by another app. And is not possible to change it because it has port 7071 hardcoded.
    And, as the pst translation tool needs to use an admin port....I cannot migrate users in full.

  5. #5
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    You need to restart tomcat after you change it.

  6. #6
    amnz is offline Active Member
    Join Date
    Apr 2006
    Location
    Barcelona (SPAIN)
    Posts
    35
    Rep Power
    9

    Default Admin Port Change

    I changed the pot using:
    zmprov ms server.domain.com zimbraAdminPort 8443
    Then restarted Tomcat

    And it continues to answer on port 7071

    I also tried to change the value at localconfig using:
    zmlocalconfig -e zimbra_admin_service_port=8443
    Then restarted everything and again the same; it's on port 7071.

    Then to use again zmprov I needed to reset localconfig to port 7071. If not this shows some error relating unsuccessful login....

    Any ideas?

  7. #7
    s0undt3ch is offline Loyal Member
    Join Date
    Apr 2007
    Location
    Portugal
    Posts
    77
    Rep Power
    8

    Exclamation

    I'm having the same problem.

    Code:
    $ id
    uid=1001(zimbra) gid=1001(zimbra) groups=4(adm),5(tty),1001(zimbra),1002(postfix)
    $ zmprov gacf | grep zimbraAdminPort
    zimbraAdminPort: 7071
    $ zmprov ms `hostname -f` zimbraAdminPort 8080
    $ zmprov gacf | grep zimbraAdminPort
    zimbraAdminPort: 7071
    $ tomcat restart
    $ zmprov gacf | grep zimbraAdminPort
    zimbraAdminPort: 7071
    So what's wrong? How can I really change it?

  8. #8
    schemers is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    228
    Rep Power
    10

    Default

    You are calling "ms" which is modifyServer, then calling "gacg", which is getting the global config value, which is the default value if the value is unset on the server. You should call "gs" to see if it actually changed.

    I don't think think there is an easy/automated way to change the admin port, and even after changing everything there might be something hardcoded in code as I don't think we've tested it. Might need to file a bug on it.

    I can think of a few places you'll have to change:

    1. zimbraAdminPort (globally via zmprov mcf, might need on each server as well)

    2. zmlocalconfig (zimbra_admin_service_port )

    3. need to manually edit /opt/zimbra/tomcat/conf/server.xml.in and and change all occurrences of 7071 to your port:
    Code:
            <!-- admin services connector; requires SSL -->
            <Connector port="7071"
    4. You'll probably also need to edit the various web.xml files as well, and change all occurrences of 7071 in these files to the new port:
    Code:
    /opt/zimbra/tomcat/webapps/service/WEB-INF/web.xml
    /opt/zimbra/tomcat/webapps/zimbraAdmin/WEB-INF/web.xml
    /opt/zimbra/tomcat/webapps/zimbra/WEB-INF/web.xml
    You'll have to restart tomcat of course.

    Even after all that, it still might not work. I'm not sure if there is a bug filed against this or not. It could certainly be cleaned up, though most of those values exist due to various chicken-and-egg problems.

    Quote Originally Posted by s0undt3ch View Post
    I'm having the same problem.

    Code:
    $ id
    uid=1001(zimbra) gid=1001(zimbra) groups=4(adm),5(tty),1001(zimbra),1002(postfix)
    $ zmprov gacf | grep zimbraAdminPort
    zimbraAdminPort: 7071
    $ zmprov ms `hostname -f` zimbraAdminPort 8080
    $ zmprov gacf | grep zimbraAdminPort
    zimbraAdminPort: 7071
    $ tomcat restart
    $ zmprov gacf | grep zimbraAdminPort
    zimbraAdminPort: 7071
    So what's wrong? How can I really change it?
    Last edited by schemers; 04-06-2007 at 12:15 PM.
    Bugzilla - Wiki - Downloads - Before posting... Search!

  9. #9
    brian is offline Project Contributor
    Join Date
    Jul 2006
    Posts
    623
    Rep Power
    10

    Default

    Quote Originally Posted by amnz View Post
    I've found info about how to change the http or https ports for Zimbra client (with the zmprov ms... command).
    But I need to change the admin 7071 port for another one (8443).
    How can I do that?
    Not really supported at this time. There are several scripts that have this value hardcoded that would need to be fixed. Feel free to file a bug.
    Bugzilla - Wiki - Downloads - Before posting... Search!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. initializing ldap...FAILED(256)ERROR
    By manjunath in forum Installation
    Replies: 39
    Last Post: 06-07-2013, 10:27 AM
  2. Installation Problem - Possibly LDAP
    By geroshea in forum Installation
    Replies: 5
    Last Post: 03-16-2007, 04:47 AM
  3. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 09:19 AM
  4. Zimbra Installation Problem
    By AnilKumarYalla in forum Developers
    Replies: 0
    Last Post: 09-10-2006, 09:33 PM
  5. How to change web access port?
    By hootjr29 in forum Installation
    Replies: 8
    Last Post: 02-21-2006, 05:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •