Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: trouble with installing zimbra on debian sarge

  1. #1
    b_52globemaster is offline Intermediate Member
    Join Date
    Mar 2007
    Posts
    18
    Rep Power
    8

    Default trouble with installing zimbra on debian sarge

    hello ,
    i am some trouble to install zimbra , i executed the script "./install,sh"
    and the result :

    The system will be modified. Continue? [N] y

    Shutting down zimbra mail

    Backing up ldap

    ./util/utilfunc.sh: line 848: /opt/zimbra/openldap/sbin/slapcat: Aucun fichier ou r�pertoire de ce type

    Removing existing packages

    zimbra-ldap...done
    zimbra-logger...done
    zimbra-mta...done
    zimbra-snmp...done
    zimbra-store...done
    zimbra-spell...done
    zimbra-apache...done
    zimbra-core...done

    Removing deployed webapp directories
    Installing packages

    ./install.sh: line 155: /opt/zimbra/.install_history: Aucun fichier ou r�pertoire de ce type
    zimbra-core......zimbra-core_4.5.3_GA_733.DEBIAN3.1_i386.deb...done
    zimbra-ldap......zimbra-ldap_4.5.3_GA_733.DEBIAN3.1_i386.deb...done
    zimbra-logger......zimbra-logger_4.5.3_GA_733.DEBIAN3.1_i386.deb...done
    zimbra-mta......zimbra-mta_4.5.3_GA_733.DEBIAN3.1_i386.deb...done
    zimbra-snmp......zimbra-snmp_4.5.3_GA_733.DEBIAN3.1_i386.deb...done
    zimbra-store......zimbra-store_4.5.3_GA_733.DEBIAN3.1_i386.deb...done
    zimbra-apache......zimbra-apache_4.5.3_GA_733.DEBIAN3.1_i386.deb...done
    zimbra-spell......zimbra-spell_4.5.3_GA_733.DEBIAN3.1_i386.deb...FAILED
    ###ERROR###

    zimbra-spell_4.5.3_GA_733.DEBIAN3.1_i386.deb installation failed

    Installation cancelled
    and thanks

  2. #2
    b_52globemaster is offline Intermediate Member
    Join Date
    Mar 2007
    Posts
    18
    Rep Power
    8

    Unhappy

    when i try manuelly to install zimbra-spell package ;

    dpkg -i /home/foxmjay/zcs/packages/zimbra-spell_4.5.3_GA_733.DEBIAN3.1_i386.deb
    (Lecture de la base de donn�es... 60125 fichiers et r�pertoires d�j� install�s.)
    Pr�paration du remplacement de zimbra-spell 4.5.3_GA_733.DEBIAN3.1 (en utilisant .../zimbra-spell_4.5.3_GA_733.DEBIAN3.1_i386.deb) ...
    D�paquetage de la mise � jour de zimbra-spell ...
    Param�trage de zimbra-spell (4.5.3_GA_733.DEBIAN3.1) ...
    hostname: Unknown host
    hostname: Unknown host
    dpkg�: erreur de traitement de zimbra-spell (--install)�:
    le sous-processus post-installation script a retourn� une erreur de sortie d'�tat 1
    Des erreurs ont �t� rencontr�es pendant l'ex�cution�:
    zimbra-spell
    tracteur:/home/foxmjay/zcs-src#

    in my /etc/hosts

    127.0.0.1 localhost
    192.168.1.64 redlight.xxx.dyndns.org
    and thanks

  3. #3
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,316
    Rep Power
    13

    Default

    Hello, welcome to the forum (bonjour et bienvenue ).

    The "spell install issue" is actually a DNS issue (don't ask me exactly why, I don't know ). A search in the forum would have give you the same answer.

    Check and double check the DNS settings of your server (both resolv.conf file and host file : I'm not sure dyndns authorises private IPs).

  4. #4
    b_52globemaster is offline Intermediate Member
    Join Date
    Mar 2007
    Posts
    18
    Rep Power
    8

    Default

    salut Klug ,

    welcome to you my friend , yeah you're right , it was a dns issue

    peace

  5. #5
    b_52globemaster is offline Intermediate Member
    Join Date
    Mar 2007
    Posts
    18
    Rep Power
    8

    Default

    back again , i am gone continue here , with my second problem since it's in the same context ,

    i have sucess to figure out DNS and MX related trouble , but i am stuck in the install
    DNS ERROR resolving MX for localhost
    It is suggested that the domain name have an MX record configured in DNS
    Change domain name? [Yes] yes
    Create Domain: [localhost] delta-consulting.dyndns.org
    Done
    Checking for port conflicts

    Main menu

    1) Hostname: localhost
    ** 2) Ldap master host: UNSET
    3) Ldap port: 389
    ** 4) Ldap password: UNSET
    r) Start servers after configuration yes
    s) Save config to file
    x) Expand menu
    q) Quit

    Address unconfigured (**) items or correct ldap configuration (? - help) 2

    Please enter the ldap server hostname localhost

    Main menu

    1) Hostname: localhost
    2) Ldap master host: localhost
    3) Ldap port: 389
    ** 4) Ldap password: UNSET
    r) Start servers after configuration yes
    s) Save config to file
    x) Expand menu
    q) Quit

    Address unconfigured (**) items (? - help) 4

    Password for ldap server (min 6 characters): ldap
    Minimum length of 6 characters!
    Password for ldap server (min 6 characters): ******

    Main menu

    1) Hostname: localhost
    2) Ldap master host: localhost
    3) Ldap port: 389
    4) Ldap password: set
    r) Start servers after configuration yes
    s) Save config to file
    x) Expand menu
    q) Quit

    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes] yes
    Save config in file: [/opt/zimbra/config.9432]
    Saving config in /opt/zimbra/config.9432...Done
    The system will be modified - continue? [No] yes
    Operations logged to /tmp/zmsetup.log.9432
    Setting local config values...Done
    Setting up CA...Done
    Fetching CA from ldap...ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    Done
    Creating server entry for localhost...Done
    Setting services on localhost...Done
    Setting up zimbra crontab...no crontab for zimbra
    Done
    Setting up syslog.conf...ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException localhost:389)
    Done

    You have the option of notifying Zimbra of your installation.
    This helps us to track the uptake of the Zimbra Collaboration Suite.
    The only information that will be transmitted is:
    The VERSION of zcs installed (4.5.3_GA_733_UNKNOWN)
    The ADMIN EMAIL ADDRESS created (admin@delta-consulting.dyndns.org)

    Notify Zimbra of your installation? [Yes]
    and thanks

  6. #6
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Code:
    (cause: javax.naming.CommunicationException localhost:389)
    Your hosts file and/or dns isn't set up correctly.

    Search the forum on hosts file.

  7. #7
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,505
    Rep Power
    57

    Default

    Your hosts file has this:
    192.168.1.64 redlight.xxx.dyndns.org
    and it should have this:
    Code:
    192.168.1.64 redlight.xxx.dyndns.org redlight
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    b_52globemaster is offline Intermediate Member
    Join Date
    Mar 2007
    Posts
    18
    Rep Power
    8

    Unhappy

    holla , Phoenix , jholder
    my /etc/hosts look like


    #127.0.0. localhost.localdomain localhost
    127.0.0.1 localhost tracteur
    #127.0.0.1 localhost.XXX.dyndns.org
    #::1 ip6-localhost ip6-loopback
    #fe00::0 ip6-localnet
    #ff00::0 ip6-mcastprefix
    #ff02::1 ip6-allnodes
    #ff02::2 ip6-allrouters
    #ff02::3 ip6-allhosts

    #192.168.1.201 tracteur
    192.168.1.201 tracteur.XXX.dyndns.org tracteur
    I apply the modifications , but still got the same error

    and thanks

  9. #9
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,505
    Rep Power
    57

    Default

    Your hosts file is still incorrect, it should only contain this:
    Code:
    127.0.0.1 localhost.localdomain localhost
    192.168.1.201 tracteur.XXX.dyndns.org tracteur
    Can you resolve your server by doing a 'dig mx tracteur.XXX.dyndns.org' - I suspect this points to your public IP address and your hosts file points to your LAN IP, is that correct? If that's correct then you probably need a split-DNS set-up - have a look oin the wiki for details.

    The problem you're seeing is that your servername can't be resolved which means that you most likely have a DNS problem. You'll find some details on troubleshooting LDAP problems in the wiki, have a look at that and try the solutions there.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    b_52globemaster is offline Intermediate Member
    Join Date
    Mar 2007
    Posts
    18
    Rep Power
    8

    Unhappy

    the dig result command :

    found
    tracteur:/home/foxmjay# dig MX.XXX.dyndns.org


    ; <<>> DiG 9.3.2-P1 <<>> MX.XXX.dyndns.org
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 8399
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;MX.XXX.dyndns.org. IN A

    ;; AUTHORITY SECTION:
    XXX.dyndns.org. 86400 IN SOA tracteur.XXX.dyndns.org. tracteur.XXX.dyndns.org. 2005110200 28800 7200 2419200 86400

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Fri Mar 16 09:10:38 2007
    ;; MSG SIZE rcvd: 93
    hm !

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Zimbra Install Problem - getDirectContext
    By bsimzer in forum Installation
    Replies: 27
    Last Post: 07-19-2007, 10:12 AM
  2. Replies: 8
    Last Post: 02-27-2007, 04:10 AM
  3. zimbra-core missing
    By kinaole in forum Developers
    Replies: 1
    Last Post: 10-02-2006, 11:59 AM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  5. Seeming variety of problems on suse-9.1
    By Crexis in forum Installation
    Replies: 52
    Last Post: 03-04-2006, 12:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •