Results 1 to 7 of 7

Thread: Network edition - strange behavior

  1. #1
    goetzi is offline Project Contributor
    Join Date
    Nov 2005
    Location
    Austria
    Posts
    223
    Rep Power
    9

    Default Network edition - strange behavior

    Hi,

    i wanted to install the Network Edition on CentOS 4.2.

    If I install with the default installation settings, all works fine.

    But if i configure the host as mail.*something*.mine.nu and the ldap-domain als *something*.mine.nu, there alway appear errors, here is the log (i made the errors bold):

    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes] y
    Save config in file: [/opt/zimbra/config.13247]
    Saving config in /opt/zimbra/config.13247...Done
    The system will be modified - continue? [No] y
    Operations logged to /tmp/zmsetup.log.13247
    Setting local config zimbra_server_hostname to mail.*something*.mine.nu
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_server_hostname=mail.*something*.mine.nu
    Setting local config ldap_master_url to ldap://mail.*something*.mine.nu:389
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_master_url=ldap://mail.*something*.mine.nu:389
    Setting local config ldap_url to ldap://mail.*something*.mine.nu
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_url=ldap://mail.*something*.mine.nu
    Setting local config zimbra_uid to 500
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_uid=500
    Setting local config zimbra_gid to 500
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_gid=500
    Setting local config zimbra_user to zimbra
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_user=zimbra
    Setting local config av_notify_user to admin@*something*.mine.nu
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e av_notify_user=admin@*something*.mine.nu
    Setting local config ssl_allow_untrusted_certs to TRUE
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ssl_allow_untrusted_certs=TRUE
    Setting up CA...
    *** Running as zimbra user: cd /opt/zimbra; zmcreateca
    Done
    Setting up SSL...
    *** Running as zimbra user: cd /opt/zimbra; zmcreatecert
    *** Running as zimbra user: cd /opt/zimbra; zmtlsctl http
    *** Running as zimbra user: cd /opt/zimbra; zmcertinstall mta /opt/zimbra/ssl/ssl/server/smtpd.crt /opt/zimbra/ssl/ssl/ca/ca.key
    Done
    Initializing ldap...
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    Done
    Saving CA in ldap...
    *** Running as zimbra user: zmprov mcf zimbraCertAuthorityCertSelfSigned \"-----BEGIN TRUSTED CERTIFICATE-----
    MIICRzCCAbACAQAwDQYJKoZIhvcNAQEEBQAwbDELMAkGA1UEBh MCVVMxDDAKBgNV
    BAgTA04vQTEMMAoGA1UEBxMDTi9BMSMwIQYDVQQKExpaaW1icm EgQ29sbGFib3Jh
    dGlvbiBTdWl0ZTEcMBoGA1UEAxMTbWFpbC5nb2V0emkubWluZS 5udTAeFw0wNTEx
    MTYxNjM3MzdaFw0wNjExMTYxNjM3MzdaMGwxCzAJBgNVBAYTAl VTMQwwCgYDVQQI
    EwNOL0ExDDAKBgNVBAcTA04vQTEjMCEGA1UEChMaWmltYnJhIE NvbGxhYm9yYXRp
    b24gU3VpdGUxHDAaBgNVBAMTE21haWwuZ29ldHppLm1pbmUubn UwgZ8wDQYJKoZI
    hvcNAQEBBQADgY0AMIGJAoGBAKZD4BvTEcsd4V7y9zkxqkfHuZ qIs2Qkw0LR/s3l
    wQji0gayU8FACni7RXQqo6Sg7F3A/yo4GOsNuijCUH7hYQAd22yF5mdsz1zMa84R
    WBNOToDgEG/P7BQ0WJjOFhMF7bETs7ezjSIAeW7MbYWX/Awdhs/FUD+WX5SQmLXr
    ubbTAgMBAAEwDQYJKoZIhvcNAQEEBQADgYEAJd29PLy01wxv3D J65Tlr+acMA9q2
    zKbkgSxCoZVHPKoVXcd3JRqEIER4gnR7pfq6FZ2P/Ncj35JL7gnyY+4/WjVv59CT
    fk7yx9QBT+UbpB/WUOUxrfXFoq4SLQKw6ghMYrJHy4rt3/0sDkP8V/b2o0bL49BZ
    MRO54kuG+jh2yhI=
    -----END TRUSTED CERTIFICATE-----\"
    *** Running as zimbra user: zmprov mcf zimbraCertAuthorityKeySelfSigned \"-----BEGIN RSA PRIVATE KEY-----
    MIICXAIBAAKBgQCmQ+Ab0xHLHeFe8vc5MapHx7maiLNkJMNC0f 7N5cEI4tIGslPB
    QAp4u0V0KqOkoOxdwP8qOBjrDboowlB+4WEAHdtsheZnbM9czG vOEVgTTk6A4BBv
    z+wUNFiYzhYTBe2xE7O3s40iAHluzG2Fl/wMHYbPxVA/ll+UkJi167m20wIDAQAB
    AoGAWWhimVPVW66DxPVOsHjeop7qVglwvkduoP4f0UTdmxOt8V/v3hm8B9Rcsu1C
    9oJ62KeyD1f/PlcxZj2n37L+35zA8+vPF91zD1uhyiqK4t7+PFZRjtcWZpqYhk Mw
    k6MiIK9UQXXDEkeaOZepv8PLuOlYQVPWWaJ+PpslJSLO21ECQQ DdPYTVKCPnb5AT
    FDePvrdZmf0eDoTq9o6Ao0lgtd4udVm3GrX9WC5vcQZHFfp3XN HQQLZf8+rIqJrE
    YNyj2OIdAkEAwGM0323hzQji+d4iYW0YpeHNvtsL4g8YEMgeMY r8WAuv0BbjGdKC
    Mt9X1+j5Xr95m46w+07HxeKNWYj1C1qprwJAbw6smVu2+jxUdF 9XrL6txzq3htj+
    +/uceRJ+iR+CUovx5ypvZKdZV/PClPiBbF2ZrRJu+ie1GdkZJ67/0vfSOQJAdU7I
    mYgty9CkXcll21QjWFp0EvELsN6VRP5Q8tKVhbYykMaz2TXzr8 Nhk8R58Zz9MK30
    Gnhx9aZrm/GXwUGZ/wJBALMKYZAbVxiZtJAaC3rBGfRblChamxW+1up5/qiveWPK
    Z2nzDSqcMTv454MACDGjP0V6h3P54hfurEufP5PB+w0=
    -----END RSA PRIVATE KEY-----\"
    Done
    Creating server entry for mail.*something*.mine.nu...*** Running as zimbra user: /opt/zimbra/bin/zmprov cs mail.*something*.mine.nu
    Done
    Setting spell check URL to http://mail.*something*.mine.nu:7780/aspell.php...
    *** Running as zimbra user: /opt/zimbra/bin/zmprov ms mail.*something*.mine.nu zimbraSpellCheckURL http://mail.*something*.mine.nu:7780/aspell.php
    Done
    Setting service ports on mail.*something*.mine.nu...
    *** Running as zimbra user: /opt/zimbra/bin/zmprov ms mail.*something*.mine.nu zimbraImapBindPort 143 zimbraImapSSLBindPort 993 zimbraPop3BindPort 110 zimbraPop3SSLBindPort 995
    Done
    Adding mail.*something*.mine.nu to zimbraMailHostPool in default COS
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mail.*something*.mine.nu:389)
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mail.*something*.mine.nu:389)

    Done
    Creating domain *something*.mine.nu...
    *** Running as zimbra user: /opt/zimbra/bin/zmprov cd *something*.mine.nu
    *** Running as zimbra user: /opt/zimbra/bin/zmprov mcf zimbraDefaultDomainName *something*.mine.nu
    Done
    Creating user admin@*something*.mine.nu...
    *** Running as zimbra user: /opt/zimbra/bin/zmprov
    Done
    Creating postmaster alias...
    *** Running as zimbra user: /opt/zimbra/zmprov aaa admin@*something*.mine.nu root@*something*.mine.nu
    *** Running as zimbra user: /opt/zimbra/zmprov aaa admin@*something*.mine.nu postmaster@*something*.mine.nu
    Done
    Initializing store sql database...
    *** Running as zimbra user: /opt/zimbra/libexec/zmmyinit
    Done
    Setting zimbraSmtpHostname for mail.*something*.mine.nu
    *** Running as zimbra user: /opt/zimbra/bin/zmprov ms mail.*something*.mine.nu zimbraSmtpHostname mail.*something*.mine.nu
    Done
    Initializing store sql database...
    *** Running as zimbra user: /opt/zimbra/libexec/zmloggerinit
    Done
    *** Running as zimbra user: /opt/zimbra/bin/zmprov mcf zimbraLogHostname mail.*something*.mine.nu
    Initializing mta config...
    *** Running as zimbra user: /opt/zimbra/libexec/zmmtainit
    Done
    Configuring SNMP...
    Setting local config snmp_notify to yes
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e snmp_notify=yes
    Setting local config smtp_notify to yes
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e smtp_notify=yes
    Setting local config snmp_trap_host to mail.*something*.mine.nu
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e snmp_trap_host=mail.*something*.mine.nu
    Setting local config smtp_source to admin@*something*.mine.nu
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e smtp_source=admin@*something*.mine.nu
    Setting local config smtp_destination to admin@*something*.mine.nu
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e smtp_destination=admin@*something*.mine.nu
    *** Running as zimbra user: /opt/zimbra/libexec/zmsnmpinit
    Done
    Configuring Spell server...
    Done
    Setting services on mail.*something*.mine.nu
    *** Running as zimbra user: /opt/zimbra/bin/zmprov ms mail.*something*.mine.nu zimbraServiceInstalled antivirus zimbraServiceInstalled antispam zimbraServiceInstalled logger zimbraServiceInstalled mailbox zimbraServiceInstalled mta zimbraServiceInstalled snmp zimbraServiceInstalled ldap zimbraServiceInstalled spell
    *** Running as zimbra user: /opt/zimbra/bin/zmprov ms mail.*something*.mine.nu zimbraServiceEnabled antivirus zimbraServiceEnabled antispam zimbraServiceEnabled spell zimbraServiceEnabled logger zimbraServiceEnabled mailbox zimbraServiceEnabled mta zimbraServiceEnabled snmp zimbraServiceEnabled ldap zimbraServiceEnabled spell
    Done
    Setting convertd stub...
    Setting local config convertd_stub_name to SocketTransformationStub
    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e convertd_stub_name=SocketTransformationStub
    Done
    *** Running as zimbra user: zmprov mcf zimbraComponentAvailable convertd zimbraComponentAvailable hotbackup zimbraComponentAvailable HSM
    *** Running as zimbra user: /opt/zimbra/bin/zmcontrol start
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mail.*something*.mine.nu:389)
    *** Running as zimbra user: /opt/zimbra/bin/zmsshkeygen
    *** Running as zimbra user: /opt/zimbra/bin/zmupdateauthkeys


    Operations logged to /tmp/zmsetup.log.13247


    Configuration complete - press return to exit
    This error (and no other one) appears 3 times:
    ERROR: service.FAILURE (system failure: getDirectContext) (cause: javax.naming.CommunicationException mail.*something*.mine.nu:389)
    What can I do?

    My /etc/hosts:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1 localhost.localdomain localhost
    Please help me

  2. #2
    raj's Avatar
    raj
    raj is offline Moderator
    Join Date
    Oct 2005
    Location
    USA, Canada and India
    Posts
    777
    Rep Power
    10

    Default

    other people had same errors in FC4 and 3.
    for me i got same errors with UNPACHED fresh FC4
    if followed
    Fedora Core 4 how-to

    and i was able to get it up on same FC 4 but this time UPDATED without this error.

    try that and it may work for you.

    Raj S Vrach
    i2k2systems.com

  3. #3
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default slapd

    comment out the loglevel 0 line in conf/slapd.conf, and run ldap start - check for tls errors in /var/log/zimbra.log

    I suspect that ldap may not like the self-signed cert...

    If that is the case - open 2 windows.

    In the first, ./install.sh -u to remove, ps axuww | grep zimbra, kill any processes, then ./install.sh

    When you get to the config menu:

    in the second window, edit /opt/zimbra/openldap/etc/openldap/slapd.conf, and remove the TLS lines from the end of the file. Also edit /opt/zimbra/bin/ldap, and remove the ldaps:// from the start line.

    In the first window, complete the configuration.

  4. #4
    goetzi is offline Project Contributor
    Join Date
    Nov 2005
    Location
    Austria
    Posts
    223
    Rep Power
    9

    Default

    I tried both (the things of raj and marcmac), but the errors are still the same

  5. #5
    goetzi is offline Project Contributor
    Join Date
    Nov 2005
    Location
    Austria
    Posts
    223
    Rep Power
    9

    Default

    I solved the problem by editing the /etc/hosts:

    before it was:
    Code:
    127.0.0.1               localhost.localdomain localhost
    with this it is working:
    Code:
    127.0.0.1               localhost.localdomain localhost mail.*something*.mine.nu
    I needed about 10 reinstalls, but now it is seems to work

  6. #6
    raj's Avatar
    raj
    raj is offline Moderator
    Join Date
    Oct 2005
    Location
    USA, Canada and India
    Posts
    777
    Rep Power
    10

    Default

    just a Q..
    if you have the FQDN on second line
    like...

    127.0.0.1 localhost.localdomain localhost
    xxx.xxx.xxx.xxx mail.*something*.mine.nu mail

    did it not work or you did not had the second line at all and you just added the HOSTNAME to first line..

    input is helpful to figure out as i also tried 4-5 install but i had the hostname in second line which worked in previous version

    Thanks
    Raj

  7. #7
    goetzi is offline Project Contributor
    Join Date
    Nov 2005
    Location
    Austria
    Posts
    223
    Rep Power
    9

    Default

    My /etc/hosts ony has this one line and it's working well.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 12-19-2006, 02:58 PM
  2. OS Requirements for Network Edition
    By mrichard in forum Installation
    Replies: 6
    Last Post: 11-22-2006, 02:52 PM
  3. Downgrading from Network Edition
    By tkrag@mostlyharmless.dk in forum Administrators
    Replies: 3
    Last Post: 07-03-2006, 01:11 PM
  4. Replies: 7
    Last Post: 04-21-2006, 09:59 AM
  5. Is Open Source edition upgradeble to Network edition
    By lkirkpatrick in forum Administrators
    Replies: 5
    Last Post: 04-03-2006, 12:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •