Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 22

Thread: Where does Zimbra look for missing files?

  1. #11
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    It sounds to me like you have a corrupt installation, as I mentioned earlier I've been installing ZCS on CentOS (clean installs of CentOS and upgraded servers) for a long time without problems. Is this actually a clean install of CentOS6 (minimum server install?) then fully updates or is it some form of VM?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  2. #12
    shieldfire is offline Intermediate Member
    Join Date
    Jun 2014
    Posts
    15
    Rep Power
    1

    Default

    Ah, that was usefull =)

    I get
    + for i in '$CORE_PACKAGES'
    + findLatestPackage zimbra-core
    + package=zimbra-core
    + latest=
    + himajor=0
    + himinor=0
    + histamp=0
    ++ ls './packages/zimbra-core*.deb'
    + files=
    + file=
    + '[' '!' -f '' ']'
    + echo 'ERROR: Required Core package zimbra-core not found in ./packages'
    It seems that the package for RHEL and CentOS looks for a deb-file? It won't find one on a rpm-based system ... so of course it will fail.
    I'm not finding any lines with *.deb in that file though...

    EDIT: this however comes from bin/get_plat_tag.sh which has a line that looks for a /etc/redhat-release file.
    In that it looks for
    grep "CentOS release 6" /etc/redhat-release > /dev/null 2>&1
    # Treat CentOS as RHEL
    if [ $? = 0 ]; then
    echo "RHEL6${i}"
    exit 0
    While my redhat-release file says

    CentOS Linux release 6.0 (Final)
    Another EDIT: changing the line in this file also seems to solve the mystery of the missing requirements.

    Checking for prerequisites...
    FOUND: NPTL
    FOUND: nc-1.84-22
    FOUND: sudo-1.7.2p2-9
    FOUND: libidn-1.18-2
    FOUND: gmp-4.3.1-7
    MISSING: libaio
    FOUND: /usr/lib64/libstdc++.so.6
    Last edited by shieldfire; 06-05-2014 at 04:17 AM.

  3. #13
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    Quote Originally Posted by shieldfire View Post
    Ah, that was usefull =)CentOS Linux release 6.0 (Final)
    Why have you not updated your server to the most recent CentOS 6.5?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #14
    shieldfire is offline Intermediate Member
    Join Date
    Jun 2014
    Posts
    15
    Rep Power
    1

    Default

    Because I'm installing stuff on it - haven't gotten that far yet. It was delivered as a 6.0 server.

  5. #15
    moren is offline Trained Alumni
    Join Date
    Jun 2007
    Location
    Halmstad, Sweden
    Posts
    57
    Rep Power
    8

    Default

    From the Release Notes:

    Preparing Your OS
    Before you upgrade ZCS, Zimbra recommends that the operating system is
    updated with the latest patches that have been tested with ZCS.


    I have installed Zimbra on RHEL over many years and never seen those problems.
    (RHEL 4.x, 5.x and 6.x and Zimbra as old as version 4.5.x. Have 8.0.6 in production, multi-server, right now)
    Regards
    Morén
    8.0.5_P1 / NE / RHEL6_64

  6. #16
    Brad_C is offline Loyal Member
    Join Date
    Apr 2012
    Posts
    91
    Rep Power
    3

    Default

    File that trick away for the future. It's really, really handy to watch batch files being interpreted line by line when things are going wrong. I only wish I could do the same thing for make.

  7. #17
    shieldfire is offline Intermediate Member
    Join Date
    Jun 2014
    Posts
    15
    Rep Power
    1

    Default

    Agreed, and thanks everyone for suggestions. Now at last the server installed =)

  8. #18
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,262
    Rep Power
    10

    Default

    There were serious issues with RHEL/CentOS in 6.2 and previous. You must run 6.3 and later. You should update to 6.3 or later PRIOR to installing Zimbra.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  9. #19
    metux is offline Senior Member
    Join Date
    Feb 2012
    Posts
    72
    Rep Power
    3

    Default

    Such things usually happen, when software isn't packaged directly for certain distros
    (_including_ proper package repositories) and instead people hack up strange
    installation programs that should work for all distros (which they obviously dont).

    This is also the reason why then also ship on instances of tons of 3rdparty libs,
    just because on some distro version there had been some bug in package X
    several years ago. Even zimbra uses packages (somehow), it still pushes them
    in using low-level tools (dpkg, rpm, etc), instead of using repositories.

    Such things are really sucking for the operators.

    (yes, I know, other companies haven't ever heared of packaging at all)

  10. #20
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,262
    Rep Power
    10

    Default

    I suggest you know what you're talking about before responding. The issues in 6.2 and earlier were related to serious kernel bugs, and have zero to do with packaging, etc.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 12-09-2010, 07:09 AM
  2. [SOLVED] missing zdesktop*.sh files
    By Neoryder in forum Developers
    Replies: 1
    Last Post: 07-02-2009, 09:55 AM
  3. Noob Here need help with missing Lib files
    By inidgoseth in forum Installation
    Replies: 1
    Last Post: 03-06-2008, 10:32 AM
  4. Replies: 4
    Last Post: 01-26-2008, 01:33 AM
  5. Missing files in RC1?
    By adoroar in forum Installation
    Replies: 2
    Last Post: 11-28-2007, 08:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •