Results 1 to 2 of 2

Thread: Error in upgrade M1->M2

  1. #1
    DeusExLibris is offline New Member
    Join Date
    Nov 2005
    Posts
    3
    Rep Power
    9

    Default Error in upgrade M1->M2

    Not sure where else to post this. When upgrading from M1 to M2, I got an error during package checking because there were multiple versions of a required package installed on my system. For example, rpm -q -a | grep fetchmail returned:

    [root@mail zcs]# rpm -q -a | grep fetchmail
    fetchmail-6.2.5-6
    fetchmail-6.2.5-7.fc3.1

    This resulted in the following message from ./install.sh:

    Checking for prerequisites...
    NPTL...FOUND
    libidn...FOUND libidn-0.5.6-1
    curl...FOUND curl-7.12.3-4.fc3
    fetchmail..../util/utilfunc.sh: line 262: [: too many arguments
    MISSING
    gmp...FOUND gmp-4.1.4-3
    /usr/lib/libstdc++.so.5...FOUND

    When I removed fetchmail-6.2.5-6, the package check ran fine.

    No need to respond as I have found the problem and resolved it, but wanted others who may run into this problem to have this info.

  2. #2
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default thanks

    Looks like I forgot to quote something - thanks for the report.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Upgrade 4.5.4 to 4.5.5 questions
    By dlochart in forum Zimbra Connector for Outlook
    Replies: 11
    Last Post: 05-14-2007, 02:44 AM
  2. Backup directory deleted during upgrade!
    By dlochart in forum Installation
    Replies: 2
    Last Post: 02-25-2007, 07:38 AM
  3. 4.01 to 4.02 upgrade problem (with solution)
    By criley in forum Migration
    Replies: 2
    Last Post: 09-28-2006, 11:36 PM
  4. 3.1.3OS Upgrade Problem
    By mcevoys in forum Installation
    Replies: 7
    Last Post: 06-16-2006, 09:47 AM
  5. M1 -> M2 Upgrade Scripts
    By KevinH in forum Announcements
    Replies: 57
    Last Post: 12-15-2005, 10:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •