Results 1 to 4 of 4

Thread: upgrade issues (4.0.2ga to 4.5.1ga)

  1. #1
    tachijuan is offline Senior Member
    Join Date
    Sep 2005
    Roswell, GA
    Rep Power

    Default upgrade issues (4.0.2ga to 4.5.1ga)

    So, I'm having issues going from 4.0.2ga to 4.5.1ga on an FC4 server.

    I tried the direct route and got the dreaded "no proc table mysql error". I recovered from a backup, ran workaround SQL script and got:

    _zimbra@stud:~\[zimbra@stud ~]$ mysql -f -Dmysql -u root --password=`zmlocalconfig -s -m nokey mysql_root_password` < /opt/zi mbra/mysql/share/mysql/mysql_fix_privilege_tables.sql 
    ERROR 1060 (42S21) at line 22: Duplicate column name 'File_priv'
    ERROR 1060 (42S21) at line 28: Duplicate column name 'Grant_priv'
    ERROR 1060 (42S21) at line 29: Duplicate column name 'Grant_priv'
    ERROR 1060 (42S21) at line 30: Duplicate column name 'Grant_priv'
    ERROR 1060 (42S21) at line 41: Duplicate column name 'ssl_type'
    ERROR 1054 (42S22) at line 87: Unknown column 'Type' in 'columns_priv'
    ERROR 1060 (42S21) at line 93: Duplicate column name 'type'
    ERROR 1060 (42S21) at line 103: Duplicate column name 'Show_db_priv'
    ERROR 1060 (42S21) at line 120: Duplicate column name 'max_questions'
    ERROR 1060 (42S21) at line 130: Duplicate column name 'Create_tmp_table_priv'
    ERROR 1060 (42S21) at line 133: Duplicate column name 'Create_tmp_table_priv'
    ERROR 1061 (42000) at line 141: Duplicate key name 'Grantor'
    _zimbra@stud:~\[zimbra@stud ~]$ mysql -f -Dmysql -u root --password=`zmlocalconfig -s -m nokey mysql_root_password`
    Reading table information for completion of table and column names
    You can turn off this feature to get a quicker startup with -A
    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 7 to server version: 4.1.20-log
    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
    mysql> show tables;
    | Tables_in_mysql           |
    | columns_priv              |
    | db                        |
    | func                      |
    | help_category             |
    | help_keyword              |
    | help_relation             |
    | help_topic                |
    | host                      |
    | tables_priv               |
    | time_zone                 |
    | time_zone_leap_second     |
    | time_zone_name            |
    | time_zone_transition      |
    | time_zone_transition_type |
    | user                      |
    15 rows in set (0.00 sec)
    mysql> ^DBye

    So since, that didn't work, I tried doing an upgrade from 4.0.2 to 4.0.5. That seemed to work, but I got the exact same error as above. Even worse, I got the following errors when I tried to start up after the 4.0.2. to 4.0.5 upgrade:

    [zimbra@stud ~]$ zmcontrol start
    	Starting ldap...Done.
    	Starting logger...Done.
    	Starting mailbox...Done.
    	Starting antispam...Done.
    	Starting antivirus...Done.
    	Starting snmp...Done.
    	Starting spell...Done.
    	Starting mta...FAILED
    postmap: fatal: bad numerical configuration: message_size_limit = 
    postalias: fatal: bad numerical configuration: message_size_limit = 
    postfix failed to start
    [zimbra@stud ~]$ zmcontrol status
    	antispam                Running
    	antivirus               Stopped
    		zmclamdctl is not running
    	ldap                    Running
    	logger                  Running
    	mailbox                 Stopped
    		tomcat is not running
    	mta                     Stopped
    		postfix is not running
    	snmp                    Running
    	spell                   Running
    [zimbra@stud ~]$ zmcontrol stop
    	Stopping mta...Done
    	Stopping spell...Done
    	Stopping snmp...Done
    	Stopping antivirus...Done
    	Stopping antispam...Done
    	Stopping imapproxy...Done
    	Stopping mailbox...Done
    	Stopping logger...Done
    	Stopping ldap...Done
    [zimbra@stud ~]$ logout

    FYI - this is an install that started with 3.0.0GA and has progressed through all of the upgrades since then. Up until now, I've never had an issue during the upgrade process.

    I'm now recovering, again, my backup of 4.0.2 and going back to that.

    What do you guys think is going on?

    Help! - TIA

    ps One thing I did notice during the 4.0.2 upgrade to 4.0.5 is this error:
    Restoring existing configuration file from /opt/zimbra/.saveconfig/
    chown: cannot access `/opt/zimbra/conf/perdition.pem': No such file or directory
    chown: cannot access `/opt/zimbra/conf/perdition.key': No such file or directory
    Operations logged to /tmp/zmsetup.log.5028
    Setting defaults...Setting defaults from existing config...Done
    Upgrading from 4.0.2_GA_362 to 4.0.5_GA_518
    Sat Feb 17 14:46:00 2007: Stopping zimbra services
    Sat Feb 17 14:46:14 2007: Starting mysql
    Sat Feb 17 14:46:21 2007: Checking logger mysql status
    Sat Feb 17 14:46:23 2007: Starting logger mysql
    Sat Feb 17 14:46:25 2007: SELECT value FROM config WHERE name = 'db.version'
    This appears to be 4.0.2_GA
    Last edited by tachijuan; 02-17-2007 at 01:15 PM. Reason: added the perdition stuff

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Thatcher, AZ
    Rep Power


    Is your backup working?

    If so, wait until next week. We'll be releasing 4.5.2 which resolves this issue.


  3. #3
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Rep Power

    Default 4.5.2 upgrade should include a solution

    The 4.5.2 upgrade (this coming week, I believe) should include a MySQL proc table fix as part of the upgrade. If you can wait a few days, that might be easiest...
    Bugzilla - Wiki - Downloads - Before posting... Search!

  4. #4
    tachijuan is offline Senior Member
    Join Date
    Sep 2005
    Roswell, GA
    Rep Power

    Default backup is working

    Thank God that I do storage for a living. My backups are good and working.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 4.0.2GA to 4.5.4GA upgrade also fails
    By tachijuan in forum Installation
    Replies: 3
    Last Post: 03-31-2007, 02:09 PM
  2. Replies: 7
    Last Post: 01-24-2007, 11:03 PM
  3. Post Upgrade Issues - Logger berserk?
    By Coilcore in forum Administrators
    Replies: 1
    Last Post: 03-03-2006, 04:08 PM
  4. Upgrade Issues - FC3
    By drogers in forum Installation
    Replies: 30
    Last Post: 01-04-2006, 04:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts