Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Unable to access web client

  1. #1
    scervera is offline Junior Member
    Join Date
    Feb 2007
    Posts
    6
    Rep Power
    8

    Default Unable to access web client

    I have successfully installed Zimbra. I am able to manage my user accounts at this URL:

    https://server.example.com:7071/zimbraAdmin/

    I have my mail server setup on a internet access where my ISP blocks port 80. I changed the http port in the Zimbra configuration to port 8000. Port 7070 is not blocked.Port 443 is blocked too.

    I am unable to connect to the web client at any of these ports:

    https://server.example.com:7070/zimbra
    https://server.example.com:7070/

    http://server.example.com:7070/zimbra
    http://server.example.com:7070/

    https://server.example.com/zimbra
    https://server.example.com/

    http://server.example.com/zimbra
    http://server.example.com/

    http://server.example.com:8000/zimbra
    http://server.example.com:8000/

    https://server.example.com:8000/zimbra
    https://server.example.com:8000/

    I think that my issue is that I did not modify the port that SSL is going over. I would like to move this to port 8001. This is just a test server, so I am not worried about security so much as I just want to get up and running for evaluation purposes.

    So my questions are:
    1) Am I using the correct URLs to access the Web Client?
    2) How can I manually change the port that Zimbra is communicating over SSL (from 443 to 8001)? How would this affect the URL that I use?

    Thanks! I am a newbie.

  2. #2
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,316
    Rep Power
    13

    Default

    Hello,

    Quote Originally Posted by scervera View Post
    I have my mail server setup on a internet access where my ISP blocks port 80. I changed the http port in the Zimbra configuration to port 8000. Port 7070 is not blocked.Port 443 is blocked too.
    How did you change the port to 8000 ?

    The correct command is, while logged in as zimbra user :
    Code:
    zmprov ms SERVERNAME zimbraMailPort 8000
    Then you have to restart Zimbra, still being logged in as zimbra user :
    Code:
    tomcat stop
    tomcat start
    If you want to change the SSL port to 8001, you have to do this, still logged in as zimbra user :
    Code:
    zmprov ms SERVERNAME zimbraMaiSSLPort 8001
    tomcat stop
    tomcat start
    Or course SERVERNAME should be replace by the FQDN of your server 8)
    Last edited by Klug; 02-20-2007 at 11:02 AM.

  3. #3
    scervera is offline Junior Member
    Join Date
    Feb 2007
    Posts
    6
    Rep Power
    8

    Default Zimbra defaul password

    Thanks. I don't recall setting a password for the zimbra user. What is the default password?

  4. #4
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Are you talking about the bash/user password? If so, we don't set a password.

    If you're talking about the mysql/ldap zimbra user passwords, then you shouldn't really need them as they are already stored in the config.

    If for some reason that your config password is wrong, please go to the wiki and look up the article on how to reset the passwords.

    john

  5. #5
    dmangot is offline Intermediate Member
    Join Date
    Feb 2007
    Location
    San Francisco
    Posts
    19
    Rep Power
    8

    Default Can't get http port to listen

    I'm trying to get my zimbra to listen to port 8080 for http and 443 for https. Port 443 is working fine, but Tomcat never listens for 8080.

    I looked at the server.xml and 8080 is known, but it's commented out!


    HTML Code:
     <!-- user services connector, no SSL -->
            <!-- HTTPBEGIN
        <Connector port="8080"
            acceptCount="1024" URIEncoding="UTF-8"
            enableLookups="false" redirectPort="443"
            maxThreads="100" minSpareThreads="100" maxSpareThreads="100"/>
    HTTPEND -->


    My zimbraMailPort is set to 8080


    bin]$ ./zmprov gcf zimbraMailPort
    zimbraMailPort: 8080


    I think my zimbraMailMode is https, is that the problem? Does that disable http entirely? Will iCal synchronization work over https?

    Thanks.

  6. #6
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Server.xml get's rewritten each time. I wouldn't change that. . .

    try
    zmprov -e zimbramailport xxx

  7. #7
    dmangot is offline Intermediate Member
    Join Date
    Feb 2007
    Location
    San Francisco
    Posts
    19
    Rep Power
    8

    Default

    Quote Originally Posted by jholder View Post
    Server.xml get's rewritten each time. I wouldn't change that. . .
    I didn't. I just looked at the file.

    try
    zmprov -e zimbramailport xxx
    My zmprov doesn't seem to have a -e argument. I just get the help screen.
    I'm on Zimbra 4.5


  8. #8
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Sorry, wrong command. You're right:
    zmprov ms myserver.domain.com zimbraMailPort (port#)

    jh

  9. #9
    dmangot is offline Intermediate Member
    Join Date
    Feb 2007
    Location
    San Francisco
    Posts
    19
    Rep Power
    8

    Default Nope

    HTML Code:
    [zimbra@zimtest bin]$ ./zmprov ms zimtest.terracotta.lan zimbraMailPort 8080
    [zimbra@zimtest bin]$ ./tomcat stop
    [zimbra@zimtest bin]$ ./tomcat start
    [zimbra@zimtest bin]$ telnet zimtest.terracotta.lan 8080
    Trying 10.0.100.119...
    telnet: connect to address 10.0.100.119: Connection refused
    telnet: Unable to connect to remote host: Connection refused

    Does this have anything to do with zimbraMailMode?

  10. #10
    dmangot is offline Intermediate Member
    Join Date
    Feb 2007
    Location
    San Francisco
    Posts
    19
    Rep Power
    8

    Default Solved

    I set zimbraMailMode to "both" and port 8080 now answers.

    -Dave

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 12
    Last Post: 08-25-2010, 02:37 AM
  2. Need Help Troubleshooting Web Client Issues
    By soxfan in forum Administrators
    Replies: 2
    Last Post: 03-23-2007, 05:27 AM
  3. Moving Zimbra Web Client from one port to another.
    By oopstu in forum Administrators
    Replies: 2
    Last Post: 01-20-2007, 02:47 AM
  4. Nee a head start with IMAP client to access Zimbra mails
    By abhishek_agl in forum Developers
    Replies: 14
    Last Post: 12-08-2006, 03:14 AM
  5. Replies: 2
    Last Post: 05-20-2006, 09:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •