Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Accessing Zimbra From a Non-Standard Port

  1. #1
    andreychek is offline Special Member & Volunteer
    Join Date
    Oct 2005
    Location
    Harrisburg, Pennsylvania
    Posts
    155
    Rep Power
    9

    Default Accessing Zimbra From a Non-Standard Port

    Howdy,

    I just installed Zimbra M2.

    I have Zimbra running on port 80 on a server in my internal LAN, but I need to be able to access it from elsewhere. To make a long story short, the easiest way to do that was to forward a high port (8888 in my case) from the router to the internal Zimbra server.

    This had worked perfectly in M1.

    In M2, I can get as far as seeing the login screen. But when I attempt to enter my credentials, the following error shows up on the page:

    Code:
    An unknown application error has occurred. Please correct any
      errors and retry. If the problem persists, please contact your
      System Aministrator. (service.FAILURE)
    I poked around in the zimbra logs and didn't see anything. I then tacked on ?debug=1 to the url, and noticed that it was giving this error:

    Code:
    code: "service.FAILURE",
    detail: "system failure: Request not allowed on port 8888",
    method: "ZmCsfeCommand.prototype.invoke",
    msg: "Csfe service error"
    Is there a way to allow requests to a port other than 80, even when Zimbra is running on port 80 on the actual server? This is the only way I can actually reach this server remotely.

    Thanks,
    -Eric

  2. #2
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Check web.xml There should be a list of allowed ports in there.

  3. #3
    andreychek is offline Special Member & Volunteer
    Join Date
    Oct 2005
    Location
    Harrisburg, Pennsylvania
    Posts
    155
    Rep Power
    9

    Default

    Quote Originally Posted by KevinH
    Check web.xml There should be a list of allowed ports in there.
    Yup, that worked like a champ.

    For anyone else who runs into this, what I did was edit:

    /opt/zimbra/jakarta-tomcat-5.5.7/webapps/service/WEB-INF/web.xml

    And I modified:

    HTML Code:
    <param-value>80, 443, 7070, 7443</param-value>
    To read:

    HTML Code:
    <param-value>80, 443, 7070, 7443, 8888</param-value>
    I only did that for the SOAP servlet section, you may need to edit additional sections based on what functionality you're using. Just search for "allowed.ports" in that file.
    -Eric

  4. #4
    andreychek is offline Special Member & Volunteer
    Join Date
    Oct 2005
    Location
    Harrisburg, Pennsylvania
    Posts
    155
    Rep Power
    9

    Default

    Quote Originally Posted by KevinH
    Check web.xml There should be a list of allowed ports in there.
    As a followup, it seems this is no longer true.

    Well, it is, but it no longer works this way :-)

    Any changes you make to web.xml are now overwritten when Zimbra starts up. You can make those same changes in this file:

    /opt/zimbra/jakarta-tomcat-5.5.7/conf/service.web.xml.in

    And that will solve this problem.

    Have fun :-)
    -Eric

  5. #5
    savkar is offline Intermediate Member
    Join Date
    Mar 2006
    Posts
    17
    Rep Power
    9

    Default Setting a port other than 80

    Folks:

    I tried to modify the file indicated - /opt/zimbra/jakarta-tomcat-5.5.7/conf/service.web.xml.in..

    However, after adding port 81 to the allowed ports sections, and restarting zimbra, I still can't get to port 81.

    Anything else I need to do?

  6. #6
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Quote Originally Posted by savkar
    Folks:

    I tried to modify the file indicated - /opt/zimbra/jakarta-tomcat-5.5.7/conf/service.web.xml.in..

    However, after adding port 81 to the allowed ports sections, and restarting zimbra, I still can't get to port 81.

    Anything else I need to do?
    No need to do this anymore. You can now change the port via config. So a search or two this has been covered many times.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  7. #7
    savkar is offline Intermediate Member
    Join Date
    Mar 2006
    Posts
    17
    Rep Power
    9

    Default More than one port

    Actually, using zmprov ms only seems to permit me to change to one port. I was hoping to keep using both port 80 and 81...

    How would i go about doing that?

  8. #8
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    Hmm two ports... You'll have to edit server.xml and web.xml manually. Why do you need both ports? Could you just run Apache in front of zimbra and redirect traffic on 81 to port 80?
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  9. #9
    savkar is offline Intermediate Member
    Join Date
    Mar 2006
    Posts
    17
    Rep Power
    9

    Default redirecting with apache

    Well, the real issue is I have a web server on another machine already using port 80 with the same wan static IP address. So I want to use port 81 for Zimbra.

    I did try to set up with my other server a proxy for zimbra, but that was just way too slow at least the way i did it. Much better to access zimbra directly thru another port.

    If things could be set up so that zimbra did not have to run self contained with its own version of apache and tomcat, or if you had it so that we could use the apache/tomcat servers for serving up other web content, this would all be unnecessary frankly.

    Sunil

  10. #10
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    Location
    San Mateo, CA
    Posts
    4,789
    Rep Power
    18

    Default

    So if you just want Zimbra to run on port 80 switch it from port 80 to port 81.
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM
  2. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 12:45 PM
  3. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 12:58 AM
  4. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 10:47 AM
  5. Zimbra Processor Output
    By UltraFlux in forum Installation
    Replies: 3
    Last Post: 02-01-2006, 08:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •