Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Accessing Zimbra From a Non-Standard Port

  1. #11
    savkar is offline Intermediate Member
    Join Date
    Mar 2006
    Posts
    17
    Rep Power
    9

    Default

    U misunderstood. I wanted apache/tomcat to listen both to ports 80 and 81. 80 when I am accessing zimbra at home. 81 when I am accessing externally since 80 is already occupied.

    I cannot translate with my router both port and IP address, just IP address. It is really annoying and I might just go ahead and replace my netgear router with a real machine I use port forwarding on. But for now, if something comes into my network on port 80, I can forward to the web server.

    If something comes on 81, I can forward to zimbra. But I can't change the port # from 81 to 80 on the fly. Thus i need zimbra on the forward to be able to respond to http requests on 81.

  2. #12
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    http://tomcat.apache.org/tomcat-5.5-...nfig/http.html seems to indicate that you can only listen on one port - but it's possible that setting up a second connector in the Catalina service may do the trick:

    Modify tomcat/conf/server.xml.in and duplicate the first connector, setting the port value to 81 in the second instance. Then restart tomcat. You'll probably have to add 81 to the allowed ports in the web.xml.in files in tomcat/conf, too.

  3. #13
    savkar is offline Intermediate Member
    Join Date
    Mar 2006
    Posts
    17
    Rep Power
    9

    Default

    I guess I could also just bite the bullet, stick to port 81, and just bounce any requests mapped to a specific location to port 81 so I basically get the same effect as if I didn't have to explicitly type in a port on my URL...

    Which brings me to a related question. If I wanted to combine my web server functionality on the same zimbra machine I am using, could I basically just keep to port 81 for apache/tomcat for Zimbra, and simply install apache for my web pages operating on port 80?

    Sounds like this would work though I hate to think about the overhead waste in running basically two instances or more of apache2 when I would have loved to use the apache processes listening on port 81.

  4. #14
    marcmac is offline Expert Member
    Join Date
    Sep 2005
    Posts
    2,103
    Rep Power
    13

    Default

    zimbra doesn't have any apache processes listening on port 81. tomcat != apache. We've got an instance for the spellchecker, default port 7780.

  5. #15
    savkar is offline Intermediate Member
    Join Date
    Mar 2006
    Posts
    17
    Rep Power
    9

    Default

    Got it. Ok, so I can start apache running on 80 then without problems it sounds like.

    Out of curiousity, what about mysql. I do believe you have a mysql process running. WOuld i be able to run my own processes on the traditional port that is listened to or will this conflict?

    If it conflicts, is there a way to use the mysql setup from Zimbra for setting up my own other databases, etc.?

  6. #16
    bobby is offline Zimbra Employee
    Join Date
    Nov 2005
    Posts
    518
    Rep Power
    10

    Default

    you probably don't want to use zimbra mysql for other stuff, but it runs on non standard port anyway, so you can run the standard mysql also.

    for the port 80 issue, you could probably run your standard apache on port 80, doing nothing but redirecting to zimbra on port 81.

    how much ram do you have

  7. #17
    savkar is offline Intermediate Member
    Join Date
    Mar 2006
    Posts
    17
    Rep Power
    9

    Default

    That sounds perfect (both). THanks!

  8. #18
    burridge is offline New Member
    Join Date
    Apr 2006
    Posts
    3
    Rep Power
    9

    Default Allowing multiple ports

    Since there was some uncertainty wrt setting multiple ports, I decided to try marcmac's suggestion, which worked for me:

    1. Duplicate the Connector entry in server.xml.in, renaming port 7071 to 443.
    2. Modified the allowed.ports entry in service.web.xml.in to include 443 (comma delimited).
    3. Restarted Tomcat.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. zmtlsctl give LDAP error
    By sourcehound in forum Administrators
    Replies: 5
    Last Post: 03-11-2007, 03:48 PM
  2. dspam logrotate errors
    By michaeln in forum Users
    Replies: 7
    Last Post: 02-19-2007, 12:45 PM
  3. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 12:58 AM
  4. port 7071 not listening OS X install
    By leeimber in forum Installation
    Replies: 7
    Last Post: 03-21-2006, 10:47 AM
  5. Zimbra Processor Output
    By UltraFlux in forum Installation
    Replies: 3
    Last Post: 02-01-2006, 08:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •