Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Ubuntu Edgy: Configuration fails: No such file bss_file.c

  1. #1
    virtualwonder is offline Starter Member
    Join Date
    Feb 2007
    Posts
    2
    Rep Power
    8

    Default Ubuntu Edgy: Configuration fails: No such file bss_file.c

    I (Zimbra newbie) am trying to install Zimbra on Ubuntu Edgy and get the following error after the system tries to start ldap:

    Creating SSL certificate...Done
    Initializing ldap...TLS: error:02001002:system library:fopen:No such file or directory bss_file.c:352
    TLS: error:20074002:BIO routines:FILE_CTRL:system lib bss_file.c:354
    TLS: error:140B0002:SSL routines:SSL_CTX_use_PrivateKey_file:system lib ssl_rsa.c:648
    main: TLS init def ctx failed: -1
    ERROR - failed to start slapd

    FAILED (1)

    Just in case nobody knows a solution:
    Is there any way to use Zimbra without ssl and tls, because I just want to test Zimbra and do not need that level of security?

    thanks...

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,485
    Rep Power
    56

    Default

    Have a look in /opt/zimbra/conf/slapd.conf - there should be a couple of entries in there for slapd.crt & slapd.key Those entries should be located in /opt/zimbra/conf - is that what your conf file has? Any other errors in the linstall log file before this?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    greywolf is offline Intermediate Member
    Join Date
    Feb 2007
    Location
    Richmond, Virginia
    Posts
    18
    Rep Power
    8

    Default

    I'm having the same error. The entries are present in the slapd.conf but the two files do not exist in the /opt/zimbra/conf direcotory. (slapd.crt , slapd.key) No other errors appear in my log file.

  4. #4
    greywolf is offline Intermediate Member
    Join Date
    Feb 2007
    Location
    Richmond, Virginia
    Posts
    18
    Rep Power
    8

    Default

    After trying various things I did see this error in my log file:

    Creating SSL certificate...
    *** Running as zimbra user: cd /opt/zimbra; zmcreatecert

    /opt/zimbra/bin/zmcreatecert: 27: source: not found
    Done

    Initializing ldap...
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit

    FAILED (1)

    ERROR

    Configuration failed


    Thanks for any help.

    Steve

  5. #5
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,485
    Rep Power
    56

    Default

    What happens if you try running those commands now (as the zimbra user)?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  6. #6
    greywolf is offline Intermediate Member
    Join Date
    Feb 2007
    Location
    Richmond, Virginia
    Posts
    18
    Rep Power
    8

    Default

    Still the same errors:

    zimbra@emily:~$ zmcreatecert
    /opt/zimbra/bin/zmcreatecert: 27: source: not found

    zimbra@emily:~$ /opt/zimbra/libexec/zmldapinit
    TLS: error:02001002:system library:fopen:No such file or directory bss_file.c:352
    TLS: error:20074002:BIO routines:FILE_CTRL:system lib bss_file.c:354
    TLS: error:140B0002:SSL routines:SSL_CTX_use_PrivateKey_file:system lib ssl_rsa.c:648
    main: TLS init def ctx failed: -1
    ERROR - failed to start slapd

    Running an strace on zmcreatecert looks like it needs something, keeps looking for a source directory or a library.

    I attached the strace output.

    Thanks,
    Attached Files Attached Files

  7. #7
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,485
    Rep Power
    56

    Default

    Is this, by any chance, a 64bit operating system?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    greywolf is offline Intermediate Member
    Join Date
    Feb 2007
    Location
    Richmond, Virginia
    Posts
    18
    Rep Power
    8

    Default

    No it's 32 bit. Maybe I'm missing a library?

  9. #9
    doublec is offline Junior Member
    Join Date
    Jan 2007
    Posts
    8
    Rep Power
    8

    Default

    The Zimbra install scripts use 'source'. Newer versions of Ubuntu (I think Edgy was the first) use 'dash' as the shell which doesn't have 'source'.

    Change to using 'bash' and run install.sh and things should work:

    sudo rm /bin/sh
    sudo ln -s /bin/bash /bin/sh

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,485
    Rep Power
    56

    Default

    Quote Originally Posted by doublec View Post
    Change to using 'bash' and run install.sh and things should work:
    Oh, that problem. That's a real pain, if it's not in the wiki would someone like to put that in there?
    Last edited by phoenix; 02-15-2007 at 04:32 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. centos 5 zimbra 4.5.6 no statistics
    By rutman286 in forum Installation
    Replies: 9
    Last Post: 08-14-2007, 09:30 AM
  2. Opensource backup Question.
    By nfear24 in forum Administrators
    Replies: 3
    Last Post: 03-31-2007, 11:47 PM
  3. Replies: 5
    Last Post: 03-01-2007, 03:20 AM
  4. Traslation SVN tree status
    By meikka in forum I18N/L10N - Translations
    Replies: 7
    Last Post: 02-13-2007, 11:13 AM
  5. M3 problem with shares
    By titangears in forum Users
    Replies: 4
    Last Post: 01-12-2006, 01:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •