Results 1 to 5 of 5

Thread: Servlets failing

  1. #1
    michael-fig is offline Junior Member
    Join Date
    May 2006
    Posts
    9
    Rep Power
    8

    Unhappy Servlets failing

    Hi,

    My company has been successfully using Zimbra for the last
    6 months or so. Last weekend, we upgraded from 4.0.1 to
    4.5.0 now running on Ubuntu. This seemed to work at first,
    and then we started getting errors.
    Users cannot log in anymore, they fail with:

    Error A network service error has occured (zclient/io)

    When I run "zmprov", I get the following error message:

    [...] HTTP Status 404 - Servlet AdminServlet is not
    available [...]

    IMAP and POP ports allow connections, but don't respond to
    any commands.

    Are there any debug logs or anything else that can show
    what the error is?

    Please help, or the Powers That Be may force us to migrate
    to Exchange.

  2. #2
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    11

    Default Errors in logfiles?

    What's the first error you're seeing in mailbox.log?
    Bugzilla - Wiki - Downloads - Before posting... Search!

  3. #3
    michael-fig is offline Junior Member
    Join Date
    May 2006
    Posts
    9
    Rep Power
    8

    Default Heap space error

    Yes, the above advice was correct:

    Code:
    2007-02-06 11:10:05,694 FATAL [main] [] soap - Unable to start servlet java.lang.OutOfMemoryError: Java heap space
    2007-02-06 11:10:05,694 INFO  [main] [] [/service] - Marking servlet SoapServlet as unavailable
    2007-02-06 11:10:05,695 ERROR [main] [] [/service] - Servlet /service threw load () exception
    javax.servlet.UnavailableException: Java heap space
    ...
    I increased the size of the Java heap with the following command:

    Code:
    # su - zimbra
    $ zmlocalconfig -e tomcat_java_heap_memory_percent=60
    Then, after restarting zimbra, everything seems fine.

    Thanks!

  4. #4
    rvanscherpe is offline Member
    Join Date
    Jul 2006
    Posts
    12
    Rep Power
    8

    Default Help!

    I'm getting the same thing:


    007-03-22 09:43:39,763 FATAL [main] [] soap - Unable to start servlet
    java.lang.OutOfMemoryError: Java heap space
    2007-03-22 09:43:39,786 INFO [main] [] [/service] - Marking servlet SoapServlet as unavailable
    2007-03-22 09:43:39,787 ERROR [main] [] [/service] - Servlet /service threw load() exception
    javax.servlet.UnavailableException: Java heap space
    at com.zimbra.soap.SoapServlet.init(SoapServlet.java: 118)
    at javax.servlet.GenericServlet.init(GenericServlet.j ava:211)
    at org.apache.catalina.core.StandardWrapper.loadServl et(StandardWrapper.java:1105)
    at org.apache.catalina.core.StandardWrapper.load(Stan dardWrapper.java:932)
    at org.apache.catalina.core.StandardContext.loadOnSta rtup(StandardContext.java:3915)
    at org.apache.catalina.core.StandardContext.start(Sta ndardContext.java:4176)
    at org.apache.catalina.core.ContainerBase.addChildInt ernal(ContainerBase.java:759)
    at org.apache.catalina.core.ContainerBase.addChild(Co ntainerBase.java:739)
    at org.apache.catalina.core.StandardHost.addChild(Sta ndardHost.java:524)
    at org.apache.catalina.startup.HostConfig.deployDirec tory(HostConfig.java:910)
    at org.apache.catalina.startup.HostConfig.deployDirec tories(HostConfig.java:873)
    at org.apache.catalina.startup.HostConfig.deployApps( HostConfig.java:474)
    at org.apache.catalina.startup.HostConfig.start(HostC onfig.java:1118)
    at org.apache.catalina.startup.HostConfig.lifecycleEv ent(HostConfig.java:310)
    at org.apache.catalina.util.LifecycleSupport.fireLife cycleEvent(LifecycleSupport.java:119)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1020)
    at org.apache.catalina.core.StandardHost.start(Standa rdHost.java:718)
    at org.apache.catalina.core.ContainerBase.start(Conta inerBase.java:1012)
    at org.apache.catalina.core.StandardEngine.start(Stan dardEngine.java:442)
    at org.apache.catalina.core.StandardService.start(Sta ndardService.java:450)
    at org.apache.catalina.core.StandardServer.start(Stan dardServer.java:700)
    at org.apache.catalina.startup.Catalina.start(Catalin a.java:551)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at org.apache.catalina.startup.Bootstrap.start(Bootst rap.java:275)
    at org.apache.catalina.startup.Bootstrap.main(Bootstr ap.java:406)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at com.zimbra.cs.launcher.TomcatLauncher.start(Tomcat Launcher.java:52)
    at com.zimbra.cs.launcher.TomcatLauncher.main(TomcatL auncher.java:74)
    2007-03-22 09:43:39,916 INFO [main] [] soap - Servlet AdminServlet starting up

    I tried zmlocalconfig -e tomcat_java_heap_memory_percent=60
    but I keep getting the above error message.

    Thanks.

    Ron.

  5. #5
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    How much RAM is on your server?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Installation with Vista and Outlook 2003 failing
    By iain in forum Zimbra Connector for Outlook
    Replies: 3
    Last Post: 09-20-2007, 12:20 PM
  2. Replies: 5
    Last Post: 08-03-2007, 08:20 AM
  3. Replies: 5
    Last Post: 08-02-2007, 04:55 PM
  4. Zimlet upload failing
    By russgalleywood in forum Zimlets
    Replies: 6
    Last Post: 03-09-2007, 05:59 AM
  5. iCal sync failing with shared calendars
    By travisbell in forum CalDAV / CardDAV / iSync
    Replies: 10
    Last Post: 10-19-2006, 08:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •