Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 29

Thread: Unable to install on Centos - LDAP errors

  1. #11
    phirephoto is offline Intermediate Member
    Join Date
    Jul 2013
    Posts
    16
    Rep Power
    1

    Default

    Quote Originally Posted by quanah View Post
    Oh, I got it from one of those other threads.

    In any case, is slapd running at all? (ps -eaf | grep slapd)

    If not, try starting it by hand to see what error is reported (ldap start as the zimbra user)

    --Quanah
    Ahh yes -

    $ ldap start
    ldap_url and ldap_master_url cannot be the same on an ldap replica

    Looking at [SOLVED] Installation on CentOS 5


    $ zmlocalconfig ldap_master_url ldap_url zimbra_server_hostname
    ldap_master_url =
    ldap_url =
    zimbra_server_hostname = localhost

    Running zmldapinit gives no errors, but still cannot start up.

  2. #12
    phirephoto is offline Intermediate Member
    Join Date
    Jul 2013
    Posts
    16
    Rep Power
    1

    Default

    Quote Originally Posted by phirephoto View Post
    Ahh yes -

    $ ldap start
    ldap_url and ldap_master_url cannot be the same on an ldap replica

    Looking at [SOLVED] Installation on CentOS 5


    $ zmlocalconfig ldap_master_url ldap_url zimbra_server_hostname
    ldap_master_url =
    ldap_url =
    zimbra_server_hostname = localhost

    Running zmldapinit gives no errors, but still cannot start up.

    Ok, did a uninstall and reinstall, now ldap starts but zmcontrol still fails

    $ whoami
    zimbra
    [zimbra@vps me]$ ldap start
    Started slapd: pid 22490
    [zimbra@vps me]$ ps -eaf | grep slapd
    zimbra 22490 1 0 14:47 ? 00:00:00 /opt/zimbra/openldap/sbin/slapd -l LOCAL0 -u zimbra -h ldap://vps.mydomain.com:389 ldapi:/// -F /opt/zimbra/data/ldap/config
    zimbra 22501 21914 0 14:47 pts/0 00:00:00 grep slapd
    [zimbra@vps me]$ zmcontrol start
    Host vps.mydomain.com
    Unable to determine enabled services from ldap.
    Unable to determine enabled services. Cache is out of date or doesn't exist.

  3. #13
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    You need to look at your install log to see why it is having problems during installation. On a correctly configured host, they will be filled out appropriately by the end of installation.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  4. #14
    phirephoto is offline Intermediate Member
    Join Date
    Jul 2013
    Posts
    16
    Rep Power
    1

    Default

    Quote Originally Posted by quanah View Post
    You need to look at your install log to see why it is having problems during installation. On a correctly configured host, they will be filled out appropriately by the end of installation.
    Ok, I'll be honest, I'm a novice at this, and this system is just for me and a few other people (friends / family). So it's a fairly 'new' install, but I probably installed a few things that may be conflicting.

    I'd prefer NOT to start over my O/S install. So - any suggestions on what to do to make a 'clean' install of the OS short of clean install? Basically I'm looking for a suggestion of say "Remove your install of mysql, PHP and sendmail, Zimbra installs its own, and your install is causing a problem."

    Short of that, I'm sure for a Zimbra expert this would be a 20 minute job if anyone is willing to assist with this remotly for a reasonable fee. Again, this is still an evaluation, so tough for me to justify a lot of money or more time, but I like the feature set in Zimbra

    Thanks!

  5. #15
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    Again, you need to examine your installation log to see what it says is the problem with your server. Zimbra creates the log in /tmp.

    --Quanah
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  6. #16
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    You could start by going to the Split DNS article and posting the output of all the commands in the 'Verify...' section of that article. You mentioned that you would be getting a 'proper' domain name, do you have that yet or is it still your 'munged' one?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #17
    phirephoto is offline Intermediate Member
    Join Date
    Jul 2013
    Posts
    16
    Rep Power
    1

    Default

    Quote Originally Posted by phoenix View Post
    You could start by going to the Split DNS article and posting the output of all the commands in the 'Verify...' section of that article. You mentioned that you would be getting a 'proper' domain name, do you have that yet or is it still your 'munged' one?
    Well I do have a proper domain, what I meant is it's not WWW . mydomain - it's vps.mydomain. Mail is not yet pointing to this server, since my mail server is still live, I need to be able to get mail, so mail for my domain goes to another server.

    I'm not running split dns - this is a VPS with a public IP. But here's the output from verify - I've munged mydomain to mydomain.com , and the vps host to vpshost.net and munged the IP's.


    dig mydomain mx

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> mydomain mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 62333
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 2, ADDITIONAL: 9

    ;; QUESTION SECTION:
    ;mydomain.com IN MX

    ;; ANSWER SECTION:
    mydomain.com 300 IN MX 5 alt2.aspmx.l.google.com.
    mydomain.com 300 IN MX 10 aspmx2.googlemail.com.
    mydomain.com 300 IN MX 10 aspmx3.googlemail.com.
    mydomain.com 300 IN MX 1 aspmx.l.google.com.
    mydomain.com 300 IN MX 5 alt1.aspmx.l.google.com.

    ;; AUTHORITY SECTION:
    mydomain.com 300 IN NS ns1.vpshost.net.
    mydomain.com 300 IN NS ns2.vpshost.net.

    ;; ADDITIONAL SECTION:
    aspmx.l.google.com. 143 IN A 74.125.25.27
    alt1.aspmx.l.google.com. 143 IN A 74.125.130.27
    alt2.aspmx.l.google.com. 143 IN A 173.194.74.27
    aspmx2.googlemail.com. 143 IN A 74.125.134.26
    aspmx3.googlemail.com. 143 IN A 173.194.74.27
    ns1.vpshost.net. 300 IN A #.#.#.#
    ns1.vpshost.net. 300 IN AAAA #:#:#:226::2
    ns2.vpshost.net. 300 IN A #.#.#.#
    ns2.vpshost.net. 300 IN AAAA 2001:470:4a::f


    # dig mydomain.com any

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.17.rc1.el6_4.4 <<>> mydomain.com any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 38577
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;mydomain.com. IN ANY

    ;; AUTHORITY SECTION:
    com. 900 IN SOA a.gtld-servers.net. nstld.verisign-grs.com. 1374600417 1800 900 604800 86400

    ;; Query time: 6 msec
    ;; SERVER: #.#.#.##53(#.#.#.#)
    ;; WHEN: Tue Jul 23 10:25:00 2013
    ;; MSG SIZE rcvd: 110


    # host vps.mydomain.com
    vps.mydomain.com has address public.ip

  8. #18
    phirephoto is offline Intermediate Member
    Join Date
    Jul 2013
    Posts
    16
    Rep Power
    1

    Default

    sorry missed:

    # cat /etc/resolv.conf
    # Generated by NetworkManager
    search mydomain.com
    nameserver public.ip
    [root@vps eplatt]# cat /etc/hosts
    #127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 www.mydomain.com
    #::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
    #127.0.0.1 www.mydomain.com www
    #127.0.0.1 autoreply.vps.mydomain.com
    #207.135.97.71 mydomain.com www
    #127.0.0.1 localhost localhost.localdomain www.mydomain.com www mydomain.com autho.mydomain.com

    127.0.0.1 localhost.localdomain localhost
    public.ip vps.mydomain.com vps

  9. #19
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    Again... install.log ....

    --Quanah
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  10. #20
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by phirephoto View Post
    I'm not running split dns - this is a VPS with a public IP. But here's the output from verify - I've munged mydomain to mydomain.com , and the vps host to vpshost.net and munged the IP's.
    OK, well this output shows no DNS A or MX records and Zimbra requires those to find the server - and I'm assuming that this "dig mydomain mx" is your valid domain name and the domain name you want to use on the Zimbra server, is that correct?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 10-01-2009, 12:58 PM
  2. Unable to install ZCS on a Centos 5, need help
    By ronian in forum Installation
    Replies: 11
    Last Post: 08-11-2009, 06:07 AM
  3. Replies: 10
    Last Post: 07-19-2008, 04:57 PM
  4. LDAP Errors during Install
    By cchill in forum Installation
    Replies: 4
    Last Post: 04-10-2008, 12:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •