Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: Can't install 7.2.2GA on Scientific 6.4

  1. #11
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Quote Originally Posted by Olorin View Post
    Up to you guys, whether you want to debug this, but it's definitely easy to reproduce
    As I mentioned earlier, SL is not a supported distribution and I don't believe you'd get it fixed but feel free to file a bug report in bugzilla.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  2. #12
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    FWIW, I've just installed a clean copy of SL in a VM and get the following when trying to install zcs-7.2.2_GA_2852.RHEL6_64.20121204211835.tgz:

    Code:
    Checking for prerequisites...
         FOUND: NPTL
         MISSING: sudo
         MISSING: libidn11
         MISSING: libgmp3c2
         MISSING: libstdc++6
    Checking for suggested prerequisites...
    
    ###ERROR###
    
    One or more prerequisite packages are missing.
    Please install them before running this installer.
    
    Installation cancelled.
    
    [root@scientific zcs]# cat /etc/redhat-release
    Scientific Linux release 6.4 (Carbon)
    Needless to say I did check before the install and those packages are all installed. I think there's something wrong with Scientific Linux rather than the ZCS installer. I've also just installed the same version of ZCS on a CentOS 6.4 machine without any problems.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #13
    Olorin is offline Senior Member
    Join Date
    May 2007
    Posts
    52
    Rep Power
    7

    Default

    curiouser and curiouser

  4. #14
    Brad_C is offline Senior Member
    Join Date
    Apr 2012
    Posts
    73
    Rep Power
    3

    Default

    Not curious at all. By the code snippet you posted the redhat variants dont have /etc/lsb-release so dpkg never gets called. Obviously your later version of scientific Linux does. It's not magic, and it's not a bug. Move that file aside while you install zimbra and be happy.

  5. #15
    Olorin is offline Senior Member
    Join Date
    May 2007
    Posts
    52
    Rep Power
    7

    Default

    Quote Originally Posted by Brad_C View Post
    Not curious at all. By the code snippet you posted the redhat variants dont have /etc/lsb-release so dpkg never gets called. Obviously your later version of scientific Linux does. It's not magic, and it's not a bug. Move that file aside while you install zimbra and be happy.
    you're right, that worked, if you're ever out in the North Alberta boonies, a beer's on me! That was so obvious, in retrospect. Seems like some of the most recent SL updates added that file in

  6. #16
    prashant's Avatar
    prashant is offline Zimbra Employee
    Join Date
    Jul 2007
    Posts
    343
    Rep Power
    7

    Default

    Yeah that seems to be problem. Confirmed with support and found that Redhat made some changes with RHN in latest version 6.4. Workaround : RHN registration will take away the problem.
    ~=Prashant=~

  7. #17
    prashant's Avatar
    prashant is offline Zimbra Employee
    Join Date
    Jul 2007
    Posts
    343
    Rep Power
    7

  8. #18
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    SL is not a supported platform. So no one will be spending any time on figuring out why it doesn't work to run Zimbra on something that isn't supported. If you really want to run it on SL, then it is up to you to modify get_plat_tag.sh to function on that system.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  9. #19
    Olorin is offline Senior Member
    Join Date
    May 2007
    Posts
    52
    Rep Power
    7

    Default

    this looks like a new addition in RHEL as well, /etc/lsb-release is empty, but it is there, so relying on the file's existence to determine the platform is debian based is wrong in any case.

    //and congrats on getting away from vmware's clutches

  10. #20
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    Well, for RH, we rely on /etc/redhat-release. Did SL do away with it?
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Page 2 of 3 FirstFirst 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 03-15-2010, 04:04 PM
  2. [SOLVED] Test ZCS Install routing to Live Install
    By alapierre in forum Installation
    Replies: 7
    Last Post: 10-29-2009, 02:13 PM
  3. Replies: 1
    Last Post: 02-22-2008, 12:36 AM
  4. Problem installing on Scientific Linux 5
    By bsdrocker in forum Installation
    Replies: 2
    Last Post: 08-20-2007, 11:21 PM
  5. Replies: 5
    Last Post: 06-14-2007, 10:14 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •