Results 1 to 4 of 4

Thread: External LDAP

  1. #1
    jaguado is offline Junior Member
    Join Date
    Jan 2007
    Posts
    9
    Rep Power
    8

    Default External LDAP

    Hi, just a couple of days ago I downloaded the Network Edition of ZCS 4.0 to analyze and test for a posible purchase in the incoming months. We already have an OpenLDAP authentication server so I really need to integrate Zimbra with this one. After reading the wiki and the forums I managed to provide a working filter string. The test run without problems but when I am trying to use the same user/password I got user/pass incorrect. Any ideas on what is going on?

    LDAP Details

    Authentication mechanism: External LDAP
    AD domain name:
    LDAP URL: ldap://trueno.fresh-it.com:389
    LDAP filter: (mail=%n@fresh-it.com)
    LDAP search base: ou=people,dc=fresh-it,dc=com
    Use DN/Password to bind to external server: No

    Regards.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    Surely you want the ldap filter without the @....., shouldn't it be: LDAP filter: (mail=%n). When the user types his name+domain it will get authenticated against that.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    jaguado is offline Junior Member
    Join Date
    Jan 2007
    Posts
    9
    Rep Power
    8

    Default Account provision

    Thank you very much for your quick answer. I think the problem is that the account must be provisioned to Zimbra prior to authentication. I have tried all this filters successfully:

    uid=%u
    mail=%n

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,480
    Rep Power
    56

    Default

    Quote Originally Posted by jaguado View Post
    Thank you very much for your quick answer. I think the problem is that the account must be provisioned to Zimbra prior to authentication.
    Ah sorry, I'd assumed you had done that. Yes the accounts will need to be provisioned first. If you have a lot of users then you can add them with a script, I think there's something in the wiki about it.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. External LDAP - auto Account creation
    By nepenthe in forum Administrators
    Replies: 9
    Last Post: 08-20-2008, 10:05 AM
  2. 3 testing: LDAP: 389 Failed when restore zimbra
    By victorLeong in forum Administrators
    Replies: 15
    Last Post: 05-24-2007, 06:45 AM
  3. External LDAP Problem
    By facerw in forum Installation
    Replies: 7
    Last Post: 05-08-2007, 04:29 AM
  4. Authentication to external ldap stop working.
    By jahaj in forum Installation
    Replies: 3
    Last Post: 12-05-2006, 03:17 PM
  5. External LDAP - Users can't log in
    By bjimerson in forum Administrators
    Replies: 4
    Last Post: 08-20-2006, 01:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •