Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Saslauthd strat up failure

  1. #1
    Assaf's Avatar
    Assaf is offline Intermediate Member
    Join Date
    Jan 2007
    Location
    Israel
    Posts
    16
    Rep Power
    8

    Default Saslauthd strat up failure

    Hello

    I'm new to zimbra , and just installed my machine on CentOs 4.4 based on i586 technology .
    I the installation worked ok - after working past the DNS issue .
    Now when i want to start the zimbra suite it fails on the saslauthd .


    #bin/zmcontrol start
    Host zimbra.mydomain.com
    Starting ldap...Done.
    Starting logger...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting snmp...Done.
    Starting spell...Done.
    Starting mta...FAILED
    saslauthd[7142] :set_auth_mech : failed to initialize mechanism zimbra
    zmsaslauthdctl failed to start



    my file looks like this :
    vi cyrus-sasl-2.1.21.ZIMBRA/etc/saslauthd.conf

    zimbra_url:
    zimbra_cert_file: /opt/zimbra/conf/smtpd.crt
    zimbra_cert_check: off


    I searched the forums and tried most of the things specified , but still it didn't work.

    Any one got any ideas ?

    Thank you


    Assaf
    Never ,Ever Cut a Deal With a Dragon

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Welcome to the forums.

    Your saslauthd.conf is missing a url, check the details in this post (obviously put your own server name in there). The url should be http or https depending on the mode you're using.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Assaf's Avatar
    Assaf is offline Intermediate Member
    Join Date
    Jan 2007
    Location
    Israel
    Posts
    16
    Rep Power
    8

    Default input isn't saved in the files

    Thanks for the help , but after i inserted the url to the /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/etc/saslauthd.conf file and saved it.
    then i do
    bin/zmsaslauthdctl start
    saslauthd[21412] :set_auth_mech : failed to initialize mechanism zimbra

    and when i open the file again - the url is empty again.
    further more , i looked at the file permissions:

    ll /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/etc/saslauthd.conf
    -rw-r----- 1 zimbra zimbra 128 Jan 9 14:44 /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/etc/saslauthd.conf

    then execute as zimbra user :
    [zimbra@zimbra ~]$ bin/zmsaslauthdctl start
    saslauthd[31621] :set_auth_mech : failed to initialize mechanism zimbra

    and then :
    [root@zimbra ~]# ll /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/etc/saslauthd.conf
    -r--r----- 1 zimbra zimbra 81 Jan 9 14:45 /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/etc/saslauthd.conf
    Last edited by Assaf; 01-09-2007 at 05:48 AM.
    Never ,Ever Cut a Deal With a Dragon

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Try stopping Zimbra first with 'zmcontrol stop', make the change to the file and restart the server and see what happens with that.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    Assaf's Avatar
    Assaf is offline Intermediate Member
    Join Date
    Jan 2007
    Location
    Israel
    Posts
    16
    Rep Power
    8

    Default Still the same issue

    i stopped the zimbra suite , changed the permissions on the file and inserted the url
    cat /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/etc/saslauthd.conf
    zimbra_url: http://zimbra.mydomain.net/service/soap/
    zimbra_cert_file: /opt/zimbra/conf/smtpd.crt
    zimbra_cert_check: off

    then saved and started the zimbra


    bin/zmcontrol start
    Host zimbra.mydomain.net
    Starting ldap...Done.
    Starting logger...Done.
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting snmp...Done.
    Starting spell...Done.
    Starting mta...FAILED
    saslauthd[11005] :set_auth_mech : failed to initialize mechanism zimbra
    zmsaslauthdctl failed to start

    then i checked the saslauthd file and it was missing the url again :

    [root@zimbra ~]# cat /opt/zimbra/cyrus-sasl-2.1.21.ZIMBRA/etc/saslauthd.conf
    zimbra_url:
    zimbra_cert_file: /opt/zimbra/conf/smtpd.crt
    zimbra_cert_check: off
    [root@zimbra ~]#
    Never ,Ever Cut a Deal With a Dragon

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    OK, let's have a look at this command:
    Code:
     zmprov gs mail.mydomain.com | grep Auth
    the 'mail.mydomain.com' should be the FQDN of your server. What does that produce?

    Is your /etc/hosts file set-up correctly, can you post the details?
    Last edited by phoenix; 01-09-2007 at 07:39 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    Assaf's Avatar
    Assaf is offline Intermediate Member
    Join Date
    Jan 2007
    Location
    Israel
    Posts
    16
    Rep Power
    8

    Default result of test

    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused

    and the /etc/hosts is :

    cat /etc/hosts
    # Do not remove the following line, or various programs
    # that require network functionality will fail.

    127.0.0.1 localhost.localdomain localhost
    192.xxx.xxx.xxx zimbra.mydomain.net zimbra

    ( names are hidden due to the paranoia of my company).

    Assaf
    Never ,Ever Cut a Deal With a Dragon

  8. #8
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Quote Originally Posted by Assaf View Post
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused
    SELinux or Firewall enabled? If they are then you should disable them. Are you absolutely sure that your DNS A & MX records are set correctly? Is your DNS an internal server or externally hosted?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    Assaf's Avatar
    Assaf is offline Intermediate Member
    Join Date
    Jan 2007
    Location
    Israel
    Posts
    16
    Rep Power
    8

    Default Re : Saslauthd strat up failure

    both are disabled , they were disabled at installation time .

    these are the open ports i have on my system :
    netstat -lpn
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 0.0.0.0:768 0.0.0.0:* LISTEN 2706/rpc.statd
    tcp 0 0 192.118.55.105:389 0.0.0.0:* LISTEN 10079/slapd
    tcp 0 0 127.0.0.1:10024 0.0.0.0:* LISTEN 10847/amavisd (mast
    tcp 0 0 127.0.0.1:7307 0.0.0.0:* LISTEN 10452/mysqld
    tcp 0 0 0.0.0.0:3310 0.0.0.0:* LISTEN 11001/clamd
    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 2686/portmap
    tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN 2840/cupsd
    tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 2924/sendmail: acce
    tcp 0 0 127.0.0.1:6010 0.0.0.0:* LISTEN 18997/1
    tcp 0 0 127.0.0.1:6011 0.0.0.0:* LISTEN 12977/2
    tcp 0 0 :::7780 :::* LISTEN 10763/httpd
    tcp 0 0 :::80 :::* LISTEN 25603/httpd
    tcp 0 0 :::22 :::* LISTEN 2871/sshd
    tcp 0 0 ::1:6010 :::* LISTEN 18997/1
    tcp 0 0 ::1:6011 :::* LISTEN 12977/2
    tcp 0 0 :::443 :::* LISTEN 25603/httpd
    udp 0 0 0.0.0.0:68 0.0.0.0:* 18922/dhclient
    udp 0 0 0.0.0.0:111 0.0.0.0:* 2686/portmap
    udp 0 0 0.0.0.0:631 0.0.0.0:* 2840/cupsd
    udp 0 0 0.0.0.0:762 0.0.0.0:* 2706/rpc.statd
    udp 0 0 192.118.55.105:123 0.0.0.0:* 2904/ntpd
    udp 0 0 127.0.0.1:123 0.0.0.0:* 2904/ntpd
    udp 0 0 0.0.0.0:123 0.0.0.0:* 2904/ntpd
    udp 0 0 0.0.0.0:765 0.0.0.0:* 2706/rpc.statd
    udp 0 0 :::123 :::* 2904/ntpd


    Assaf
    Never ,Ever Cut a Deal With a Dragon

  10. #10
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    What do the following produce:
    Code:
    zmcontrol status
    host `hostname`
    dig mx yourdomain.com
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 3.0 to 4.5.3 Upgrade failed (mysql error)
    By dealt in forum Installation
    Replies: 35
    Last Post: 03-19-2007, 10:30 PM
  2. Cannot determine services - exiting
    By tawas in forum Installation
    Replies: 7
    Last Post: 04-25-2006, 02:47 AM
  3. Is it started or not
    By kwelipatton in forum Installation
    Replies: 10
    Last Post: 03-28-2006, 11:11 PM
  4. Yet another get.DirectContext issue
    By dccpark in forum Installation
    Replies: 5
    Last Post: 03-08-2006, 01:25 PM
  5. system failure: getDirectContext
    By avisser in forum Installation
    Replies: 3
    Last Post: 10-12-2005, 05:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •