Results 1 to 8 of 8

Thread: installing ZCS8 on a test/private IP zone

  1. #1
    ple
    ple is offline Loyal Member
    Join Date
    Jan 2009
    Location
    Houston, TX
    Posts
    99
    Rep Power
    6

    Default installing ZCS8 on a test/private IP zone

    Hi,
    Does anyone have experience setting up your test environment using private IP address? I'm having issue installing ZCS8. I keep getting the no MX record found and have this error in the log file: IO::Socket::INET6: connect: No route to host at /opt/zimbra/libexec/zmldapinit line 137.
    Please advice

    RHAS6_64bit
    ZCS8.02
    VMWare5.1

    Thanks,
    PL

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by ple View Post
    Does anyone have experience setting up your test environment using private IP address?
    Yes, it would be the same as any other installation behind a NAT router.

    Quote Originally Posted by ple View Post
    I'm having issue installing ZCS8. I keep getting the no MX record found ......
    Have you actually set-up the correct DNS A & MX records plus the correct hosts & resolv.conf files?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    ple
    ple is offline Loyal Member
    Join Date
    Jan 2009
    Location
    Houston, TX
    Posts
    99
    Rep Power
    6

    Default

    Phoenix,
    Thanks for quick responding. Do you happen to have an example of such settings?
    PL

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by ple View Post
    Thanks for quick responding. Do you happen to have an example of such settings?
    They've been discussed many times all over the forums and the wiki article you want is titled Split DNS. BTW, the required settings are the same as you would use on a public IP with the only difference being that you're using a private LAN IP address instead of the Public IP.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    ple
    ple is offline Loyal Member
    Join Date
    Jan 2009
    Location
    Houston, TX
    Posts
    99
    Rep Power
    6

    Default

    I got the split-DNS figured out. Thanks for your help. Do you think if I switch this box from private IP to public IP and keep the same hostname in the future, will Zimbra still working if I do so?
    PL

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by ple View Post
    I got the split-DNS figured out. Thanks for your help. Do you think if I switch this box from private IP to public IP and keep the same hostname in the future, will Zimbra still working if I do so?
    IMO, putting Zimbra on a public IP serves no useful purpose and you're far better leaving it behind a NAT router for protection.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    ple
    ple is offline Loyal Member
    Join Date
    Jan 2009
    Location
    Houston, TX
    Posts
    99
    Rep Power
    6

    Default

    I'll bring that up the our next meeting. Thanks for replying. I think this thread should be closed.
    PL

  8. #8
    dent_a is offline New Member
    Join Date
    Sep 2008
    Posts
    3
    Rep Power
    6

    Default

    So for everyone out there that gets here via the "IO::Socket::INET6: connect: No route to host at /opt/zimbra/libexec/zmldapinit line 137" error showing up in the install logfile created in the /tmp/ directory... see this link: Perl Net::LDAP (awesomeness)

    For Net::LDAP to work right you HAVE TO put your server's entry in the host file FIRST. (And in my case the correct IP address ).

    Even if you have ipv6 disabled Perl will use IO::Socket::INET6. Not to worry as it will handle ipv4 & ipv6. Well at least that is what I understand it to do.
    Hope this of help to someone.
    Cheers.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. From ZCS5 to ZCS8
    By sguenneur in forum Administrators
    Replies: 2
    Last Post: 01-02-2013, 05:11 PM
  2. From ZCS5 to ZCS8
    By sguenneur in forum Migration
    Replies: 0
    Last Post: 01-02-2013, 01:53 PM
  3. ZCS8 and default search
    By ripienaar in forum Installation
    Replies: 0
    Last Post: 09-12-2012, 03:44 PM
  4. Replies: 5
    Last Post: 05-22-2008, 08:13 AM
  5. Installing with private IP-address
    By RJB in forum Installation
    Replies: 15
    Last Post: 01-22-2007, 09:10 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •