Results 1 to 9 of 9

Thread: splitting a ldap/mailbox server

  1. #1
    malaquerre is offline Junior Member
    Join Date
    Dec 2006
    Posts
    5
    Rep Power
    8

    Default splitting a ldap/mailbox server

    hi i have been assigned the task of modifying a present infrastructure (2 servers one that is a MTA and another one that is ldap/mailbox) and configure it to be (at least 3 servers one ldap master , one mta , one mailbox) i have been trying many ways to do this but i havent had much success.I have tried creating a ldap replicator but once i was finished following the guide ,installing a replicator, i cannot use the cli zmprov withouth have the folowing error :

    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)

    thank you

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Welcome to the forums.

    Did you search through the forums or wiki first? Does this page help?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    malaquerre is offline Junior Member
    Join Date
    Dec 2006
    Posts
    5
    Rep Power
    8

    Default

    Yup i did, i have tried all morning and all night trying to get this replication down but for some reason each time i get to the end of the guide where they say to do a search against the replicator machine or use zmprov it give me an error message

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    Well, the obvious questions in that case are: is there a firewall or SElinux enabled on the server and can you telnet to port 389 on that server?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    malaquerre is offline Junior Member
    Join Date
    Dec 2006
    Posts
    5
    Rep Power
    8

    Default

    You made me think that i forgot another important information im running Centos 4.4 and no i dont have any firewall activated . SElinux is at warn , not active

  6. #6
    Klug's Avatar
    Klug is online now Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,316
    Rep Power
    13

    Default

    Quote Originally Posted by malaquerre View Post
    SElinux is at warn , not active
    Disable it. Fully disabled.

  7. #7
    malaquerre is offline Junior Member
    Join Date
    Dec 2006
    Posts
    5
    Rep Power
    8

    Default

    i have disabled fully SElinux and i still get :

    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    [] INFO: I/O exception (java.net.ConnectException) caught when processing request: Connection refused
    [] INFO: Retrying request
    ERROR: zclient.IO_ERROR (invoke Connection refused, server: localhost) (cause: java.net.ConnectException Connection refused)

    when launching zmprov on my ldap master

  8. #8
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,566
    Rep Power
    57

    Default

    It's a requirement that SElinux is disabled on any Zimbra server. Can you telnet to port 389 from any other server? Have you also tried a reboot of that server?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  9. #9
    malaquerre is offline Junior Member
    Join Date
    Dec 2006
    Posts
    5
    Rep Power
    8

    Default

    Yes i can telnet to the server and i have rebooted the server a couple of times (im lucky we are still in devel)

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. initializing ldap...FAILED(256)ERROR
    By manjunath in forum Installation
    Replies: 39
    Last Post: 06-07-2013, 10:27 AM
  2. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. Error 256 on Installation
    By RuinExplorer in forum Installation
    Replies: 5
    Last Post: 10-19-2006, 09:19 AM
  5. Replies: 18
    Last Post: 03-20-2006, 02:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •