Results 1 to 9 of 9

Thread: mysql will not start during the installation process zimbra 8 (reward)

  1. #1
    devlnull is offline New Member
    Join Date
    Oct 2012
    Posts
    4
    Rep Power
    2

    Exclamation mysql will not start during the installation process zimbra 8 (reward)

    Hi,
    Sorry for the English.
    I installed Zimbra (OSE) 8 on 7.1.3 OS ubuntu 10.4, the installation has finished with the inability to run mysql, I upgraded to ubuntu server12.4 and run Setup again (OSE 8 for U12.4) with the same results.

    FOUND: sysstat
    FOUND: sqlite3
    Prerequisite check complete.
    Checking current number of databases...

    Do you want to verify message store database integrity? [Y]
    Verifying integrity of message store databases. This may take a while.
    Starting mysqld...failed.
    perl: symbol lookup error: /opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi/auto/Socket/Socket.so: undefined symbol: Perl_Istack_sp_ptr

    I am a beginner, there is a reward for anyone who corrects my mistakes.

    devlnullpk@gmail.com

  2. #2
    devlnull is offline New Member
    Join Date
    Oct 2012
    Posts
    4
    Rep Power
    2

    Default

    Now I make new instalation of OSE is possible to transfer old email and configuration from disfunction zimbra? if there is a person who will do it (or reair old instalation) I'm willing to pay a small amount.
    Please submit your offers :-). But I'm grateful for pushing forward.

    PK

  3. #3
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,497
    Rep Power
    56

    Default

    You can start by going to the Split DNS and post the output of all the commands in the 'Verify...' section, run the commands on your original server. Is your original server an upgrade or a new install? I assume the original error you posted was after the 'upgrade' of Ubuntu?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    devlnull is offline New Member
    Join Date
    Oct 2012
    Posts
    4
    Rep Power
    2

    Default

    Quote Originally Posted by phoenix View Post
    You can start by going to the Split DNS and post the output of all the commands in the 'Verify...' section, run the commands on your original server. Is your original server an upgrade or a new install? I assume the original error you posted was after the 'upgrade' of Ubuntu?
    No problem start after upgrade zimbra 7.1.3 to zibmra 8 OSE. I am upgrading ubuntu after this but with same error mysql did not start. I use correct version Zimbra first for ubuntu 10.4 now for 12.4.

    Thanks for reply


    zimbra@mail:/home/pk$ dig 8c.cz mx

    ; <<>> DiG 9.8.1-P1 <<>> 8c.cz mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19069
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 5, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;8c.cz. IN MX

    ;; ANSWER SECTION:
    8c.cz. 3600 IN MX 1 mail.8c.cz.

    ;; AUTHORITY SECTION:
    cz. 172800 IN NS f.ns.nic.cz.
    cz. 172800 IN NS a.ns.nic.cz.
    cz. 172800 IN NS d.ns.nic.cz.
    cz. 172800 IN NS c.ns.nic.cz.
    cz. 172800 IN NS b.ns.nic.cz.

    ;; Query time: 2062 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Fri Oct 5 14:20:24 2012
    ;; MSG SIZE rcvd: 131

    zimbra@mail:/home/pk$ dig 8c.cz any

    ; <<>> DiG 9.8.1-P1 <<>> 8c.cz any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17900
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 5, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;8c.cz. IN ANY

    ;; ANSWER SECTION:
    8c.cz. 3563 IN MX 1 mail.8c.cz.

    ;; AUTHORITY SECTION:
    cz. 172763 IN NS d.ns.nic.cz.
    cz. 172763 IN NS f.ns.nic.cz.
    cz. 172763 IN NS a.ns.nic.cz.
    cz. 172763 IN NS c.ns.nic.cz.
    cz. 172763 IN NS b.ns.nic.cz.

    ;; Query time: 1 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Fri Oct 5 14:21:01 2012
    ;; MSG SIZE rcvd: 131

  5. #5
    Himanshu is offline Advanced Member
    Join Date
    Jan 2008
    Posts
    223
    Rep Power
    7

    Default

    Quote Originally Posted by devlnull View Post
    Now I make new instalation of OSE is possible to transfer old email and configuration from disfunction zimbra? if there is a person who will do it (or reair old instalation) I'm willing to pay a small amount.
    Please submit your offers :-). But I'm grateful for pushing forward.

    PK
    I have overCome this error during Upgrade from CentOS4.3 with ZCS7.x to CentOS6.3 with ZCS 8.0.

    Can Help . Let me know how would you like to get in touch .You can PM me.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,497
    Rep Power
    56

    Default

    Quote Originally Posted by devlnull View Post
    No problem start after upgrade zimbra 7.1.3 to zibmra 8 OSE. I am upgrading ubuntu after this but with same error mysql did not start. I use correct version Zimbra first for ubuntu 10.4 now for 12.4.
    You've missed the output from two of the requested command, the output from the hosts file and the resolv.conf. You've also used the wrong format for the dig command, it should be as follows:

    Code:
    dig 8c.cz mx
    dig 8c.cz any
    Please provide all the correct output again.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    devlnull is offline New Member
    Join Date
    Oct 2012
    Posts
    4
    Rep Power
    2

    Default

    zimbra@mail:/home/pk$ cat /etc/hosts
    127.0.0.1 localhost
    109.233.69.101 mail.ssc-cz.cz mail

    # The following lines are desirable for IPv6 capable hosts
    ::1 localhost ip6-localhost ip6-loopback
    fe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    zimbra@mail:/home/pk$
    zimbra@mail:/home/pk$ cat /etc/resolv.conf
    # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
    # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
    nameserver 127.0.0.1
    search ssc-cz.cz
    zimbra@mail:/home/pk$

    zimbra@mail:/home/pk$ dig ssc-cz.cz mx

    ; <<>> DiG 9.8.1-P1 <<>> ssc-cz.cz mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 45166
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;ssc-cz.cz. IN MX

    ;; ANSWER SECTION:
    ssc-cz.cz. 604800 IN MX 10 mail.ssc-cz.cz.

    ;; AUTHORITY SECTION:
    ssc-cz.cz. 604800 IN NS mail.ssc-cz.cz.

    ;; ADDITIONAL SECTION:
    mail.ssc-cz.cz. 604800 IN A 109.233.69.101

    ;; Query time: 3 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Fri Oct 5 20:10:45 2012
    ;; MSG SIZE rcvd: 78

    zimbra@mail:/home/pk$ dig ssc-cz.cz any

    ; <<>> DiG 9.8.1-P1 <<>> ssc-cz.cz any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63147
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;ssc-cz.cz. IN ANY

    ;; ANSWER SECTION:
    ssc-cz.cz. 604800 IN SOA mail.ssc-cz.cz. webmail.ssc-cz.cz. 70727 604800 86400 2419200 604800
    ssc-cz.cz. 604800 IN NS mail.ssc-cz.cz.
    ssc-cz.cz. 604800 IN MX 10 mail.ssc-cz.cz.
    ssc-cz.cz. 604800 IN A 109.233.69.101

    ;; ADDITIONAL SECTION:
    mail.ssc-cz.cz. 604800 IN A 109.233.69.101

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Fri Oct 5 20:11:23 2012
    ;; MSG SIZE rcvd: 138

  8. #8
    m.erill is offline New Member
    Join Date
    Oct 2012
    Posts
    4
    Rep Power
    2

    Default

    You have it quite easy: reply N to validate the database.

    If you do validate you are doing it with code from the actual ZCS version that is NOT working with your new Ubuntu version (that is the reason that you are upgrading ZCS, right?).

    Go on without validating the database and you will end up with a working ZCS.

    Regards.

    Quote Originally Posted by devlnull View Post
    Hi,
    Sorry for the English.
    I installed Zimbra (OSE) 8 on 7.1.3 OS ubuntu 10.4, the installation has finished with the inability to run mysql, I upgraded to ubuntu server12.4 and run Setup again (OSE 8 for U12.4) with the same results.

    FOUND: sysstat
    FOUND: sqlite3
    Prerequisite check complete.
    Checking current number of databases...

    Do you want to verify message store database integrity? [Y]
    Verifying integrity of message store databases. This may take a while.
    Starting mysqld...failed.
    perl: symbol lookup error: /opt/zimbra/zimbramon/lib/x86_64-linux-gnu-thread-multi/auto/Socket/Socket.so: undefined symbol: Perl_Istack_sp_ptr

    I am a beginner, there is a reward for anyone who corrects my mistakes.

    devlnullpk@gmail.com

  9. #9
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,270
    Rep Power
    10

    Default

    This issue has nothing to do with DNS, and everything to do with mixing perl modules from an old version of an OS with perl from a newer OS. Simply ignore the error and continue the installation.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I can't start antivirus process
    By rcanto in forum Administrators
    Replies: 1
    Last Post: 10-08-2012, 05:10 AM
  2. Replies: 2
    Last Post: 09-03-2012, 09:47 PM
  3. Zimbra 6.0.12: sometimes mysql does not start
    By fabrica64 in forum Administrators
    Replies: 3
    Last Post: 05-28-2011, 11:56 AM
  4. Replies: 1
    Last Post: 05-14-2008, 07:40 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •