Results 1 to 5 of 5

Thread: We have a multi-node cluster of 6 servers spread around the world.

  1. #1
    Hivos's Avatar
    Hivos is offline Advanced Member
    Join Date
    Aug 2009
    Location
    The Hague -- The Netherlands
    Posts
    214
    Rep Power
    6

    Default We have a multi-node cluster of 6 servers spread around the world.

    Hello Forum users,

    We have a multi-node cluster of 6 servers spread around the world.

    The 'master' sits in The Hague (The Netherlands)

    Something happened to the node in kenia (company.or.ke/zimbranai.company.or.ke), it can no longer be reached. So the domains on the kenia server have been migrated to google apps.

    Now the world can mail to company.or.ke and they receive mails. But the rest of the cluster (company.nl) cannot send mail to company.or.ke. The DNS is set correctly on
    company.nl to see the new MX records. But I need to know what I must configure, so the cluster knows how to use the correct relay.

    I do not want to jeopardize the correct functioning of the cluster, so I need your advice.


    root@zimbra:~# cat /var/log/mail.info | grep 2036B5C80E4
    Jul 25 09:22:59 zimbra postfix/smtpd[24620]: 2036B5C80E4: client=localhost.localdomain[127.0.0.1]
    Jul 25 09:22:59 zimbra postfix/cleanup[24583]: 2036B5C80E4: message-id=<1085398968.89500.1343200973789.JavaMail.root@zimbr a.company.nl>
    Jul 25 09:22:59 zimbra postfix/smtp[29349]: 9F5FB5C80DD: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=0.54, delays=0.06/0/0/0.48, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=25049-19, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 2036B5C80E4)
    Jul 25 09:22:59 zimbra postfix/qmgr[16965]: 2036B5C80E4: from=, size=1309, nrcpt=1 (queue active)
    Jul 25 09:23:01 zimbra postfix/lmtp[27050]: 2036B5C80E4: to=, relay=zimbranai.company.or.ke[192.168.4.112]:7025, delay=1.9, delays=0.07/0.02/1.1/0.72, dsn=2.1.5, status=sent (250 2.1.5 Delivery OK)
    Jul 25 09:23:01 zimbra postfix/qmgr[16965]: 2036B5C80E4: removed


    Jul 25 09:22:32 zimbra postfix/smtpd[24620]: ED6FF5C80DD: client=localhost.localdomain[127.0.0.1]
    Jul 25 09:22:32 zimbra postfix/cleanup[24583]: ED6FF5C80DD: message-id=<465964345.89498.1343200952601.JavaMail.root@zimbra .company.nl>
    Jul 25 09:22:32 zimbra postfix/smtp[24584]: B038D5C80A4: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=0.26, delays=0.03/0/0/0.23, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=16805-16, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as ED6FF5C80DD)
    Jul 25 09:22:33 zimbra postfix/qmgr[16965]: ED6FF5C80DD: from=, size=1098, nrcpt=1 (queue active)
    Jul 25 09:22:33 zimbra postfix/smtp[29283]: ED6FF5C80DD: to=, relay=smarthost.company.nl[10.140.6.128]:25, delay=0.12, delays=0.04/0.03/0.02/0.03, dsn=2.0.0, status=sent (250 ok: Message 98650907 accepted)
    Jul 25 09:22:33 zimbra postfix/qmgr[16965]: ED6FF5C80DD: removed


    >>> mail to @company.or.ke should be treated the same as mail to domains outside the cluster (in the example above @testdomain.tk) and not be replayed to zimbranai.company.or.ke.

    possible solutions: change /etc/hosts change the ip address of zimbranai.company.or.ke to that of smarthost
    OR
    remove all accounts for company.or.ke and remove the server from the web interface



    Please advice on the issue

  2. #2
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,320
    Rep Power
    13

    Default

    Remove/rename domain.ke from the ZCS infrastructure.

    As long as the domain will exist in the infrastructure, mail to this domain from any other account of the infrastructure will be (tried to be) delivered inside the infrastructure.

  3. #3
    Hivos's Avatar
    Hivos is offline Advanced Member
    Join Date
    Aug 2009
    Location
    The Hague -- The Netherlands
    Posts
    214
    Rep Power
    6

    Default

    Thanks Klug for your reply,

    Via the webinterface I cannot delete the domain, says there are still accounts configured on the domain. Beside manually removing the accounts. What would you recommend to do, to remove the domain?

    zmprov dd domain.ke?

    Is there a risk in renaming the domain? (other than it looks complicated in the manual)

    Thanks a lot,

    Barry

    Additional info:
    zmcontrol -v
    Release 6.0.6_GA_2330.UBUNTU8_64 UBUNTU8_64 NETWORK edition.

    ->The communications with the node to be deleted is interrupted, so not all commands via de webinterface complete succesful.
    Last edited by Hivos; 07-26-2012 at 12:16 AM.

  4. #4
    Klug's Avatar
    Klug is offline Moderator
    Join Date
    Mar 2006
    Location
    Beaucaire, France
    Posts
    2,320
    Rep Power
    13

    Default

    6.0.6 is quite old, I don't know what was the command to rename the domain at this time.
    Today it's quite simple : "zmprov -l rd oldname.tld newname.tld"

    AFAIK you can not delete the domain while it's not empty.

  5. #5
    Hivos's Avatar
    Hivos is offline Advanced Member
    Join Date
    Aug 2009
    Location
    The Hague -- The Netherlands
    Posts
    214
    Rep Power
    6

    Default

    I contacted zimbra support, they suggested setting a forward for the domain:

    zmprov md company.or.ke zimbraMailTransport smtp:smarthost.company.nl

    where company.or.ke is the domain to forward (node to be deleted
    eventually)

    I verified that smarthost.company.nl is accepting smtp, I can use it from
    other server to send mail to company.or.ke.

    But I still does not work from the zimbra cluster. In the log it still uses
    zimbranai.company.or.ke for relay.

    See mail.info:
    Jul 26 14:22:41 zimbra postfix/smtp[13739]: 277655C80BB: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=0.21, delays=0.04/0/0/0.17, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=31328-16, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 55E695C80F2)
    Jul 26 14:22:41 zimbra postfix/lmtp[27095]: 55E695C80F2: to=, relay=none, delay=0.08, delays=0.04/0.04/0/0, dsn=4.4.1, status=deferred (connect to zimbranai.company.or.ke[192.168.4.112]:7025: Network is unreachable)
    Jul 26 14:26:11 zimbra postfix/smtp[13739]: B061E5C80F8: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=0.42, delays=0.09/0/0/0.32, dsn=2.0.0, status=sent (250 2.0.0 Ok, id=05650-05, from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 1B6755C80FB)
    Jul 26 14:26:13 zimbra postfix/lmtp[27095]: 1B6755C80FB: to=, relay=zimbranai.company.or.ke[192.168.4.112]:7025, delay=2.1, delays=0.03/0.01/1/1, dsn=2.1.5, status=sent (250 2.1.5 Delivery OK)
    Jul 26 14:31:58 zimbra postfix/lmtp[26602]: 55E695C80F2: to=, relay=zimbranai.company.or.ke[192.168.4.112]:7025, delay=557, delays=556/0/1/0.79, dsn=2.1.5, status=sent (250 2.1.5 Delivery OK)


    Do I need to give some sort of reload command after the zmprov md or is
    there an other rule in effect that does the relay?


    Can you please give me some advise on that?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 11-11-2010, 03:53 AM
  2. Replies: 6
    Last Post: 06-21-2010, 12:46 AM
  3. sinlge node to multi node migration
    By baktolio in forum Migration
    Replies: 2
    Last Post: 04-04-2010, 08:13 PM
  4. Replacing a failed cluster node?
    By Lebha in forum Administrators
    Replies: 1
    Last Post: 03-10-2009, 04:30 AM
  5. Upgrading from 5.0.7 to 5.0.11 Single Node Cluster
    By 2myhre in forum Installation
    Replies: 1
    Last Post: 02-06-2009, 02:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •