Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: MTA fails after installation

  1. #1
    manking is offline New Member
    Join Date
    Dec 2006
    Posts
    4
    Rep Power
    8

    Default MTA fails after installation

    Start out by saying I have never used Linux based servers so If you can help be tech gentle.

    I configured a server with Red Hat fedora 5 core. I installed Zimbra as this was the application we are interrested in converting to.

    Here is the status log

    Dec 1 15:36:06 teachers zmtomcatmgr[12869]: status requested
    Dec 1 15:36:06 teachers zmtomcatmgr[12869]: status OK
    Dec 1 20:36:06 teachers postfix/postqueue[12879]: fatal: file /opt/zimbra/postfix-2.2.9/conf/main.cf: parameter mail_owner: unknown user name value: postfix
    Dec 1 15:36:07 teachers zimbramon[12732]: 12732:info: 2006-12-01 15:36:01, STATUS: mail.teachers.yourkidshomework.com: antispam: Running
    Dec 1 15:36:07 teachers zimbramon[12732]: 12732:info: 2006-12-01 15:36:01, STATUS: mail.teachers.yourkidshomework.com: antivirus: Running
    Dec 1 15:36:07 teachers zimbramon[12732]: 12732:info: 2006-12-01 15:36:01, STATUS: mail.teachers.yourkidshomework.com: ldap: Running
    Dec 1 15:36:07 teachers zimbramon[12732]: 12732:info: 2006-12-01 15:36:01, STATUS: mail.teachers.yourkidshomework.com: logger: Running
    Dec 1 15:36:07 teachers zimbramon[12732]: 12732:info: 2006-12-01 15:36:01, STATUS: mail.teachers.yourkidshomework.com: mailbox: Running
    Dec 1 15:36:07 teachers zimbramon[12732]: 12732:info: 2006-12-01 15:36:01, STATUS: mail.teachers.yourkidshomework.com: mta: Stopped
    Dec 1 15:36:07 teachers zimbramon[12732]: 12732:info: 2006-12-01 15:36:01, STATUS: mail.teachers.yourkidshomework.com: snmp: Running
    Dec 1 15:36:07 teachers zimbramon[12732]: 12732:info: 2006-12-01 15:36:01, STATUS: mail.teachers.yourkidshomework.com: spell: Stopped

    I ran the zmmtactl start as a previous post suggested and received this.


    DO: /opt/zimbra/postfix/sbin/postconf -e content_filter=''
    DO: /opt/zimbra/postfix/sbin/postconf -e content_filter='smtp-amavis:[127.0.0.1]:10024'
    DO: /opt/zimbra/postfix/sbin/postconf -e myhostname='mail.teachers.yourkidshomework.com'
    DO: /opt/zimbra/postfix/sbin/postconf -e recipient_delimiter=''
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_sasl_auth_enable='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_auth_only='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_use_tls='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e disable_dns_lookups='no'
    DO: /opt/zimbra/postfix/sbin/postconf -e message_size_limit='10240000'
    DO: /opt/zimbra/postfix/sbin/postconf -e mailbox_size_limit='0'
    DO: /opt/zimbra/postfix/sbin/postconf -e relayhost=''
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_recipient_restrictions='reject_non_fqdn_reci pient, permit_sasl_authenticated, permit_mynetworks, reject_unlisted_recipient, reject_invalid_hostname, reject_non_fqdn_sender, reject_unauth_destination, permit'
    DO: /opt/zimbra/postfix/sbin/postconf -e alias_maps='hash:/etc/aliases'
    DO: /opt/zimbra/postfix/sbin/postconf -e broken_sasl_auth_clients='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e command_directory='/opt/zimbra/postfix-2.2.9/sbin'
    DO: /opt/zimbra/postfix/sbin/postconf -e daemon_directory='/opt/zimbra/postfix-2.2.9/libexec'
    DO: /opt/zimbra/postfix/sbin/postconf -e header_checks='pcre:/opt/zimbra/conf/postfix_header_checks'
    DO: /opt/zimbra/postfix/sbin/postconf -e mailq_path='/opt/zimbra/postfix-2.2.9/sbin/mailq'
    DO: /opt/zimbra/postfix/sbin/postconf -e manpage_directory='/opt/zimbra/postfix-2.2.9/man'
    DO: /opt/zimbra/postfix/sbin/postconf -e newaliases_path='/opt/zimbra/postfix-2.2.9/sbin/newaliases'
    DO: /opt/zimbra/postfix/sbin/postconf -e queue_directory='/opt/zimbra/postfix-2.2.9/spool'
    DO: /opt/zimbra/postfix/sbin/postconf -e sender_canonical_maps='ldap:/opt/zimbra/conf/ldap-scm.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e sendmail_path='/opt/zimbra/postfix-2.2.9/sbin/sendmail'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_client_restrictions='reject_unauth_pipelinin g'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_data_restrictions='reject_unauth_pipelining'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_helo_required='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_reject_unlisted_recipient='no'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_cert_file='/opt/zimbra/conf/smtpd.crt'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_key_file='/opt/zimbra/conf/smtpd.key'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_loglevel='1'
    DO: /opt/zimbra/postfix/sbin/postconf -e transport_maps='ldap:/opt/zimbra/conf/ldap-transport.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e version='2.2.9'
    DO: /opt/zimbra/postfix/sbin/postconf -e virtual_alias_domains='ldap://opt/zimbra/conf/ldap-vad.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e virtual_alias_maps='ldap:/opt/zimbra/conf/ldap-vam.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e virtual_mailbox_domains='ldap:/opt/zimbra/conf/ldap-vmd.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e virtual_mailbox_maps='ldap:/opt/zimbra/conf/ldap-vmm.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e virtual_transport='error'
    postmap: fatal: file /opt/zimbra/postfix-2.2.9/conf/main.cf: parameter mail_owner: unknown user name value: postfix
    postalias: fatal: file /opt/zimbra/postfix-2.2.9/conf/main.cf: parameter mail_owner: unknown user name value: postfix
    postfix: fatal: file /opt/zimbra/postfix-2.2.9/conf/main.cf: parameter mail_owner: unknown user name value: postfix
    postfix failed to start

    What do I have to do to correct this problem??

  2. #2
    netjunkie is offline Member
    Join Date
    Nov 2006
    Posts
    10
    Rep Power
    8

    Default mta failed after install

    Hi guys.

    I am getting the exact same problem.

    [zimbra@mta root]$ zmmtactl start
    DO: /opt/zimbra/postfix/sbin/postconf -e content_filter=''
    DO: /opt/zimbra/postfix/sbin/postconf -e content_filter='smtp-amavis:[127.0.0.1]:10024'
    DO: /opt/zimbra/postfix/sbin/postconf -e myhostname='mta.mydomain.co.uk'
    DO: /opt/zimbra/postfix/sbin/postconf -e recipient_delimiter=''
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_sasl_auth_enable='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_auth_only='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_use_tls='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e disable_dns_lookups='no'
    DO: /opt/zimbra/postfix/sbin/postconf -e message_size_limit='10240000'
    DO: /opt/zimbra/postfix/sbin/postconf -e mailbox_size_limit='0'
    DO: /opt/zimbra/postfix/sbin/postconf -e relayhost=''
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_recipient_restrictions='reject_non_fqdn_reci pient, permit_sasl_authenticated, permit_mynetworks, reject_unlisted_recipient, reject_invalid_hostname, reject_non_fqdn_sender, reject_unauth_destination, permit'
    DO: /opt/zimbra/postfix/sbin/postconf -e alias_maps='hash:/etc/aliases'
    DO: /opt/zimbra/postfix/sbin/postconf -e broken_sasl_auth_clients='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e command_directory='/opt/zimbra/postfix-2.2.9/sbin'
    DO: /opt/zimbra/postfix/sbin/postconf -e daemon_directory='/opt/zimbra/postfix-2.2.9/libexec'
    DO: /opt/zimbra/postfix/sbin/postconf -e header_checks='pcre:/opt/zimbra/conf/postfix_header_checks'
    DO: /opt/zimbra/postfix/sbin/postconf -e mailq_path='/opt/zimbra/postfix-2.2.9/sbin/mailq'
    DO: /opt/zimbra/postfix/sbin/postconf -e manpage_directory='/opt/zimbra/postfix-2.2.9/man'
    DO: /opt/zimbra/postfix/sbin/postconf -e newaliases_path='/opt/zimbra/postfix-2.2.9/sbin/newaliases'
    DO: /opt/zimbra/postfix/sbin/postconf -e queue_directory='/opt/zimbra/postfix-2.2.9/spool'
    DO: /opt/zimbra/postfix/sbin/postconf -e sender_canonical_maps='ldap:/opt/zimbra/conf/ldap-scm.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e sendmail_path='/opt/zimbra/postfix-2.2.9/sbin/sendmail'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_client_restrictions='reject_unauth_pipelinin g'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_data_restrictions='reject_unauth_pipelining'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_helo_required='yes'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_reject_unlisted_recipient='no'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_cert_file='/opt/zimbra/conf/smtpd.crt'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_key_file='/opt/zimbra/conf/smtpd.key'
    DO: /opt/zimbra/postfix/sbin/postconf -e smtpd_tls_loglevel='1'
    DO: /opt/zimbra/postfix/sbin/postconf -e transport_maps='ldap:/opt/zimbra/conf/ldap-transport.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e version='2.2.9'
    DO: /opt/zimbra/postfix/sbin/postconf -e virtual_alias_domains='ldap://opt/zimbra/conf/ldap-vad.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e virtual_alias_maps='ldap:/opt/zimbra/conf/ldap-vam.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e virtual_mailbox_domains='ldap:/opt/zimbra/conf/ldap-vmd.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e virtual_mailbox_maps='ldap:/opt/zimbra/conf/ldap-vmm.cf'
    DO: /opt/zimbra/postfix/sbin/postconf -e virtual_transport='error'
    postfix/postfix-script: warning: not owned by root: /opt/zimbra/postfix-2.2.9/conf/main.cf
    postfix/postfix-script: starting the Postfix mail system
    saslauthd[16498] :set_auth_mech : failed to initialize mechanism zimbra
    zmsaslauthdctl failed to start

  3. #3
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,506
    Rep Power
    57

    Default

    Quote Originally Posted by netjunkie View Post
    I am getting the exact same problem.
    This isn't the exact same problem is it? Have a search of the forums for zimbraMtaAuthHost.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,506
    Rep Power
    57

    Default

    Quote Originally Posted by manking View Post
    Start out by saying I have never used Linux based servers so If you can help be tech gentle.

    I configured a server with Red Hat fedora 5 core. I installed Zimbra as this was the application we are interrested in converting to.

    What do I have to do to correct this problem??
    Did you disable the firewall and SElinux on this machine?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    netjunkie is offline Member
    Join Date
    Nov 2006
    Posts
    10
    Rep Power
    8

    Default

    Hi,

    SELINUX is disabled, and firewalling is allowing SMTP, HTTP,HTTPS

    regards

    charles

  6. #6
    netjunkie is offline Member
    Join Date
    Nov 2006
    Posts
    10
    Rep Power
    8

    Default

    Hi,

    I have also tried this with SElinux and Firewall disabled, and restarted the machine.

    The zimbra service still fails to start.

    Regards

    charles

  7. #7
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,506
    Rep Power
    57

    Default

    Try the following:

    su - zimbra
    cd /opt/zimbra/libexec
    ./zmfixperms

    see if that fixes it.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  8. #8
    netjunkie is offline Member
    Join Date
    Nov 2006
    Posts
    10
    Rep Power
    8

    Default

    Hi

    I assumed there may be major problem with the first install of the MTA box, so I completely reinstalled RHEL4 and the MTA.

    Now I get the following:

    [zimbra@localhost root]$ zmcontrol start mta
    Host mta.mydomain.co.uk
    Starting antispam...Done.
    Starting antivirus...Done.
    Starting snmp...Done.
    Starting mta...Done.

    [zimbra@localhost root]$ zmcontrol status
    Host mta.mydomain.co.uk
    antispam Running
    antivirus Running
    mta Stopped
    postfix is not running
    snmp Running

    Looks like some progress, but still no luck.

    Regards

    charles

  9. #9
    dkarp is offline Zimbra Employee
    Join Date
    Aug 2005
    Posts
    1,433
    Rep Power
    11

    Default Pre-existring MTA?

    Are you sure that you weren't already running an MTA that came with the distro?
    Bugzilla - Wiki - Downloads - Before posting... Search!

  10. #10
    manking is offline New Member
    Join Date
    Dec 2006
    Posts
    4
    Rep Power
    8

    Default That fixed the MTA will not Start Problem

    Quote Originally Posted by phoenix View Post
    Did you disable the firewall and SElinux on this machine?
    This fixed the particular MTA failure problem I was having, look at my inital post. Thanks to PHOENIX for helping point me in the right direction.


    For other newbie Linux Fedora Users goto the desktop, choose System Settings, then Security Level In mine it was called Security Level/ Firewall see http://www.reallylinux.com/docs/basicfirewall.html. On mine the SElinus was a tab to this box. I am using Red Hat Fedora Core 5.


Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Daily mail report always reports "No messages found"
    By McPringle in forum Installation
    Replies: 42
    Last Post: 06-13-2011, 08:57 AM
  2. Replies: 9
    Last Post: 06-15-2009, 09:31 AM
  3. mta not running in OSX multi-server installation
    By Britt in forum Installation
    Replies: 11
    Last Post: 03-22-2006, 02:19 PM
  4. Installation fails on zimbra-store
    By wyleyrabbit in forum Installation
    Replies: 8
    Last Post: 01-15-2006, 08:19 AM
  5. Installation fault - getDirectContext fails
    By gregjohnson1024 in forum Administrators
    Replies: 3
    Last Post: 11-07-2005, 04:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •