Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Zimbra Calendar in Ubuntu Dapper

  1. #1
    jarbelix is offline Member
    Join Date
    Oct 2006
    Location
    Campo Grande - MS - Brasil
    Posts
    11
    Rep Power
    8

    Default Zimbra Calendar in Ubuntu Dapper

    I am using the Ubuntu Dapper (brought up to date) with the last free version available Ubuntu in http://www.zimbra.com/community/downloads.html (zcs-4.0.4_GA_457.UBUNTU6.tgz).

    The installation was very simple and I only informed the password of the administrator. When I try to include an item in the calendar I have the following message of error:

    msg - system failure: java.lang.IllegalArgumentException: Illegal end time 86400000
    com.zimbra.cs.service.ServiceException: system failure: java.lang.IllegalArgumentException: Illegal end time 86400000
    at com.zimbra.cs.service.ServiceException.FAILURE(Ser viceException.java:174)
    ....
    ....
    ....
    com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:261)
    ... 21 more

    code - service.FAILURE
    method - ZmCsfeCommand.prototype.invoke
    detail - soap:Receiver
    Any ideas?

    Tanks,
    Jarbelix

  2. #2
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Have you tried a reinstall?

  3. #3
    jarbelix is offline Member
    Join Date
    Oct 2006
    Location
    Campo Grande - MS - Brasil
    Posts
    11
    Rep Power
    8

    Thumbs down

    Quote Originally Posted by wannabetenor View Post
    Have you tried a reinstall?
    Yes. I too tried install in other server with the same result.

  4. #4
    jholder's Avatar
    jholder is offline Former Zimbran
    Join Date
    Oct 2005
    Location
    Thatcher, AZ
    Posts
    5,606
    Rep Power
    20

    Default

    Is this a problem with any time you enter, or just a specific time?

  5. #5
    jarbelix is offline Member
    Join Date
    Oct 2006
    Location
    Campo Grande - MS - Brasil
    Posts
    11
    Rep Power
    8

    Thumbs down

    Quote Originally Posted by wannabetenor View Post
    Is this a problem with any time you enter, or just a specific time?
    This error occurs in all the attempts. In any schedule and any user.

    This problem did not occur in browser IE6. Only in firefox in the Desktop Dapper.

    In IE6 works fine!
    Last edited by jarbelix; 11-30-2006 at 07:39 PM.

  6. #6
    medo is offline Junior Member
    Join Date
    Dec 2006
    Location
    Amman Jordan
    Posts
    6
    Rep Power
    8

    Default

    Hi jarblex,

    I face the same problem but with Kubuntu 6.10/ Zimbra 4.5
    Did you find out the source of the problem?

    If I use Opera, I can not even reach the login page, meaning that the page is blank (beige) and no fields to enter credentials.

    Konquror has no luck too, it says that its not supported yet.

    If you run zmcontrol status, what is the result. Are all services running ok?
    Last edited by medo; 12-20-2006 at 03:26 AM. Reason: add more info

  7. #7
    pshah is offline Zimbra Employee
    Join Date
    Sep 2005
    Location
    Sunnyvale, CA
    Posts
    269
    Rep Power
    9

    Default

    If this is indeed only happening in FF, theres a couple of things you can try to debug your issue:

    1. Open the Javascript console (from Tools menu) *after* you login, clear it, and then try whatever it is you're trying to do. If you see any javascript errors, post them here or create a new bug in bugzilla with your repro steps and the javascript errors you're getting.

    2. Open the debug window *before* you login. To do this, append this to the URL: "?debug=1" (minus the quotes). This will popup a separate window which will log all client/server requests/responses (make sure you are not blocking popup windows for the domain you are connecting to zimbra with).

    If/when you see a server error returned, post the previous request and the full server response (preferably as an attachment) to this forum post or again, create a new bugzilla bug report.

    Lastly, any *very specific* repro steps always helps. For instance, be more specific about what you mean with "When I try to include an item in the calendar..."
    Bugzilla - Wiki - Downloads - Before posting... Search!

  8. #8
    medo is offline Junior Member
    Join Date
    Dec 2006
    Location
    Amman Jordan
    Posts
    6
    Rep Power
    8

    Default cont.

    Hi pshah,

    Thanks for your reply. I am sorry that I was not clear in my post. I did not have problem specificly with calendar, but just after logging I get this error:

    msg - system failure: java.lang.IllegalArgumentException: Illegal end time 86400000
    com.zimbra.cs.service.ServiceException: system failure: java.lang.IllegalArgumentException: Illegal end time 86400000
    at com.zimbra.cs.service.ServiceException.FAILURE(Ser viceException.java:174)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:273)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:162)
    at com.zimbra.soap.SoapEngine.dispatch(SoapEngine.jav a:84)
    at com.zimbra.soap.SoapServlet.doPost(SoapServlet.jav a:223)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:709)
    at com.zimbra.cs.servlet.ZimbraServlet.service(Zimbra Servlet.java:162)
    at javax.servlet.http.HttpServlet.service(HttpServlet .java:802)
    at org.apache.catalina.core.ApplicationFilterChain.in ternalDoFilter(ApplicationFilterChain.java:252)
    at org.apache.catalina.core.ApplicationFilterChain.do Filter(ApplicationFilterChain.java:173)
    at org.apache.catalina.core.StandardWrapperValve.invo ke(StandardWrapperValve.java:213)
    at org.apache.catalina.core.StandardContextValve.invo ke(StandardContextValve.java:178)
    at org.apache.catalina.core.StandardHostValve.invoke( StandardHostValve.java:126)
    at org.apache.catalina.valves.ErrorReportValve.invoke (ErrorReportValve.java:105)
    at org.apache.catalina.core.StandardEngineValve.invok e(StandardEngineValve.java:107)
    at org.apache.catalina.valves.AccessLogValve.invoke(A ccessLogValve.java:541)
    at org.apache.catalina.connector.CoyoteAdapter.servic e(CoyoteAdapter.java:148)
    at org.apache.coyote.http11.Http11Processor.process(H ttp11Processor.java:869)
    at org.apache.coyote.http11.Http11BaseProtocol$Http11 ConnectionHandler.processConnection(Http11BaseProt ocol.java:667)
    at org.apache.tomcat.util.net.PoolTcpEndpoint.process Socket(PoolTcpEndpoint.java:527)
    at org.apache.tomcat.util.net.LeaderFollowerWorkerThr ead.runIt(LeaderFollowerWorkerThread.java:80)
    at org.apache.tomcat.util.threads.ThreadPool$ControlR unnable.run(ThreadPool.java:684)
    at java.lang.Thread.run(Thread.java:595)
    Caused by: java.lang.IllegalArgumentException: Illegal end time 86400000
    at java.util.SimpleTimeZone.decodeEndRule(SimpleTimeZ one.java:1406)
    at java.util.SimpleTimeZone.setEndRule(SimpleTimeZone .java:456)
    at com.zimbra.cs.mailbox.calendar.ICalTimeZone.(ICalTimeZone.java:474)
    at com.zimbra.cs.service.mail.CalendarUtils.parseTzEl ement(CalendarUtils.java:589)
    at com.zimbra.cs.service.mail.Search.parseTimeZonePar t(Search.java:152)
    at com.zimbra.cs.service.mail.Search.parseCommonParam eters(Search.java:177)
    at com.zimbra.cs.service.mail.Search.handle(Search.ja va:75)
    at com.zimbra.soap.SoapEngine.dispatchRequest(SoapEng ine.java:262)
    ... 21 more

    code - service.FAILURE
    method - ZmCsfeCommand.prototype.invoke
    detail - soap:Receiver









    when I check the error as you suggested
    1. Open the Javascript console (from Tools menu) *after* you login, clear it, and then try whatever it is you're trying to do. If you see any javascript errors, post them here or create a new bug in bugzilla with your repro steps and the javascript errors you're getting.
    I got: Unknown property 'filter'. Declaration dropped.
    http://xx.xxxxx.xx:8888/zimbra/IoRes...v=061109220310
    the contents are attached.

    When I perform the second test

    2. Open the debug window *before* you login. To do this, append this to the URL: "?debug=1" (minus the quotes). This will popup a separate window which will log all client/server requests/responses (make sure you are not blocking popup windows for the domain you are connecting to zimbra with).
    I get this:NEW RUN - [15:27:45.621]

    As summury for the test I made:

    ________win________linux_____mac
    FF 2.0__ok_________prob______prob
    IE 7____ok __________--________--
    safary__-- __________--________prob

    I removed all zimlets but that changed nothing.


    Zimbra 4.5 ubuntu package
    Kubuntu edgy 6.10

    help is appreciated
    medo
    Attached Files Attached Files
    Last edited by medo; 12-21-2006 at 07:22 AM.

  9. #9
    medo is offline Junior Member
    Join Date
    Dec 2006
    Location
    Amman Jordan
    Posts
    6
    Rep Power
    8

    Default updates

    Hi all,

    I get more info regarding this problem.

    When I use Camino on Mac OR epiphany under Linux, I get the same error message.

    When I use IE 5 on Mac (to my knowledge is the latest IE on mac) and after enabling script error reporting, when I tried to access the first logging page i.e. mail.xxxx.xx I get this error:

    Code:
    Microsoft Jscript compilation error:
    Line 1044
    Char: 7
    error: expected ')'

    and refered me to this link where the content is



    I am now more convinced that the script has a bug, but how to fix it.
    Any idea how to proceed?
    Last edited by medo; 12-24-2006 at 08:04 AM.

  10. #10
    pshah is offline Zimbra Employee
    Join Date
    Sep 2005
    Location
    Sunnyvale, CA
    Posts
    269
    Rep Power
    9

    Default

    Medo,

    not sure what the bug you're seeing is about. The point of opening the debug window was to see whether the server returned any errors during login. You posted only the first line which is not helpful in determining this.

    Also the attachment from you previous post is empty. As suggested in the previous posts, have you tried a reinstall?

    It doesnt make sense to me that you are seeing errors using Mac/Linux on FF but not in Windows. BTW, Zimbra does not support IE on the mac which is why you would be seeing those errors.

    Can you provide specific repro steps? Are you able to at least login and see your inbox?
    Bugzilla - Wiki - Downloads - Before posting... Search!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. upgrade woes -made into new thread
    By JustinHarlow in forum Installation
    Replies: 18
    Last Post: 06-08-2007, 12:11 PM
  2. huge log size
    By rmvg in forum Administrators
    Replies: 5
    Last Post: 01-02-2007, 10:39 AM
  3. Getting problems in FC4 while instalation
    By kitty_bhoo in forum Installation
    Replies: 13
    Last Post: 09-12-2006, 10:34 PM
  4. Unable to start tomcat
    By chanck in forum Administrators
    Replies: 11
    Last Post: 06-11-2006, 12:58 AM
  5. Seeming variety of problems on suse-9.1
    By Crexis in forum Installation
    Replies: 52
    Last Post: 03-04-2006, 12:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •