Results 1 to 3 of 3

Thread: ZCS on CentOS6x64 / OpenVZ / DNS errors

  1. #1
    Razva is offline Starter Member
    Join Date
    Mar 2012
    Posts
    2
    Rep Power
    3

    Question ZCS on CentOS6x64 / OpenVZ / DNS errors

    Hi folks,

    Before we begin, please note: I don't have much experience as a sysadmin, so please excuse me if I'll ask newbie questions.

    OS & Details:
    - CentOS 6x64
    - Virtualized: yes, on OpenVZ
    - ZCS: Release 7.1.4_GA_2555.RHEL6_64_20120105094542 CentOSUNKNOWN_64 FOSS edition.
    - DNS - EXTERNAL, hosted on a cPanel server.
    - ZCS installed after this tutorial (obviously I've changed the IPs properly)

    Explanation: I've created a separate VPS in order to test Zimbra, named "zimbra.myhost.tld". In cPanel I've created a A entry and pointed it to the test VPS IP. Also I've reversed the IP in .arpa (on the cPanel server, obviously).

    Problems:
    - the installation was stopping at "ldap...". This solution solved the problem, the installation finished

    - when executing /opt/zimbra/libexec/zmsetup.pl I receive a lot of:

    ERROR: service.FAILURE (system failure: unable to lookup server by name: zimbra.webhipo.ro message: [LDAP: error code 80 - internal error]) (cause: javax.naming.NamingException [LDAP: error code 80 - internal error])]
    AND

    Could not create the Java virtual machine.
    AND

    /opt/zimbra/bin/zmshutil: line 39: Error: command not found
    - when trying to login I receive the following error:

    system failure: unable to lookup account via query: (&(|(zimbraMailDeliveryAddress=admin@zimbra.webhipo. ro)(zimbraMailAlias=admin@zimbra.webhipo.ro))(obje ctclass=zimbraAccount)) message: [LDAP: error code 80 - internal error]
    Can you please give me a hand? Thanks a lot!

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,497
    Rep Power
    56

    Default

    Quote Originally Posted by Razva View Post
    - Virtualized: yes, on OpenVZ
    That is not a supported platform for Zimbra and you may, or may not, get it working but basically you'll be on your own.

    Quote Originally Posted by Razva View Post
    - ZCS installed after this tutorial (obviously I've changed the IPs properly)
    Why is it obvious? If you've followed that tutorial, are you on a LAN? If you are have you followed the Split DNS tutorial, you can also check your DNS config using the instructions in that article.

    You've posted the following error:

    Code:
    Could not create the Java virtual machine.
    That would indicate a lack of RAM, I mean real RAM not burst.

    Quote Originally Posted by Razva View Post
    Can you please give me a hand? Thanks a lot!
    What makes you think this is a DNS error?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    Razva is offline Starter Member
    Join Date
    Mar 2012
    Posts
    2
    Rep Power
    3

    Default

    Thanks for your fast reply!

    If you've followed that tutorial, are you on a LAN? If you are have you followed the Split DNS tutorial, you can also check your DNS config using the instructions in that article.
    No, the container acts like an ethernet card:
    venet0:0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
    inet addr:217.19.1.24 P-t-P:217.19.1.24 Bcast:217.19.1.24 Mask:255.255.255.255
    UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1
    That would indicate a lack of RAM, I mean real RAM not burst.
    Here's the free result:

    total used free shared buffers cached
    -/+ buffers/cache: 4126 11885
    So I have 11GB of free RAM on the machine (from which 8GB are allocated to the Zimbra VPS, which now uses 42MB). So the machine has plenty of free RAM.

    What makes you think this is a DNS error?
    Because it's the single thing that posts errors...but I may be wrong. This is the reason why I'm asking for help.

    Is there any way to debug this...?

    Thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trouble Sending mail - All Messages deferred!
    By SiteDiscovery in forum Administrators
    Replies: 7
    Last Post: 09-03-2009, 04:52 AM
  2. Replies: 41
    Last Post: 10-29-2007, 02:36 PM
  3. ZCS and DNS
    By Bill Brock in forum Installation
    Replies: 1
    Last Post: 06-04-2007, 09:32 PM
  4. ZCS ROCKS! Need some DNS help!
    By SiteDiscovery in forum Administrators
    Replies: 9
    Last Post: 12-30-2006, 10:50 PM
  5. ZCS 3.2 Beta Available
    By KevinH in forum Announcements
    Replies: 31
    Last Post: 07-07-2006, 03:46 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •