Results 1 to 7 of 7

Thread: ZCS-7.1.4 (x64) and CentOS 6.2 (x64) - can not install

  1. #1
    Vottghern is offline Starter Member
    Join Date
    Feb 2012
    Posts
    2
    Rep Power
    3

    Default ZCS-7.1.4 (x64) and CentOS 6.2 (x64) - can not install

    Hi!

    When installing Zimbra gives this error:

    Code:
    Setting local config values...done.
    Setting up CA...done.
    Deploying CA to /opt/zimbra/conf/ca ...done.
    Creating SSL certificate...done.
    Installing mailboxd SSL certificates...done.
    Initializing ldap...failed. (256)
    
    ERROR
    
    Configuration failed

    Here are the last lines of the corresponding log-file:

    Code:
    Wed Feb 15 08:48:49 2012 Setting up CA...
    Wed Feb 15 08:48:49 2012 *** Running as root user: /opt/zimbra/bin/zmcertmgr createca
    ** Creating directory /opt/zimbra/ssl/zimbra
    ** Creating directory /opt/zimbra/ssl/zimbra/ca
    ** Creating directory /opt/zimbra/ssl/zimbra/server
    ** Creating directory /opt/zimbra/ssl/zimbra/commercial
    ** Creating directory /opt/zimbra/mailboxd/webapps/zimbraAdmin/tmp
    ** Creating /opt/zimbra/ssl/zimbra/ca/zmssl.cnf...done
    ** Retrieving CA private key from ldap...failed.
    ** Retrieving CA cert from ldap...failed.
    ** Retrieving Commercial CA cert from ldap...failed.
    ** Creating CA private key /opt/zimbra/ssl/zimbra/ca/ca.key...done.
    ** Creating CA cert /opt/zimbra/ssl/zimbra/ca/ca.pem...done.
    Wed Feb 15 08:48:58 2012 done.
    Wed Feb 15 08:48:58 2012 Deploying CA to /opt/zimbra/conf/ca ...
    Wed Feb 15 08:48:58 2012 *** Running as root user: /opt/zimbra/bin/zmcertmgr deployca -localonly
    ** Importing CA /opt/zimbra/ssl/zimbra/ca/ca.pem into CACERTS...done.
    ** Copying CA to /opt/zimbra/conf/ca...done.
    Wed Feb 15 08:49:00 2012 done.
    Wed Feb 15 08:49:00 2012 Creating SSL certificate...
    Wed Feb 15 08:49:00 2012 *** Running as root user: /opt/zimbra/bin/zmcertmgr createcrt self
    ** Creating /opt/zimbra/conf/zmssl.cnf...done
    ** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20120215084901
    ** Retrieving server config key zimbraSSLCertificate...failed.
    ** Retrieving server config key zimbraSSLPrivateKey...failed.
    ** Generating a server csr for download self -keysize 1024
    ** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20120215084907
    ** Retrieving Commercial CA cert from ldap...failed.
    ** Creating server cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.
    ** Saving server config key zimbraSSLPrivateKey...failed.
    ** Signing cert request /opt/zimbra/ssl/zimbra/server/server.csr...done.
    Wed Feb 15 08:49:13 2012 done.
    Wed Feb 15 08:49:13 2012 Installing mailboxd SSL certificates...
    Wed Feb 15 08:49:13 2012 /opt/zimbra/mailboxd/etc/keystore didn't exist.
    Wed Feb 15 08:49:13 2012 *** Running as root user: /opt/zimbra/bin/zmcertmgr deploycrt self
    ** Saving server config key zimbraSSLCertificate...failed.
    ** Saving server config key zimbraSSLPrivateKey...failed.
    ** Installing mta certificate and key...done.
    ** Installing slapd certificate and key...done.
    ** Installing proxy certificate and key...done.
    ** Creating pkcs12 file /opt/zimbra/ssl/zimbra/jetty.pkcs12...done.
    ** Creating keystore file /opt/zimbra/mailboxd/etc/keystore...done.
    ** Installing CA to /opt/zimbra/conf/ca...done.
    Wed Feb 15 08:49:20 2012 done.
    Wed Feb 15 08:49:20 2012 checking isEnabled zimbra-ldap
    Wed Feb 15 08:49:20 2012 zimbra-ldap is enabled
    Wed Feb 15 08:49:20 2012 Initializing ldap...
    Wed Feb 15 08:49:20 2012 *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    TLS: unsupported extended operation
    Wed Feb 15 08:50:03 2012 failed. (256)
    Wed Feb 15 08:50:03 2012
    
    ERROR
    
    Wed Feb 15 08:50:03 2012
    
    Configuration failed
    Please help me to understand what is the problem.
    Thanx!

  2. #2
    poweredmail is offline Member
    Join Date
    Feb 2012
    Posts
    14
    Rep Power
    3

    Default

    Hi,

    Did you download RHEL 6 Zimbra? If yes,

    use this command and re-start the installation

    Code:
    ./install.sh --platform-override
    Since, There is no version of ZCS for CentOS you can use RHEL build and Use platform override that should help you.

  3. #3
    Vottghern is offline Starter Member
    Join Date
    Feb 2012
    Posts
    2
    Rep Power
    3

    Default

    Forgot to say that the installation is running with the option --platform-override.

  4. #4
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,196
    Rep Power
    9

    Default

    I believe this is related to a bug in net::ldap perl module. It will be fixed in 7.1.5. However, the issue is because of a misconfiguration in DNS (that's what triggers the bug in the perl module).

    --Quanah
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  5. #5
    sjswarts is offline New Member
    Join Date
    Feb 2012
    Posts
    3
    Rep Power
    3

    Default

    I found on another part of this forum (don't know where) that you needed to add this code to the sudoers file...

    Access sudoers by doing typing this into putty (thats what I use)

    Code:
    visudo
    find this code:

    Code:
    Defaults requiretty
    and put this under it:

    Code:
    Defaults:%zimbra !requiretty
    Defaults:zimbra !requiretty
    This worked for me and my install continued without fail. Now I just have a issue with MTA service not running or the zmconfigd service.

    If you find out how to fix that please post back. Or direct me to where it is solved.

    Regards,
    Steve

  6. #6
    mmcvey7355 is offline Starter Member
    Join Date
    Mar 2012
    Posts
    1
    Rep Power
    3

    Default Centos 6.2 install

    Here are the steps I have found to get a successful install on 6.2


    1. Install Centos with nc and dnsmasq
    2. Do the configuration for SplitDNS (a quick search will find it)
    3. build hosts, resolver, and dnsmasq config files
    4. start dnsmasq and set it to autostart with server
    5. Set resolver to localhost
    6. disable SElinux
    7. fix sudoers (as shown or # in front of reqgetty)
    8. copy /usr/lib64/libstdc* to /usr/lib/
    9. stop and disable postfix (fixes MTA won't start)
    10. install with "--platform-overide"

    If i helped let me know, I fought with this for the better part of a week to get these steps down and using them I can get repeatable successful single server split DNS working.

    Thanks

  7. #7
    imonlinux's Avatar
    imonlinux is offline Starter Member
    Join Date
    Nov 2005
    Posts
    1
    Rep Power
    9

    Default Thanks mmcvey7355

    Thanks for the effort in figuring this out and sharing. These steps worked perfectly for me. Saved me a significant amount of time.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ZCS OS 7.1.2 x64 on Centos 6 x64 note
    By malayo in forum Installation
    Replies: 4
    Last Post: 01-21-2012, 04:25 AM
  2. centos 5 zcs 7: Server Status Problems - again
    By alex_rhys-hurn in forum Administrators
    Replies: 0
    Last Post: 03-09-2011, 04:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •