Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Split DNS and dnsmasq confustion

  1. #1
    bishop05 is offline Intermediate Member
    Join Date
    Feb 2012
    Posts
    24
    Rep Power
    3

    Default Split DNS and dnsmasq confustion

    I'm a bit confused, I'm tried to use the WiKi and it stated to install bind9.

    Do both bind and dnsmasq have to be installed, or is it one or the other?

  2. #2
    bishop05 is offline Intermediate Member
    Join Date
    Feb 2012
    Posts
    24
    Rep Power
    3

    Default

    installed bind and followed the Wiki I'm getting the following error.
    DNS ERROR resolving zms1.domain.net
    It is suggested that the hostname be resolveable via DNS
    nslookup reports
    Server: 192.168.1.235
    Address: 192.168.1.235#53

    Non-authoritative answer:
    Name: Domain.net
    Address: 108.41.6.80 my (external address)

  3. #3
    bishop05 is offline Intermediate Member
    Join Date
    Feb 2012
    Posts
    24
    Rep Power
    3

    Default

    please anyone.
    I've been trying this for 2 weeks now and hit road block after road block.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,568
    Rep Power
    57

    Default

    Quote Originally Posted by bishop05 View Post
    I'm a bit confused, I'm tried to use the WiKi and it stated to install bind9.
    There's no reason why you should be confused, it's a fairly easy document to read.

    Quote Originally Posted by bishop05 View Post
    Do both bind and dnsmasq have to be installed, or is it one or the other?
    This quote from the wiki article Overview section:

    Attention! the use of Bind or dnsmasq are mutually exclusive, you have to setup one OR the other!
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    bishop05 is offline Intermediate Member
    Join Date
    Feb 2012
    Posts
    24
    Rep Power
    3

    Default

    okay so why when i try to start named I'm presented with this?
    /etc/init.d/named: No such file or directory? I followed the Wiki to the Tee.

  6. #6
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,568
    Rep Power
    57

    Default

    Quote Originally Posted by bishop05 View Post
    okay so why when i try to start named I'm presented with this?
    /etc/init.d/named: No such file or directory? I followed the Wiki to the Tee.
    I've no idea, it would depend on what the startup script is called on your distribution (whatever that is) but it would imply that BIND isn't installed.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    bishop05 is offline Intermediate Member
    Join Date
    Feb 2012
    Posts
    24
    Rep Power
    3

    Default

    but it's installed i can see the dir and all the files are there.

  8. #8
    bishop05 is offline Intermediate Member
    Join Date
    Feb 2012
    Posts
    24
    Rep Power
    3

    Default

    I'm going to venture to say that the Wiki is not 100% accurate.
    I just created a new VM and when through the splitDNS configs and again there is no named service.

  9. #9
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,568
    Rep Power
    57

    Default

    Quote Originally Posted by bishop05 View Post
    but it's installed i can see the dir and all the files are there.
    .... and you can see the startup script? You still haven't mentioned which distribution you're using. You need to look at the files that are installed and see where it's put the startup script and what it's called.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    bishop05 is offline Intermediate Member
    Join Date
    Feb 2012
    Posts
    24
    Rep Power
    3

    Default

    I'm running Ubuntu server 10.04.
    I'm guessing if your not a Linux Pro, there's really no way to get this off the ground properly.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: 10-29-2012, 10:59 PM
  2. DNS issues
    By nowatkins in forum Administrators
    Replies: 1
    Last Post: 08-06-2011, 10:33 PM
  3. I have a DNS issue, but I can't figure it out.
    By AmandaM in forum Installation
    Replies: 5
    Last Post: 03-21-2011, 10:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •