Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: DNS Error - none of the MX records resolve to this host

  1. #11
    Eclipse is offline Senior Member
    Join Date
    Jun 2011
    Posts
    73
    Rep Power
    3

    Default

    Quote Originally Posted by phoenix View Post
    You can only run one DNS server on a server, the dnsmasq configuration is only there as an alternative (some people find it easier to configure).

    Gotcha, I suppose it helps to read the main article first

    Attention! the use of Bind or dnsmasq are mutually exclusive, you have to setup one OR the other!
    After removing dnsmasq I'm still getting the message though....

    Setting defaults...
    Interface: 192.168.0.111
    Interface: 127.0.0.1


    DNS ERROR - none of the MX records for lulzy.ath.cx
    resolve to this host
    Change domain name? [Yes]

    Like I said before I tried adding the MX record to dyndns but it had no effect.
    Last edited by Eclipse; 02-09-2012 at 02:04 AM.

  2. #12
    farrukhndm is offline Special Member
    Join Date
    Aug 2008
    Location
    Pakistan
    Posts
    100
    Rep Power
    6

    Default

    Here is Split DNS configration for my Production setup . Hope everyone find it beneficial

    Configuring dnsmasq on the Zimbra Server behind pfsense
    Split DNS - Zimbra :: Wiki
    Centos 6
    # yum -y install dnsmasq


    #vi /etc/dnsmasq.conf
    # Add other name servers here, with domain specs if they are for
    # non-public domains.
    server=8.8.8.8
    server=8.8.4.4
    domain=mydomian.com
    mx-host=mydomian.com,mail.mydomian.com,10 listen-address=127.0.0.1

    // My error resolved after correcting Name:mx-host=mydomian.com,mail.mydomian.com,MX
    [root@mail ~]# cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
    10.10.10.110 mail.mydomian.com mail

    [root@mail ~]# hostname
    mail.mydomian.com


    [root@mail ~]# host -t mx mydomian.com
    mydomian.com mail is handled by 10 mail.mydomian.com.

    tail -f /var/log/zimbra.log
    #chkconfig dnsmasq on
    #service dnsmasq restart

    [root@mail ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
    DEVICE=eth0
    BOOTPROTO=none
    NM_CONTROLLED=yes
    TYPE=Ethernet
    IPADDR=10.10.10.110 ( LAN IP)
    NETMASK=255.255.255.0
    GATEWAY=10.10.10.254 # (pfsense LAN IP )
    DNS1=127.0.0.1 # (listen-address=127.0.0.1 in dnsmasq.conf)
    UUID="b1af519c-dc53-4f4e-9635-9f2da670cfac"
    IPV6INIT=no
    USERCTL=no
    HWADDR=00:0c:29:f2:a3:59
    ONBOOT=yes


    In Previous System Centos 5 we have to edit resolve.conf
    Edit the /etc/resolv.conf file
    [root@mail ~]# cat /etc/resolv.conf
    # Generated by NetworkManager
    search mydomian.com
    # No nameservers found; try putting DNS servers into your
    # ifcfg files in /etc/sysconfig/network-scripts like so:
    #
    # DNS1=xxx.xxx.xxx.xxx
    # DNS2=xxx.xxx.xxx.xxx
    # DOMAIN=lab.foo.com bar.foo.com
    nameserver 127.0.0.1

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Daily Report Prob
    By ranjeet_azad in forum Administrators
    Replies: 0
    Last Post: 01-30-2012, 10:03 PM
  2. zmclamdctl is not running after upgrade
    By Darren in forum Installation
    Replies: 24
    Last Post: 10-10-2008, 09:10 AM
  3. Replies: 20
    Last Post: 03-18-2008, 05:37 AM
  4. DNS Strategies and Best Practices, and a SLES10 Request
    By LMStone in forum Administrators
    Replies: 4
    Last Post: 10-14-2006, 07:51 AM
  5. Install Help Suse 10.1
    By rusty741 in forum Installation
    Replies: 21
    Last Post: 10-02-2006, 01:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •