Results 1 to 4 of 4

Thread: Installtion error JRE

  1. #1
    reza225 is offline Advanced Member
    Join Date
    Aug 2006
    Location
    San Diego
    Posts
    193
    Rep Power
    8

    Default Installtion error JRE

    I get the following error in /tmp/zmsetup.log.3256 on RHEL4
    fresh install

    Setting defaults...


    DNS ERROR resolving MX for mail.rndcomputing.com

    It is suggested that the domain name have an MX record configured in DNS

    MX: mail.rndcomputing.com (66.11.117.178)



    Interface: 192.168.0.11

    Interface: 127.0.0.1



    DNS ERROR - none of the MX records for rndcomputing.com

    resolve to this host

    It is suggested that the MX record resolve to this host



    DNS ERROR resolving MX for mail.rndcomputing.com

    It is suggested that the domain name have an MX record configured in DNS

    Done

    Checking for port conflicts

    Saving config in /opt/zimbra/mail.config...
    Done

    Operations logged to /tmp/zmsetup.log.3295

    Setting local config values...
    Setting local config zimbra_server_hostname to mail.rndcomputing.com

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_server_hostname=mail.rndcomputing.com

    Setting local config ldap_master_url to ldap://mail.rndcomputing.com:389

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_master_url=ldap://mail.rndcomputing.com:389

    Setting local config ldap_url to ldap://mail.rndcomputing.com:389

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_url=ldap://mail.rndcomputing.com:389

    Setting local config ldap_port to 389

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_port=389

    Setting local config ldap_host to mail.rndcomputing.com

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ldap_host=mail.rndcomputing.com

    Setting local config zimbra_uid to 501

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_uid=501

    Setting local config zimbra_gid to 501

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_gid=501

    Setting local config zimbra_user to zimbra

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e zimbra_user=zimbra

    Setting local config av_notify_user to admin@mail.rndcomputing.com

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e av_notify_user=admin@mail.rndcomputing.com

    Setting local config ssl_allow_untrusted_certs to TRUE

    *** Running as zimbra user: /opt/zimbra/bin/zmlocalconfig -f -e ssl_allow_untrusted_certs=TRUE

    Done

    Setting up CA...
    *** Running as zimbra user: cd /opt/zimbra; zmcreateca

    ** Creating CA private key

    Generating a 1024 bit RSA private key
    .....++++++
    ............................++++++
    unable to write 'random state'
    writing new private key to '/opt/zimbra/ssl/ssl/ca/ca.key'
    -----
    ** Creating CA cert

    Signature ok
    subject=/C=US/ST=N/A/L=N/A/O=Zimbra Collaboration Suite
    Getting Private key
    unable to write 'random state'
    Done

    Creating SSL certificate...
    chmod: cannot access `/jre/lib/security/cacerts': No such file or directory
    *** Running as zimbra user: cd /opt/zimbra; zmcreatecert

    ** Importing CA

    Certificate was added to keystore
    keytool error: java.io.FileNotFoundException: /opt/zimbra/java/jre/lib/security/cacerts (Permission denied)
    ** Creating keystore

    ** Creating server cert request

    Generating a 1024 bit RSA private key
    ...........++++++
    ..............++++++
    unable to write 'random state'
    writing new private key to '/opt/zimbra/ssl/ssl/server/server.key'
    -----
    ** Signing cert request

    Using configuration from /opt/zimbra/ssl/ssl/zmssl.cnf
    Check that the request matches the signature
    Signature ok
    Certificate Details:
    Serial Number: 2 (0x2)
    Validity
    Not Before: Oct 25 19:08:19 2006 GMT
    Not After : Oct 25 19:08:19 2007 GMT
    Subject:
    countryName = US
    stateOrProvinceName = N/A
    organizationName = Zimbra Collaboration Suite
    commonName = mail.rndcomputing.com
    X509v3 extensions:
    X509v3 Basic Constraints:
    CA:FALSE
    Netscape Comment:
    OpenSSL Generated Certificate
    X509v3 Subject Key Identifier:
    DC7F:FD:3F:0D:29:6B:5B:47:7D:26:37:12:FC:89:14:AB:9C: 15
    X509v3 Authority Key Identifier:
    DirName:/C=US/ST=N/A/L=N/A/O=Zimbra Collaboration Suite
    serial:00

    X509v3 Key Usage:
    Digital Signature, Non Repudiation, Key Encipherment
    Certificate is to be certified until Oct 25 19:08:19 2007 GMT (365 days)

    Write out database with 1 new entries
    Data Base Updated
    unable to write 'random state'
    Signature ok
    subject=/C=US/ST=NA/L=NA/O=Zimbra/OU=Zimbra/CN=mail.rndcomputing.com
    Getting CA Private Key
    unable to write 'random state'
    chmod: cannot access `/jre/lib/security/cacerts': No such file or directory
    Done

    Initializing ldap...
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit

    ERROR - failed to start slapd

    FAILED (256)



    ERROR




    Configuration failed


    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to

    complete the configuration

  2. #2
    reza225 is offline Advanced Member
    Join Date
    Aug 2006
    Location
    San Diego
    Posts
    193
    Rep Power
    8

    Default

    should i just symlink /jre to /usr/lib/jvm/java-1.5.0-ibm-1.5.0.0.x86_64/jre/

  3. #3
    reza225 is offline Advanced Member
    Join Date
    Aug 2006
    Location
    San Diego
    Posts
    193
    Rep Power
    8

    Default

    that worked for the ssl cert part, but now i still have this error in the zmsetup.log

    Write out database with 1 new entries
    Data Base Updated
    unable to write 'random state'
    Signature ok
    subject=/C=US/ST=NA/L=NA/O=Zimbra/OU=Zimbra/CN=mail.rndcomputing.com
    Getting CA Private Key
    unable to write 'random state'
    Done

    Initializing ldap...
    *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit

    ERROR - failed to start slapd

    FAILED (256)



    ERROR




    Configuration failed


    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to

    complete the configuration

  4. #4
    reza225 is offline Advanced Member
    Join Date
    Aug 2006
    Location
    San Diego
    Posts
    193
    Rep Power
    8

    Default

    it didn't seem to like the name of my config file. it works now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Installtion Freezes at zmsetup.pl
    By Shrewd in forum Installation
    Replies: 7
    Last Post: 04-17-2007, 12:26 AM
  2. Replies: 4
    Last Post: 11-08-2006, 12:14 AM
  3. Installtion Zimbra no error, but cannot send any out mail
    By diablo_bsd in forum Installation
    Replies: 3
    Last Post: 08-11-2006, 09:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •