Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: DNS ERROR resolving MX

  1. #1
    chris Fergus is offline Junior Member
    Join Date
    Oct 2006
    Posts
    6
    Rep Power
    8

    Default DNS ERROR resolving MX

    I am trying to install zimbra on an internal network for testing before installing on a production server.

    Installation of zimbra fails with the DNS ERROR resolving MX error and I can't figure out what isn't set up correctly in DNS.

    the test server is running Debian 3.1 (S1)

    The firewall - Debian 3.1 (S2). the firewall is Bind9 for DNS and is also the nameserver.

    DNS is set up as follows:

    DB.Internal
    Code:
    $ORIGIN .
    $TTL 604800	; 1 week
    130.168.192.in-addr.arpa IN SOA	my.domain.com. root.my.domain.com. (
    				1635       ; serial
    				604800     ; refresh (1 week)
    				86400      ; retry (1 day)
    				2419200    ; expire (4 weeks)
    				604800     ; minimum (1 week)
    				)
    			NS	S2.my.domain.com.
    $ORIGIN 130.168.192.in-addr.arpa.
    1			PTR	S2.my.domain.com.
    3			PTR	other.my.domain.com.
    4			PTR	other2.my.domain.com.
    7			PTR	S1.my.domain.com.
    DB.external

    Code:
    $ORIGIN .
    $TTL 43200	; 12 hours
    my.domain.com	IN 	SOA	S2.my.domain.com. root.my.domain.com. (
    				2001100316 ; serial
    				3600       ; refresh (1 hour)
    				900        ; retry (15 minutes)
    				1209600    ; expire (2 weeks)
    				43200      ; minimum (12 hours)
    					)
    			NS	S2.my.domain.com.
    			MX	1 S1.my.domain.com.
    $ORIGIN my.domain.com.
    $TTL 3200	; 53 minutes 20 seconds
    #mail			CNAME	S1
    #S1		              A      192.168.130.7
    other		               A      192.168.130.3
    backup			CNAME  Other
    ftp				A     218.215.130.18
    fulda			       A     192.168.130.4
    mail			       A     218.215.130.18
    S1		               A     192.168.130.7
    testing3	             A     218.215.130.2
    www			      A     218.215.130.6
    S1 resolve.conf looks like this:

    nameserver 192.168.130.1
    domain my.domain.com


    S2 resolve.conf looks like this:

    nameserver other.name.ser.ver
    nameserver 192.168.130.1




    I am able to ping S1.my.domain.com with no problem.


    If I run dig from the firewall (S2)

    dig S1.my.doman.com

    I get the following:

    Code:
    ; <<>> DiG 9.2.4 <<>> S1.my.domain.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 42125
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;S1.my.domain.com.		IN	A
    
    ;; ANSWER SECTION:
    S1.my.domain.com.	3200	IN	A    192.168.130.7
    
    ;; AUTHORITY SECTION:
    my..		43200	IN	NS	S2.my.domain.com.
    
    ;; Query time: 4 msec
    ;; SERVER: 192.168.130.1#53(192.168.130.1)
    ;; WHEN: Sun Oct 22 22:42:23 2006
    ;; MSG SIZE  rcvd: 77
    However, when I dig for the MX

    Code:
    dig 192.168.130.1 -t MX
    
    I get the following:
    
    
    ; <<>> DiG 9.2.4 <<>> -t MX 192.168.130.1
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 32366
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;192.168.130.1.			IN	MX
    
    ;; Query time: 16 msec
    ;; SERVER: 192.168.130.1#53(192.168.130.1)
    ;; WHEN: Sun Oct 22 23:10:29 2006
    ;; MSG SIZE  rcvd: 31
    Even though I have the MX specified in the

    DB.external

    MX 1 S1.my.domain.com.


    So, what don't I have set up correctly in DNS?

    Any help would be appreciated.
    Last edited by chris Fergus; 10-23-2006 at 10:22 AM.

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Welcome to the forums.

    Your post would be more readable if you highlighted a section of text and put 'code' around it (the # symbol above the edit box).

    Have a look ath the DNS in a nutshell post and compare your DNS entries to that. You'll also need your /etc/hosts file set correctly, it's detailed in the forums and the Quick Start Guide.

    What does 'dig mx yourdomain.com' return, is it the IP of your zimbra server?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    chris Fergus is offline Junior Member
    Join Date
    Oct 2006
    Posts
    6
    Rep Power
    8

    Default

    Thanks for the heads up on the code option for readability.

    I ran dig MX my.doman.com and got the following:


    Code:
    ; <<>> DiG 9.2.4 <<>> MX my.domain.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 59311
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;my.domain.com.			IN	MX
    
    ;; ANSWER SECTION:
    my.domain.com.		43200	IN	MX	1 S1.my.domain.com.
    
    ;; AUTHORITY SECTION:
    lucidoc.com.		43200	IN	NS	S2.my.domain.com.
    
    ;; ADDITIONAL SECTION:
    S1.my.domain.com.	3200	IN	A	192.168.130.7
    
    ;; Query time: 5 msec
    ;; SERVER: 192.168.130.1#53(192.168.130.1)
    ;; WHEN: Mon Oct 23 11:56:53 2006
    ;; MSG SIZE  rcvd: 93
    Which to me looks correct, so I ran the zimbra install again, but still got the following error:

    "DNS error resolving MX for S1.my.domain.com
    It is suggested that the domain name have an MX record configured in DNS"

    So I modified the db.external and seperated by one more space the "1" from S1.my.domain.com

    I also incremented the serial number by 1, restarted bind9 , while monitoring syslog and found that it didn't like the added space between the "1" and S1.my.domain.com, so I set things back the way they were, incremented the serial number by 1, saved the db.external. Then restarted bind9.

    Now when I try the dig command, I get the following:

    dig MX my.domain.com

    Code:
    ; <<>> DiG 9.2.4 <<>> MX my.domain.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 41449
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;my.domain.com.			IN	MX
    
    ;; Query time: 3 msec
    ;; SERVER: 192.168.130.1#53(192.168.130.1)
    ;; WHEN: Mon Oct 23 12:23:17 2006
    ;; MSG SIZE  rcvd: 29

    which is the same response I get if I dig the MX using the IP address.
    Last edited by chris Fergus; 10-23-2006 at 12:59 PM.

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    Just to clarify something in your first post. You mention a 'firewall', I'm assuming that's a seperate box from the one you're installing zimbra on (as in S1 & S2) - is that correct? I'm also assuming that the system you're installing zimbra on has no firewall installed at all. I'm not familiar with debian but does it have anything like SElinux?
    Last edited by phoenix; 10-24-2006 at 12:16 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    chris Fergus is offline Junior Member
    Join Date
    Oct 2006
    Posts
    6
    Rep Power
    8

    Default

    That is correct; two seperate boxes and there is no firewall on the box I'm installing zimbra on.

    I'm not familiar with SElinux, so I'm not sure how similar it is to debian.

  6. #6
    rsharpe is offline Elite Member & Volunteer
    Join Date
    Nov 2005
    Location
    London, ON
    Posts
    255
    Rep Power
    9

    Default

    "DNS error resolving MX for S1.my.domain.com
    It is suggested that the domain name have an MX record configured in DNS"
    This was in a previous post. From what I understand you are trying to setup mail for my.domain.com correct? This requires an MX record for my.domain.com. From the above statement it looks as though zimbra is setting up a mail for s1.my.domain.com, and is in turn looking for an MX record for s1.my.domain.com. Try running the install again and double check that it is configured to setup email for my.domain.com, because by default it will setup a email for the local hostname, which makes sense as to why it looks this way.

  7. #7
    chris Fergus is offline Junior Member
    Join Date
    Oct 2006
    Posts
    6
    Rep Power
    8

    Default

    I ran the install again to verify and it is indeed Stpping with the dna error on the macine name "s1.my.domain.com.

    So, are you saying that the MX should be set for the my.domain.com and not s1.my.domain.com [machinename.my.domain.com]?

    If so, then this may be a problem since my existing mailserver (on another server) uses the same domain name.

    I'm trying to set up zimbra for testing and relay through the existing mail server. In order to do this, should I set up a cname alias and assign the MX to the alias.mydomain.com?
    Last edited by chris Fergus; 10-25-2006 at 12:28 AM.

  8. #8
    iceruam is offline Special Member
    Join Date
    Oct 2006
    Posts
    124
    Rep Power
    8

    Default Domain

    did you get an answer to this?

  9. #9
    chris Fergus is offline Junior Member
    Join Date
    Oct 2006
    Posts
    6
    Rep Power
    8

    Default

    To Iceruan -No, haven't received an answer to my last post.

  10. #10
    rsharpe is offline Elite Member & Volunteer
    Join Date
    Nov 2005
    Location
    London, ON
    Posts
    255
    Rep Power
    9

    Default

    Looking at what is returned from your dig command:
    Code:
    ; <<>> DiG 9.2.4 <<>> MX my.domain.com
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 59311
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 1, ADDITIONAL: 1
    
    ;; QUESTION SECTION:
    ;my.domain.com.			IN	MX
    
    ;; ANSWER SECTION:
    my.domain.com.		43200	IN	MX	1 S1.my.domain.com.
    
    ;; AUTHORITY SECTION:
    lucidoc.com.		43200	IN	NS	S2.my.domain.com.
    
    ;; ADDITIONAL SECTION:
    S1.my.domain.com.	3200	IN	A	192.168.130.7
    
    ;; Query time: 5 msec
    ;; SERVER: 192.168.130.1#53(192.168.130.1)
    ;; WHEN: Mon Oct 23 11:56:53 2006
    ;; MSG SIZE  rcvd: 93
    your MX record is fine. The problem is in the Zimbra install.

    At some point in the install it will say something to the affect of:
    DNS ERROR resolving MX for s1.my.domain.com
    Then it asks you to enter the domain. Here is were you need to enter my.domain.com it will then search again and it will find a current MX, all should then be right in the world.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. split dns isn't working for me....
    By lucidblue in forum Installation
    Replies: 5
    Last Post: 06-02-2007, 09:24 PM
  2. :( DNS Lookup issues
    By jhgutierrezg in forum Administrators
    Replies: 3
    Last Post: 05-30-2007, 08:00 AM
  3. ZCS ROCKS! Need some DNS help!
    By SiteDiscovery in forum Administrators
    Replies: 9
    Last Post: 12-30-2006, 10:50 PM
  4. DNS in a nutshell part two (For dummies)
    By daimer77 in forum Installation
    Replies: 4
    Last Post: 12-18-2006, 06:28 PM
  5. DNS Strategies and Best Practices, and a SLES10 Request
    By LMStone in forum Administrators
    Replies: 4
    Last Post: 10-14-2006, 07:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •