Results 1 to 6 of 6

Thread: Error 256 on Installation

  1. #1
    RuinExplorer is offline New Member
    Join Date
    Oct 2006
    Posts
    3
    Rep Power
    8

    Default Error 256 on Installation

    We are trying to quickly get a test server up for evaluation.

    Running Red Hat 4 Enterprise AS

    The MX entry as well as a CNAME entry on the DNS.

    host zimbra.usu.edu gives the following:
    zimbra.usu.edu is an alias for infosys07.tsc.usu.edu
    infosys07.tsc.usu.edu has address 129.123.114.151


    entries on DNS:
    zimbra.usu.edu. 10800 IN CNAME infosys07.tsc.usu.edu.
    infosys07.tsc.usu.edu. 10800 IN MX 10 zimbra.usu.edu.
    infosys07.tsc.usu.edu. 10800 IN A 129.123.114.151

    When we install we get an MX error and another on ldap. We need help to have a test server in place to show that zimbra can compete with the other options of GroupWise and Exchange.

    I have looked through the Threads to see that several people have these problems, but they seldom finish out the solution (usually people get a little help and figure it out on their own). I have looked into a couple of the threads, but my limited linux exposure is crippling my efforts.

    Installation attempt follows:

    [root@infosys07 zcs]# ./install.sh

    Operations logged to /tmp/install.log.7709
    Checking for existing installation...
    zimbra-ldap...NOT FOUND
    zimbra-logger...NOT FOUND
    zimbra-mta...NOT FOUND
    zimbra-snmp...NOT FOUND
    zimbra-store...NOT FOUND
    zimbra-apache...NOT FOUND
    zimbra-spell...NOT FOUND
    zimbra-core...NOT FOUND


    PLEASE READ THIS AGREEMENT CAREFULLY BEFORE USING THE SOFTWARE.
    ZIMBRA, INC. ("ZIMBRA") WILL ONLY LICENSE THIS SOFTWARE TO YOU IF YOU
    FIRST ACCEPT THE TERMS OF THIS AGREEMENT. BY DOWNLOADING OR INSTALLING
    THE SOFTWARE, OR USING THE PRODUCT, YOU ARE CONSENTING TO BE BOUND BY
    THIS AGREEMENT. IF YOU DO NOT AGREE TO ALL OF THE TERMS OF THIS
    AGREEMENT, THEN DO NOT DOWNLOAD, INSTALL OR USE THE PRODUCT.

    License Terms for the Zimbra Collaboration Suite:
    http://www.zimbra.com/license/zimbra...al_license.pdf


    Press Return to continue

    Checking for prerequisites...
    NPTL...FOUND
    sudo...FOUND sudo-1.6.7p5-30.1.3
    libidn...FOUND libidn-0.5.6-1
    curl...FOUND curl-7.12.1-8
    fetchmail...FOUND fetchmail-6.2.5-6
    gmp...FOUND gmp-4.1.4-3
    compat-libstdc++-296...FOUND compat-libstdc++-296-2.96-132.7.2
    compat-libstdc++-33...FOUND compat-libstdc++-33-3.2.3-47.3
    /usr/lib/libstdc++.so.5...FOUND

    Checking for installable packages

    Found zimbra-core
    Found zimbra-ldap
    Found zimbra-logger
    Found zimbra-mta
    Found zimbra-snmp
    Found zimbra-store
    Found zimbra-apache
    Found zimbra-spell


    Select the packages to install

    Install zimbra-ldap [Y] y

    Install zimbra-logger [Y] y

    Install zimbra-mta [Y] y

    Install zimbra-snmp [Y] y

    Install zimbra-store [Y] y

    Install zimbra-spell [Y] y

    Installing:
    zimbra-core
    zimbra-ldap
    zimbra-logger
    zimbra-mta
    zimbra-snmp
    zimbra-store
    zimbra-apache
    zimbra-spell

    The system will be modified. Continue? [N] y

    Removing /opt/zimbra
    Installing packages

    zimbra-core......zimbra-core-4.0.3_GA_406.RHEL4-20061016143637.i386.rpm...done
    zimbra-ldap......zimbra-ldap-4.0.3_GA_406.RHEL4-20061016143637.i386.rpm...done
    zimbra-logger......zimbra-logger-4.0.3_GA_406.RHEL4-20061016143637.i386.rpm...done
    zimbra-mta......zimbra-mta-4.0.3_GA_406.RHEL4-20061016143637.i386.rpm...done zimbra-snmp......zimbra-snmp-4.0.3_GA_406.RHEL4-20061016143637.i386.rpm...done
    zimbra-store......zimbra-store-4.0.3_GA_406.RHEL4-20061016143637.i386.rpm...done
    zimbra-apache......zimbra-apache-4.0.3_GA_406.RHEL4-20061016143637.i386.rpm...done
    zimbra-spell......zimbra-spell-4.0.3_GA_406.RHEL4-20061016143637.i386.rpm...done
    Operations logged to /tmp/zmsetup.log.8432
    Setting defaults... MX: zimbra.usu.edu (129.123.114.151)

    Interface: 192.168.1.101
    Interface: 127.0.0.1
    129.123.114.151
    129.123.114.151


    DNS ERROR - none of the MX records for infosys07.tsc.usu.edu
    resolve to this host
    Change domain name? [Yes] y
    Create Domain: [infosys07.tsc.usu.edu] zimbra.usu.edu
    MX: zimbra.usu.edu (129.123.114.151)

    Interface: 192.168.1.101
    Interface: 127.0.0.1


    DNS ERROR - none of the MX records for zimbra.usu.edu
    resolve to this host
    It is suggested that the MX record resolve to this host
    Re-Enter domain name? [Yes] n
    Done
    Checking for port conflicts

    Main menu

    1) Hostname: infosys07.tsc.usu.edu
    2) Ldap master host: infosys07.tsc.usu.edu
    3) Ldap port: 389
    4) Ldap password: set
    5) zimbra-ldap: Enabled
    6) zimbra-store: Enabled
    +Create Admin User: yes
    +Admin user to create: admin@zimbra.usu.edu
    ******* +Admin Password UNSET
    +Enable automated spam training: yes
    +Spam training user: skwr321sw@zimbra.usu.edu
    +Non-spam(Ham) training user: ogvkqeb79@zimbra.usu.edu
    +SMTP host: infosys07.tsc.usu.edu
    +Web server HTTP port: 80
    +Web server HTTPS port: 443
    +Web server mode: http
    +Enable POP/IMAP proxy: no
    +IMAP server port: 143
    +IMAP server SSL port: 993
    +POP server port: 110
    +POP server SSL port: 995
    +Use spell check server: yes
    +Spell server URL: http://infosys07.tsc.usu.edu:7780/aspell.php

    7) zimbra-mta: Enabled
    8) zimbra-snmp: Enabled
    9) zimbra-logger: Enabled
    10) zimbra-spell: Enabled
    11) Enable default backup schedule: yes
    r) Start servers after configuration yes
    s) Save config to file
    x) Expand menu
    q) Quit

    Address unconfigured (**) items (? - help) 1

    Please enter the logical hostname for this host [infosys07.tsc.usu.edu] zimbra.usu.edu

    Main menu

    1) Hostname: zimbra.usu.edu
    2) Ldap master host: zimbra.usu.edu
    3) Ldap port: 389
    4) Ldap password: set
    5) zimbra-ldap: Enabled
    6) zimbra-store: Enabled
    +Create Admin User: yes
    +Admin user to create: admin@zimbra.usu.edu
    ******* +Admin Password UNSET
    +Enable automated spam training: yes
    +Spam training user: skwr321sw@zimbra.usu.edu
    +Non-spam(Ham) training user: ogvkqeb79@zimbra.usu.edu
    +SMTP host: zimbra.usu.edu
    +Web server HTTP port: 80
    +Web server HTTPS port: 443
    +Web server mode: http
    +Enable POP/IMAP proxy: no
    +IMAP server port: 143
    +IMAP server SSL port: 993
    +POP server port: 110
    +POP server SSL port: 995
    +Use spell check server: yes
    +Spell server URL: http://zimbra.usu.edu:7780/aspell.php

    7) zimbra-mta: Enabled
    8) zimbra-snmp: Enabled
    9) zimbra-logger: Enabled
    10) zimbra-spell: Enabled
    11) Enable default backup schedule: yes
    r) Start servers after configuration yes
    s) Save config to file
    x) Expand menu
    q) Quit

    Address unconfigured (**) items (? - help) 6


    Store configuration

    1) Status: Enabled
    2) Create Admin User: yes
    3) Admin user to create: admin@zimbra.usu.edu
    ** 4) Admin Password UNSET
    5) Enable automated spam training: yes
    6) Spam training user: skwr321sw@zimbra.usu.edu
    7) Non-spam(Ham) training user: ogvkqeb79@zimbra.usu.edu
    8) SMTP host: zimbra.usu.edu
    9) Web server HTTP port: 80
    10) Web server HTTPS port: 443
    11) Web server mode: http
    12) Enable POP/IMAP proxy: no
    13) IMAP server port: 143
    14) IMAP server SSL port: 993
    15) POP server port: 110
    16) POP server SSL port: 995
    17) Use spell check server: yes
    18) Spell server URL: http://zimbra.usu.edu:7780/aspell.php

    Select, or 'r' for previous menu [r] 4

    Password for admin@zimbra.usu.edu (min 6 characters): [ik.msNhO] ******

    Store configuration

    1) Status: Enabled
    2) Create Admin User: yes
    3) Admin user to create: admin@zimbra.usu.edu
    4) Admin Password set
    5) Enable automated spam training: yes
    6) Spam training user: skwr321sw@zimbra.usu.edu
    7) Non-spam(Ham) training user: ogvkqeb79@zimbra.usu.edu
    8) SMTP host: zimbra.usu.edu
    9) Web server HTTP port: 80
    10) Web server HTTPS port: 443
    11) Web server mode: http
    12) Enable POP/IMAP proxy: no
    13) IMAP server port: 143
    14) IMAP server SSL port: 993
    15) POP server port: 110
    16) POP server SSL port: 995
    17) Use spell check server: yes
    18) Spell server URL: http://zimbra.usu.edu:7780/aspell.php

    Select, or 'r' for previous menu [r]

    Main menu

    1) Hostname: zimbra.usu.edu
    2) Ldap master host: zimbra.usu.edu
    3) Ldap port: 389
    4) Ldap password: set
    5) zimbra-ldap: Enabled
    6) zimbra-store: Enabled
    7) zimbra-mta: Enabled
    8) zimbra-snmp: Enabled
    9) zimbra-logger: Enabled
    10) zimbra-spell: Enabled
    11) Enable default backup schedule: yes
    r) Start servers after configuration yes
    s) Save config to file
    x) Expand menu
    q) Quit

    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes] y
    Save config in file: [/opt/zimbra/config.8432]
    Saving config in /opt/zimbra/config.8432...Done
    The system will be modified - continue? [No] y
    Operations logged to /tmp/zmsetup.log.8432
    Setting local config values...Done
    Setting up CA...Done
    Creating SSL certificate...Done
    Initializing ldap...FAILED (256)


    ERROR



    Configuration failed

    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration[root@infosys07 zcs]#
    Last edited by RuinExplorer; 10-19-2006 at 09:21 AM.

  2. #2
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    How does your /etc/hosts look?

    Also, ensure that 389 is not blocked by the firewall.
    Last edited by czaveri; 10-18-2006 at 02:43 PM. Reason: Removed: What is the hostname of the system?
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  3. #3
    pbruna is offline Project Contributor
    Join Date
    Feb 2006
    Posts
    92
    Rep Power
    9

    Default

    Do you have openssl097a installed?

    rpm -qa |grep openssl0

    if the answer its no, install it, and try again.
    Patricio Bruna
    http://www.itlinux.cl

  4. #4
    RuinExplorer is offline New Member
    Join Date
    Oct 2006
    Posts
    3
    Rep Power
    8

    Default

    rpm -qa |grep openssl0 responds:
    openssl096b-0.9.6b-22.42

    /etc/hosts has the single entry:
    127.0.0.1 localhost.localdomain localhost

    and since we are simply trying to qickly get a test server up, the firewall is turned off.

  5. #5
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    You /etc/hosts shoud look like this to install Zimbra:
    Code:
    127.0.0.1 localhost.localdomain localhost
    192.168.0.5 hostname.domain.com hostname
    (You need to have at least these two lines)
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  6. #6
    RuinExplorer is offline New Member
    Join Date
    Oct 2006
    Posts
    3
    Rep Power
    8

    Default

    OK, I feel foolsih. I was doing something entirely unrelated and in the process I did a ping again the sever ip address... which timed out every time...

    So, I followed the cord back to a router, (cursed profusely) unplugged it, plugged it into the switch I assumed it was plugged into, uninstalled zimbra, changed the server hostname to what I wanted in the first place, reset the server, and proceeded to have a successful install.

    Thanks for all your help guys. I wish it had been a more interesting solution than this, but I'll take what I can get.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Installation Failed
    By freit5 in forum Installation
    Replies: 2
    Last Post: 08-17-2006, 11:38 PM
  2. Installation fails on zimbra-store
    By wyleyrabbit in forum Installation
    Replies: 8
    Last Post: 01-15-2006, 08:19 AM
  3. Replies: 16
    Last Post: 01-05-2006, 09:55 AM
  4. Installation on FC3 under Xen
    By andreground in forum Installation
    Replies: 9
    Last Post: 11-14-2005, 10:29 AM
  5. Installation problem
    By sywong70 in forum Installation
    Replies: 5
    Last Post: 11-07-2005, 09:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •