Results 1 to 8 of 8

Thread: Cannot send mail.

  1. #1
    jeremyshoe is offline Member
    Join Date
    Oct 2006
    Posts
    10
    Rep Power
    8

    Default Cannot send mail.

    I got everthing installed ok but I cannot send mail. Is there a service I can stop or restart or a setting I can use to fix this. Also fyi I am sending mail internally on my local network. Any help would be great.
    Thanks,
    Jeremy

  2. #2
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    ssh host.yourdomain.com

    su - zimbra
    zmcontrol status

    (If you see anything stopped or not working ...)

    zmcontrol stop
    ps aux | grep zimbra
    (kill all lingering processes)

    zmcontrol start

    check again:
    zmcontrol status

    exit
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  3. #3
    jeremyshoe is offline Member
    Join Date
    Oct 2006
    Posts
    10
    Rep Power
    8

    Default I did a reinstall but still no go.

    I did a reinstall but still no go.
    postfix: fatal: file /opt/zimbra/postfix-2.2.9/conf/main.cf: parameter mail_owner: unknown user name value: postfix
    Gives me that error.

    any ideas

  4. #4
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Looks like the install was not 100% successful. It probably didn't create 'postfix' user.

    Try these:
    grep postfix /etc/passwd
    grep postfix /etc/group
    grep postfix /etc/shadow

    Do these show the user/group?
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  5. #5
    brianpwolfe is offline Intermediate Member
    Join Date
    Oct 2006
    Posts
    18
    Rep Power
    8

    Default

    Jeremy,

    You may be having the same problem as me. When you go to the zimbraAdmin page, and look in the queues. Is all your mail getting stuck in the deferred or active queue?

    Check out my post for 'Unable To Send Mail - No route to host - Error' as well.

    Good Luck
    Brian

  6. #6
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Quote Originally Posted by brianpwolfe
    You may be having the same problem as me. When you go to the zimbraAdmin page, and look in the queues. Is all your mail getting stuck in the deferred or active queue?

    Check out my post for 'Unable To Send Mail - No route to host - Error' as well.

    Actually, I think this is a different problem, though the solution matrix may co-incide but it doesn't look like the same.
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  7. #7
    jeremyshoe is offline Member
    Join Date
    Oct 2006
    Posts
    10
    Rep Power
    8

    Default Correct postfix needed a user.

    Correct postfix needed a user. I set the username as zimbra. Not sure if that is what I should have done but it works. I also had to set permissions postfix permissions.
    Thanks,
    Jeremy

  8. #8
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    If it works, then it is ok. But my system shows permissions as follows:


    Code:
    [czaveri@arihant ~]$ ls -al //opt/zimbra/postfix-2.2.9/
    total 28
    drwxr-xr-x   7 root root	4096 Sep 27 04:08 .
    drwxr-xr-x  48 root root	4096 Sep 27 04:12 ..
    drwxrwxrwx   2 root postfix 4096 Oct 18 04:34 conf
    drwxr-xr-x   2 root root	4096 Sep 27 04:08 libexec
    drwxr-xr-x   5 root root	4096 Sep 27 04:08 man
    drwxr-xr-x   2 root root	4096 Sep 27 04:08 sbin
    drwxr-xr-x  16 root postfix 4096 Sep 27 04:08 spool
    [czaveri@arihant ~]$ ls -al /opt/zimbra/postfix-2.2.9/conf
    total 216
    drwxrwxrwx  2 root   postfix  4096 Oct 18 04:34 .
    drwxr-xr-x  7 root   root	 4096 Sep 27 04:08 ..
    -rw-r--r--  1 root   postfix 15647 Jul 13 06:46 access
    -rw-r--r--  1 root   postfix  8240 Jul 13 06:46 aliases
    -rw-r--r--  1 root   postfix 10947 Jul 13 06:46 canonical
    -rw-r--r--  1 root   postfix  9622 Jul 13 06:46 generic
    -rw-r--r--  1 root   postfix 16393 Jul 13 06:46 header_checks
    -rw-r--r--  1 root   postfix 11942 Jul 13 06:46 LICENSE
    -rw-r--r--  1 zimbra zimbra   1599 Oct 18 04:34 main.cf
    -rw-r--r--  1 root   postfix 14379 Jul 13 06:46 main.cf.default
    -rw-r--r--  1 root   postfix  1939 Jul 13 06:46 makedefs.out
    -rw-r--r--  1 root   postfix  5120 Sep 25 08:43 master.cf
    -rw-r--r--  1 root   postfix 17077 Jul 13 06:46 postfix-files
    -rwxr-xr-x  1 root   postfix  6366 Jul 13 06:46 postfix-script
    -rwxr-xr-x  1 root   postfix 22018 Jul 13 06:46 post-install
    -rw-r--r--  1 root   postfix  1024 Oct 18 09:37 prng_exch
    -rw-r--r--  1 root   postfix  6523 Jul 13 06:46 relocated
    -rw-r--r--  1 root   postfix  1629 Jul 13 06:46 TLS_LICENSE
    -rw-r--r--  1 root   postfix 11033 Jul 13 06:46 transport
    -rw-r--r--  1 root   postfix 11732 Jul 13 06:46 virtual
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  2. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM
  3. DynDNS and Zimbra
    By afterwego in forum Installation
    Replies: 30
    Last Post: 04-01-2007, 03:34 PM
  4. Installed OK - Can send but not recieve email
    By gregbazar in forum Installation
    Replies: 3
    Last Post: 11-05-2005, 04:56 PM
  5. Mail not getting to mail boxes
    By ehults in forum Installation
    Replies: 5
    Last Post: 10-31-2005, 09:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •