Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Building a Mirror

  1. #1
    arg
    arg is offline Member
    Join Date
    Oct 2006
    Location
    Boulder CO
    Posts
    14
    Rep Power
    8

    Default Building a Mirror

    Hello I currently run the open source version of Zimbra.

    I only have a test base of 6 users. The company is willing to roll it out company wide but I have to verify the backup/rollover options.
    I have seen this: http://wiki.zimbra.com/index.php?tit...ckup_Procedure

    I have done the:
    zmcontrol stop
    cp -rp /archive/zimbra_master /opt
    tar -cf /archive/zimbra_master.tar zimbra_master
    gzip /archive/zimbra_master.tar

    scp /archive/zimbra_master.tar.gz to backup_server:/opt
    tar -xvzf [name of file].tgz
    cd zcs
    ./install.sh
    it upgrades over my backup version

    chown -R zimbra:zimbra /opt/zimbra/st*


    However during the upgrade it conflicts over ports.
    Port conflict detected: 25 (zimbra-mta)
    Port conflict detected: 80 (zimbra-store)
    Port conflict detected: 443 (zimbra-store)
    Port conflicts detected! - Any key to continue

    My master has them set to different ports.
    My mirro default empty install also was set to the matching master ports before.

    Starting servers...Done.

    Now it says it is up. However I can not get to anything since the ports are conflicted.
    And they do not respond with the webserver off as well.

    Is their a simple config to edit/copy to change the ports ? and see if I actually have my backup version up?

    Keith

  2. #2
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    In the light of what I understand you want to do:

    Do these links help?
    Changing service port
    www Port Conflict/Changing Zimbra Apache Setting

    zmprov is the utility.

    I haven't really looked at changing SMTP port. So that will be an exercise. I am thinking it should be possible by using zmprov.
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  3. #3
    arg
    arg is offline Member
    Join Date
    Oct 2006
    Location
    Boulder CO
    Posts
    14
    Rep Power
    8

    Default Thanks

    Hmm thanks,

    I have done this

    su - zimbra
    zmprov ms SERVERNAME zimbraMailPort 8080
    zmprov ms SERVERNAME zimbraMailSSLPort 444
    tomcat restart

    and I did get a response on 8080.

    So thanks !

    Now however login has failed.

    What is the best way to edit account logins via command line?

  4. #4
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Is this thread helpful?
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  5. #5
    arg
    arg is offline Member
    Join Date
    Oct 2006
    Location
    Boulder CO
    Posts
    14
    Rep Power
    8

    Default Still got issues

    Hello,

    1st thanks for all the help so far.

    SO I tried these steps again with no luck.

    I did a fresh install of Zimbra.
    Got it up and in just fine.

    Moved the original zimbra folder to a zim_back
    Moved the tar.gz version of live zimbra to /opt/zimbra

    Install again as upgrade.

    port conflicts and etc.

    [zimbra@major bin]$ zmprov gs major.activeresponsegroup.com | grep Mode
    zimbraMailMode: http
    [zimbra@major bin]$ zmprov ms major.activeresponsegroup.com zimbraMailPort 8080
    [zimbra@major bin]$ zmprov ms major.activeresponsegroup.com zimbraMailSSLPort 444
    [zimbra@major bin]$ tomcat restart
    Error: tomcat not running (pid 13997), stale pid file?


    When I got it up before I couldnt log in as well.

  6. #6
    arg
    arg is offline Member
    Join Date
    Oct 2006
    Location
    Boulder CO
    Posts
    14
    Rep Power
    8

    Default Now what :)

    Hello,

    So After a complete new copy I got the backup and was allowed to config ports and etc during upgrade of backup copy. I added a new admin to server to make sure I had an account to get into.

    Now via the admin interface I see my user accounts, view mail goes to the original server.

    I also can not log into the backup server as a previous user. What settings do I need to move accounts to the new backup server and get access into the box via them ?

    By removing the master domain will they all defualt to the backup server?

  7. #7
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Can you confirm that you stopped Zimbra before backing it up?

    Also make sure that before you backup there shouldn't be any zimbra processes running. If there are any of these running, kill them gracefully.

    Instead of using 'cp' for copying, can you try using:

    Code:
    rsync -avrlHKpogDt /opt/zimbra/ /opt/zim_back
    Then:

    Code:
    tar cvzf /opt/zimback.tar.gz /opt/zim_back
    Note: I haven't tried this, yet, but perhaps using the "-p" flag with tar will preserve permissions. You might want to check that out.
    Last edited by czaveri; 10-17-2006 at 09:37 PM. Reason: tar cvzf /opt/zimback.tar.gz /opt/zim_back
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  8. #8
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    If you backup /opt/zimbra preserving permissions and ownerships, I don't think you should have any problems. All your accounts are backed up when you do so.
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  9. #9
    arg
    arg is offline Member
    Join Date
    Oct 2006
    Location
    Boulder CO
    Posts
    14
    Rep Power
    8

    Default OH I am in

    I am in the admin version of server now.

    I just need to verify I can actually get to user accounts.
    So far view mail sends me to the master version.

    How do I reset the mail server domain?

    So all the older accounts can log in ok to the new domain

  10. #10
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Not to discourage you, just my view: All this is looking like a not so good plan. NO reasons, really, just a feeling.

    http://wiki.zimbra.com/index.php?title=ZmSetServerName

    Please let us know how things work out. Maybe a How-to on the wiki, if it is not inconvenient.
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 01-02-2008, 03:17 PM
  2. Building Zimbra
    By raks35 in forum Developers
    Replies: 1
    Last Post: 06-12-2007, 11:04 AM
  3. list of CPAN modules zimbra uses for building perl
    By ravinder in forum Developers
    Replies: 3
    Last Post: 06-28-2006, 10:39 AM
  4. problem while building perl
    By ravinder in forum Developers
    Replies: 7
    Last Post: 05-29-2006, 09:38 AM
  5. Building from zcs-3.0.0_M2_740-src.tgz
    By daly1 in forum Installation
    Replies: 5
    Last Post: 12-20-2005, 05:47 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •