Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: [SOLVED] Initializing LDAP fails (28416) on installation on Ubuntu 10.04

  1. #1
    mikee is offline Junior Member
    Join Date
    May 2011
    Posts
    6
    Rep Power
    4

    Default [SOLVED] Initializing LDAP fails (28416) on installation on Ubuntu 10.04

    Hi,
    I'm desperately trying to install Zimbra 7.1 OSE on a Ubuntu 10.04 LTS server behind a NAT. The zmsetup-script fails on "Initializing LDAP (28416)". I had a different ldap error before which i sorted out by setting up a split-dns installation. The A and MX entries should now properly resolve the hostname to the private IP. However, I can't come across the error 28416.

    When I try to start slapd manually by
    "/opt/zimbra/openldap/sbin/slapd -d -1 -u zimbra -f /opt/zimbra/openldap/etc/openldap/slapd.conf"
    it fails with error "Unknown database: bdb". I figured out that the bdb-backend libraries are missing. So I changed /opt/zimbra/openldap/etc/openldap/slapd.conf to

    # Load dynamic backend modules:
    modulepath /opt/zimbra/openldap-2.4.23.6z/sbin/openldap
    # moduleload back_bdb.la
    moduleload back_hdb.so
    # moduleload back_ldap.so

    ...

    ################################################## #####################
    # BDB database definitions
    ################################################## #####################

    database hdb
    slapd now would start successfully, but the zmsetup.pl script still fails with the same error. I've already purge and reinstalled the packages several times.

    Any ideas?

    Thanks,

    Mike

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,502
    Rep Power
    57

    Default

    Quote Originally Posted by mikee View Post
    Hi,
    I'm desperately trying to install Zimbra 7.1 OSE on a Ubuntu 10.04 LTS server behind a NAT. The zmsetup-script fails on "Initializing LDAP (28416)". I had a different ldap error before which i sorted out by setting up a split-dns installation. The A and MX entries should now properly resolve the hostname to the private IP
    Post the output from all the commands in the 'Verify...' section of the Split DNS article.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    mikee is offline Junior Member
    Join Date
    May 2011
    Posts
    6
    Rep Power
    4

    Default

    root@mail:~# dig redmouse.cc mx

    ; <<>> DiG 9.7.0-P1 <<>> redmouse.cc mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 7493
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;redmouse.cc. IN MX

    ;; ANSWER SECTION:
    redmouse.cc. 0 IN MX 5 mail.redmouse.cc.

    ;; ADDITIONAL SECTION:
    mail.redmouse.cc. 0 IN A 192.168.2.6

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu May 12 12:09:06 2011
    ;; MSG SIZE rcvd: 77
    root@mail:~# dig redmouse.cc any

    ; <<>> DiG 9.7.0-P1 <<>> redmouse.cc any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 17477
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;redmouse.cc. IN ANY

    ;; ANSWER SECTION:
    redmouse.cc. 0 IN MX 5 mail.redmouse.cc.

    ;; ADDITIONAL SECTION:
    mail.redmouse.cc. 0 IN A 192.168.2.6

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Thu May 12 12:09:44 2011
    ;; MSG SIZE rcvd: 77
    root@mail:~# host $(hostname)
    mail.redmouse.cc has address 192.168.2.6
    Thanks,

    Mike

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,502
    Rep Power
    57

    Default

    You've missed the output from the /etc/hosts file.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    mikee is offline Junior Member
    Join Date
    May 2011
    Posts
    6
    Rep Power
    4

    Default

    Quote Originally Posted by phoenix View Post
    You've missed the output from the /etc/hosts file.
    root@mail:~# cat /etc/hosts
    127.0.0.1 localhost
    192.168.2.6 mail.redmouse.cc mail
    xyjfe00::0 ip6-localnet
    ff00::0 ip6-mcastprefix
    ff02::1 ip6-allnodes
    ff02::2 ip6-allrouters
    Thanks for you quick replies!

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,502
    Rep Power
    57

    Default

    Your hosts file is incorrect, go to the Split DNS article and check the correct format of the loopback entry - make that change and try starting Zimbra again.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    mikee is offline Junior Member
    Join Date
    May 2011
    Posts
    6
    Rep Power
    4

    Default

    Thank you for your help, but still no success.

    My /etc/hosts file looks like this now:

    127.0.0.1 localhost.localdomain localhost
    192.168.2.6 mail.redmouse.cc mail
    Still:

    *** CONFIGURATION COMPLETE - press 'a' to apply
    Select from menu, or press 'a' to apply config (? - help) a
    Save configuration data to a file? [Yes]
    Save config in file: [/opt/zimbra/config.9507] /root/zimbra.conf
    Saving config in /root/zimbra.conf...done.
    The system will be modified - continue? [No] y
    Operations logged to /tmp/zmsetup.05122011-234228.log
    Setting local config values...done.
    Setting up CA...done.
    Deploying CA to /opt/zimbra/conf/ca ...done.
    Creating SSL certificate...done.
    Installing mailboxd SSL certificates...done.
    Initializing ldap...failed. (28416)


    ERROR



    Configuration failed

    Please address the error and re-run /opt/zimbra/libexec/zmsetup.pl to
    complete the configuration.

    Errors have been logged to /tmp/zmsetup.05122011-234228.log
    Did I miss something?

    Br,
    Mike

  8. #8
    mikee is offline Junior Member
    Join Date
    May 2011
    Posts
    6
    Rep Power
    4

    Default

    Ok, I'm one step further...I setuid to /usr/sudo as claimed in the install.log. Now I get error 5632 bad hostname....

  9. #9
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,271
    Rep Power
    10

    Default

    I'll just note that ZCS doesn't use slapd.conf, so modifying it will have no affect on ZCS installs.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  10. #10
    mikee is offline Junior Member
    Join Date
    May 2011
    Posts
    6
    Rep Power
    4

    Default

    Thank you all, gents, for your quick assistance. I finally found the solution(s): The error 28416 appears to be related to a non-standard sudo configuation, whatever caused this as the server installation was pretty fresh. The subsequent error 5632 occured probably to a wrongly stored hostname before the split-dns was set correctly in the configuration file I tried to reuse. After a complete de- and reinstall i finally worked. So I mark this thread as solved.
    Thanks again!

    Mike

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ldap not initializing on Ubuntu with zimbra 5RC2
    By askov in forum Installation
    Replies: 14
    Last Post: 12-09-2007, 03:45 AM
  2. installation fails on ubuntu 7.10
    By josevis in forum Installation
    Replies: 16
    Last Post: 11-22-2007, 03:44 PM
  3. Replies: 9
    Last Post: 04-14-2007, 08:31 AM
  4. Replies: 4
    Last Post: 11-15-2006, 12:16 PM
  5. Replies: 4
    Last Post: 11-07-2006, 07:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •