Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Unable To Send Mail - No route to host - Error

  1. #1
    brianpwolfe is offline Intermediate Member
    Join Date
    Oct 2006
    Posts
    18
    Rep Power
    8

    Default Unable To Send Mail - No route to host - Error

    No route to host.

    All of my email is getting stuck in the deferred queue.

    From my research, I assume this has something to do with DNS. Can anyone explain to me how this is suppose to be setup?

    I have been working at it and gotten this far:

    1. RHEL4 box.
    2. Edited the named.conf file to include my zone. --> domain.com
    3. Added my zone file domain.com to the /var/named/chroot/var/named directory.
    4. In my zone file added ns1, ns2, and mail for the 2 name servers and MX record, all pointing to my ip address.
    5. Went out to the company I bought the domain from in order to edit my DNS record. Added NS1, and NS2, pointing to my IP address.
    6. Installed Open Source 4.0.2 edition.

    Now down to a few questions.
    -What IP addresses should be in my resolv.conf file?
    -What am I missing in this DNS puzzle?

    This is my first real encounter with DNS and I have been struggling to get this far.
    -If anyone can elaborate and tell me what I am missing, point me to a good tutorial or example, etc. It would be appreciated.

    Brian

  2. #2
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,201
    Rep Power
    56

    Default

    You shouldn't need to modify the resolve.conf Have a look for a thread titled 'DNS in a Nutshell' it details what you need your DNS to look like (I assume you're using BIND). Also make sure your /etc/hosts file is correct - details are in the Quick Start Guide.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    brianpwolfe is offline Intermediate Member
    Join Date
    Oct 2006
    Posts
    18
    Rep Power
    8

    Default Still Having Trouble

    I followed the directions in the forum post and changed my resolv.conf file to just read:

    nameserver 127.0.0.1

    resterted named

    Still no luck sending outgoing mail. One thing that did catch my eye, and I think is where my problem might be is in my zone file. Here are the contents.

    Can anyone tell me if this looks right?

    HTML Code:
    $ORIGIN domain.com.
    @     3600      IN      SOA     ns1.domain.com. admin.domain.com. (
                    2006101401 ;    serial
                    172800 ;        refresh
                    3600 ;          retry
                    1209600 ;       expire
                    3600 ;          ttl
                    )
    
                    IN      NS              ns1
                    IN      NS              ns2
                    IN      MX      10      mail
                    IN      A               1.2.3.4
    
    mail            IN      A               1.2.3.4
    www             IN      A               1.2.3.4
    ns1             IN      A               1.2.3.4
    ns2             IN      A               1.2.3.4
    Last edited by brianpwolfe; 10-16-2006 at 07:02 AM. Reason: resterted named

  4. #4
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    named is not the only parameter.

    Here is how I would check this:

    1. Network
    a) Don't start named yet.
    b) Ensure that your eth IP is properly set
    c) Ensure that your hostname is properly set
    d) Ensure that your /etc/hosts looks something like this:
    Code:
    127.0.0.1	   localhost.localdomain   localhost
    192.168.106.11 hostname.domain.com 	  hostname
    e) Ensure that you can ping localhost
    f) Ensure that you can ping hostname
    g) Ensure that you can ping gateway IP
    (If not, check the results of "/sbin/route -n"
    h) Enter your ISP provided DNS in /etc/resolv.conf
    i) Ensure that you can ping google.com or yahoo.com
    (If not, ping the DNS IP and confirm that they are there)

    2. DNS
    a) (I think) your zone configs look Ok
    b) Start named
    c) Enter the DNS server IP in resolv.conf (Is your "named" on the same host?) and comment out the previous one (that is, your ISP provided ...).
    d) dig domain.com
    (Are you getting proper response?)
    e) Enter these DNS servers in resolv.conf on some other host
    On and from the other host:
    f) Ensure you don't have hostname in /etc/hosts
    g) Ping domain.com
    (If you don't get a response, dig it!)
    h) Ping hostname.domain.com
    (If you don't get a response, dig it!)
    If all of these work, and if you can see MX from this host when you dig, it should work.

    Does it?
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  5. #5
    brianpwolfe is offline Intermediate Member
    Join Date
    Oct 2006
    Posts
    18
    Rep Power
    8

    Default Debugging Question

    What would cause this?

    On a Fedora 4 (another box without ZCS), I do a 'dig domain.com' I get back the MX record or my ZCS box.
    On a RHEL (My ZCS box), I do a 'dig domain.com' I do not get back the MX record.

    Any thoughts? Still debugging.

  6. #6
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    You have checked that /etc/resolv.conf looks the same on both. Right?
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  7. #7
    brianpwolfe is offline Intermediate Member
    Join Date
    Oct 2006
    Posts
    18
    Rep Power
    8

    Default Sorry

    I am sorry about the last post. I meant to say, when I do:

    host greacl.com from one box I get the MX information back.

    Code:
    greacl.com has address 208.109.87.2
    greacl.com mail is handled by 10 mail.greacl.com.

    On my Zimbra box, when I do a host greacl.com I only get:

    Code:
    greacl.com has address 208.109.87.2
    Does this shed any light on the DNS problem? I will keep working on it, and post any other debugging info.

    My host file looks like this:
    Code:
    127.0.0.1               localhost.localdomain localhost
    208.109.87.2            greacl.com
    and my resolv.conf file looks like this:
    Code:
    nameserver 127.0.0.1
    nameserver 208.109.96.1
    nameserver 208.109.96.2
    my greacl.com file looks like this:
    Code:
    $ORIGIN greacl.com.
    @     3600      IN      SOA     ns1.greacl.com. admin.greacl.com. (
                    2006101401 ;    serial
                    172800 ;        refresh
                    3600 ;          retry
                    1209600 ;       expire
                    3600 ;          ttl
                    )
    
                    IN      NS              ns1
                    IN      NS              ns2
                    IN      MX      10      mail
                    IN      A               208.109.87.2
    
    mail            IN      A               208.109.87.2
    www             IN      A               208.109.87.2
    ns1             IN      A               208.109.87.2
    ns2             IN      A               208.109.87.2
    Is there any other files that I should be looking at?
    Last edited by brianpwolfe; 10-17-2006 at 05:10 AM.

  8. #8
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    This behaviour is correct.

    I am not a DNS expert but I checked this on a few of my domains and "host" responds in the same manner.

    Now if you can discover this system using DNS and the other system also knows which IP to send your mails to and both are properly connected over network...

    I am thinking this problem is not pertaining to DNS or Network ... let's leave this here for a while.

    Can you check what is checked or not in the Admin Section ->
    Global Settings -> MTA

    That is which Protocol checks, are checked and which DNS checks are checked.

    Also, Admin Section -> Servers -> yourhost.domain.com -> MTA

    Is "Enable DNS Lookups" checked?
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

  9. #9
    brianpwolfe is offline Intermediate Member
    Join Date
    Oct 2006
    Posts
    18
    Rep Power
    8

    Default

    Only the 2 are checked under the global settings.

    Code:
    Protocol checks: 	
    	X Hostname in greeting violates RFC (reject_invalid_hostname)
    	   Client must greet with a fully qualified hostname (reject_non_fqdn_hostname)
    	X Sender address must be fully qualified (reject_non_fqdn_sender)
    DNS checks: 	
    	  Client's IP address (reject_unknown_client)
    	  Hostname in greeting (reject_unknown_hostname)
    	  Sender's domain (reject_unknown_sender_domain)
    Enable DNS Lookups is checked. Under the domain settings.

  10. #10
    czaveri's Avatar
    czaveri is offline Former Zimbran
    Join Date
    Feb 2006
    Location
    Pune, India
    Posts
    294
    Rep Power
    9

    Default

    Ok, uncheck all of them. Save.

    Restart Zimbra

    Try Sending Email.

    Does the problem persist?
    Regards,

    Chintan Zaveri
    (Yet another ZIMBRAN!)

    "Dhundhne par Bhagwan bhi ..."

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problems with port 25
    By yogiman in forum Installation
    Replies: 57
    Last Post: 06-13-2011, 01:55 PM
  2. Replies: 7
    Last Post: 02-03-2011, 07:01 AM
  3. Zimbra fails after working for 2 weeks
    By Linsys in forum Administrators
    Replies: 10
    Last Post: 10-07-2008, 12:42 AM
  4. fresh install down may be due to tomcat
    By gon in forum Installation
    Replies: 10
    Last Post: 07-25-2007, 08:09 AM
  5. receiveing mail
    By maybethistime in forum Administrators
    Replies: 15
    Last Post: 12-09-2005, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •