Results 1 to 6 of 6

Thread: [SOLVED] Connection timed out when initializing ldap

  1. #1
    rob87 is offline New Member
    Join Date
    Apr 2011
    Posts
    4
    Rep Power
    4

    Default [SOLVED] Connection timed out when initializing ldap

    Hi There,
    I'm trying to install the latest version of Zimbra.

    OS: CentOS 5.6
    Zibra version: 7.1

    My installer hangs when it's trying to initialize ldap. My /tmp/zmsetup.04212011-220216.log sais:

    Thu Apr 21 21:59:09 2011 *** Running as zimbra user: /opt/zimbra/libexec/zmldapinit
    IO::Socket::INET: connect: Connection timed out at /opt/zimbra/libexec/zmldapinit line 136.
    Thu Apr 21 22:00:26 2011 failed. (28160)
    Thu Apr 21 22:00:26 2011

    ERROR

    Thu Apr 21 22:00:26 2011

    Configuration failed
    I thought i'ts becouse of the ip tables so i disabled it and still the same error.

    My next guess is that it has something to do with the DNS settings since it's a bit complicated with a dynamic IP but I have no clue what.

    My settings:

    domain: xyz.dyndns.biz
    the domain has an MX record pointing to: mail-host.dyndns.biz

    both DNS entries, xyz.dyndns.biz and mail-host.dyndns.biz point to the same address (my router that forwards all ports to my server).
    Since the installer does not accept it if the mx-record of the domain has not the same address as the server itself i added a local record with dnsmasq. So mail-host.dyndns.biz points to 127.0.0.1 now.

    I tried this for several hours now and google wasn't helpful aswell. If anyone could give me a hint what the problem is i'd be very grateful.

    Cheers

  2. #2
    quanah is offline Zimbra Employee
    Join Date
    May 2007
    Location
    Zimbra
    Posts
    1,262
    Rep Power
    10

    Default

    The ldap server tries to bind to a specific DNS name. If that DNS name isn't valid, it will fail to bind.
    Quanah Gibson-Mount
    Server Architect
    Zimbra, Inc
    --------------------
    Zimbra :: the leader in open source messaging and collaboration

  3. #3
    rob87 is offline New Member
    Join Date
    Apr 2011
    Posts
    4
    Rep Power
    4

    Default

    Thx for your replies. I figured out how to create a split-dns setup with dyndns and dnsmasq so everything works fine now.

    I created a blog entry how to do it becouse I didn't find anything about zimbra, split-dns and dnsmasq on google and thought others might be intrested aswell. Zimbra with dynamic IP and dnsmasq. Feel free to use it if it is helpful.

    Regards

  4. #4
    phoenix is offline Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,470
    Rep Power
    56

    Default

    Quote Originally Posted by rob87 View Post
    I created a blog entry how to do it becouse I didn't find anything about zimbra, split-dns and dnsmasq on google and thought others might be intrested aswell. Zimbra with dynamic IP and dnsmasq. Feel free to use it if it is helpful.
    There are threads all over the forums and a wiki article on Split DNS and Zimbra.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    rob87 is offline New Member
    Join Date
    Apr 2011
    Posts
    4
    Rep Power
    4

    Default

    I noticed that But all the examples i saw included a fully functional local DNS server (e.g. BIND). I though this is a bit of an overkill.
    (Besides that, using dnsmasq gives you the possibility to run it without touching an existing dns server running on your machine)
    But it is a split-dns solution after all.
    Last edited by rob87; 04-22-2011 at 04:20 AM.

  6. #6
    Valentine is offline Starter Member
    Join Date
    Jan 2013
    Posts
    1
    Rep Power
    2

    Default

    Good day, respected community! I have a problem with the installation at the Zimbru Tsentos version
    Linux mail 2.6.18-194.32.1.el5xen # 1 SMP Wed Jan 5 19:32:33 EST 2011 i686 i686 i386 GNU / Linux

    I did everything by the manual Split DNS - Zimbra :: Wiki eventually

    dig valentyne.kz mx
    ; << >> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_5.3 << >> valentyne.kz mx
    ;; Global options: printcmd
    ;; Got answer:
    ;; - >> HEADER << - opcode: QUERY, status: NOERROR, id: 11780
    ;; Flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ; Valentyne.kz. IN MX

    ;; ANSWER SECTION:
    valentyne.kz. 0 IN MX 10 mail.valentyne.kz.

    ;; ADDITIONAL SECTION:
    mail.valentyne.kz. 0 IN A 23.23.246.13

    ;; Query time: 1 msec
    ;; SERVER: 127.0.0.1 # 53 (127.0.0.1)
    ;; WHEN: Wed Jan 16 11:59:39 2013
    ;; MSG SIZE rcvd: 79

    dig valentyne.kz any
    ; << >> DiG 9.3.6-P1-RedHat-9.3.6-4.P1.el5_5.3 << >> valentyne.kz any
    ;; Global options: printcmd
    ;; Got answer:
    ;; - >> HEADER << - opcode: QUERY, status: NOERROR, id: 18480
    ;; Flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ; Valentyne.kz. IN ANY

    ;; ANSWER SECTION:
    valentyne.kz. 0 IN MX 10 mail.valentyne.kz.

    ;; ADDITIONAL SECTION:
    mail.valentyne.kz. 0 IN A 23.23.246.13

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1 # 53 (127.0.0.1)
    ;; WHEN: Wed Jan 16 12:00:36 2013
    ;; MSG SIZE rcvd: 79

    / Etc / hosts
    127.0.0.1 localhost.localdomain localhost
    23.23.246.13 mail.valentyne.kz mail

    / Etc / resolv.conf
    search valentyne.kz
    nameserver 127.0.0.1

    Wed Jan 16 11:47:51 2013 Initializing ldap ...
    Wed Jan 16 11:47:51 2013 *** Running as zimbra user: / opt / zimbra / libexec / zmldapinit
    IO :: Socket :: INET: connect: timeout at / opt / zimbra / libexec / zmldapinit line 137.
    Wed Jan 16 11:50:32 2013 failed. (28160)

    SELinux disabled
    Help please understand.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. initializing ldap...FAILED(256)ERROR
    By manjunath in forum Installation
    Replies: 39
    Last Post: 06-07-2013, 10:27 AM
  2. ldap no connection
    By jjj0923 in forum Installation
    Replies: 2
    Last Post: 03-13-2011, 11:00 AM
  3. Replies: 2
    Last Post: 02-12-2008, 11:55 AM
  4. can't you help me
    By iwan siahaan in forum Administrators
    Replies: 6
    Last Post: 12-17-2007, 06:53 PM
  5. Replies: 4
    Last Post: 11-15-2006, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •