Results 1 to 4 of 4

Thread: [SOLVED] Trouble with Documents Feature

  1. #1
    Jazzhands is offline Active Member
    Join Date
    May 2006
    Posts
    33
    Rep Power
    9

    Default [SOLVED] Trouble with Documents Feature

    After reading through the forums I found instructions on getting the Notebook feature to work. I'm running Release 4.0.1_GA_324.RHEL4_20060908135401 RHEL4 FOSS edition on an RHEL4 server. I made sure the feature was enabled through the admin. I then tried to use the feature through my login and saw the error:

    Error: Document templates missing. Please notify administrator.
    After searching the forums I saw I had to do a few things on the command line. So I did:

    zmprov -l mc default zimbraFeatureNotebookEnabled TRUE
    zmprov -l mcf zimbraNotebookAccount notebook@locahost.localdomain

    That looks good so far. Note the "-l" feature due to some java security alert I'm using ldap. The cert issue is another thing I'll need to fix once I get this doc feature working.

    Ok, I think I'm almost done and run this command:
    zmprov -l in notebook@domain.com /opt/zimbra/wiki/Template Template
    Initializing folders
    Initializing...
    Creating wiki document _TocBodyTemplate in folder Template
    Cannot import Wiki documents from /opt/zimbra/wiki/Template
    com.zimbra.cs.service.wiki.WikiServiceException: error: import
    at com.zimbra.cs.service.wiki.WikiServiceException.ER ROR(WikiServiceException.java:60)
    at com.zimbra.cs.wiki.WikiUtil$WikiSoapUtil.startImpo rt(WikiUtil.java:499)
    at com.zimbra.cs.account.ProvUtil.doImport(ProvUtil.j ava:1201)
    at com.zimbra.cs.account.ProvUtil.initNotebook(ProvUt il.java:1153)
    at com.zimbra.cs.account.ProvUtil.execute(ProvUtil.ja va:522)
    at com.zimbra.cs.account.ProvUtil.main(ProvUtil.java: 1418)
    Caused by: com.zimbra.soap.SoapFaultException: error: empty config variable zimbraNotebookAccount
    at com.zimbra.soap.Soap12Protocol.soapFault(Soap12Pro tocol.java:102)
    at com.zimbra.soap.SoapTransport.extractBodyElement(S oapTransport.java:212)
    at com.zimbra.soap.SoapTransport.parseSoapResponse(So apTransport.java:188)
    at com.zimbra.soap.SoapHttpTransport.invoke(SoapHttpT ransport.java:210)
    at com.zimbra.soap.SoapTransport.invoke(SoapTransport .java:228)
    at com.zimbra.cs.client.soap.LmcSoapRequest.invoke(Lm cSoapRequest.java:148)
    at com.zimbra.cs.wiki.WikiUtil$WikiSoapUtil.createWik i(WikiUtil.java:417)
    at com.zimbra.cs.wiki.WikiUtil$WikiSoapUtil.createIte m(WikiUtil.java:424)
    at com.zimbra.cs.wiki.WikiUtil$WikiSoapUtil.populateF olders(WikiUtil.java:460)
    at com.zimbra.cs.wiki.WikiUtil$WikiSoapUtil.startImpo rt(WikiUtil.java:496)
    ... 4 more
    I do some searches on the forums for keywords from the error, I search google, and I find nothing. So here's hoping someone has any clue with this means and can help me fix it. "error: empty config variable zimbraNotebookAccount" seems to be the key error but I don't have any idea how to rectify it. Thank you and please help

  2. #2
    Jazzhands is offline Active Member
    Join Date
    May 2006
    Posts
    33
    Rep Power
    9

    Default

    Well I figured out the problem. Something with ldap, possibly a password issue. So I found instructions in the wiki on how to renew my cert. Then reran the final template command without the "-l" and now it seems the doc feature is up and running. At least this thread might help someone in the future.

  3. #3
    dnortham is offline Starter Member
    Join Date
    Jun 2007
    Posts
    1
    Rep Power
    8

    Default

    I had gotten the same error. (Debian 4 etch). I ran:

    zmprov -l in wikiuser@somedomain.com password /opt/zimbra/wiki/Template Template

    then restarted zimbra, and then ran:

    zmprov in wikiuser@somedomain.com password /opt/zimbra/wiki/Template Template


    make sure your zimbra user is setup.
    zmprov gacf | grep -i notebook

    zimbraNotebookAccount: wikiuser@somedomain.com
    zimbraNotebookFolderCacheSize: 1024
    zimbraNotebookMaxCachedTemplatesPerFolder: 256
    zimbraNotebookPageCacheSize: 10240

  4. #4
    OneLoveAmaru is offline Junior Member
    Join Date
    May 2008
    Posts
    7
    Rep Power
    7

    Default

    Just running Jazzhands 2 commands worked for me! I have a CentOS 5 box and a Debian Etch box, but only the Cent had the problem. It seems that Zimbra has a lot of problems setting up and starting if DNS isn't perfect.

    Thanks for the help guys.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Trouble with Documents Upload feature
    By mmennen in forum Users
    Replies: 2
    Last Post: 06-04-2007, 08:04 AM
  2. Documents & Notebooks Woes
    By torusgrp in forum Administrators
    Replies: 0
    Last Post: 05-11-2007, 10:19 PM
  3. Documents Feature
    By tbullock in forum Users
    Replies: 3
    Last Post: 12-13-2006, 04:25 PM
  4. Documents Feature Messed up
    By frogstarr78 in forum Installation
    Replies: 1
    Last Post: 11-07-2006, 07:14 PM
  5. Documents feature - not seeing uploaded files
    By kevindods in forum Installation
    Replies: 7
    Last Post: 10-31-2006, 06:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •