Results 1 to 3 of 3

Thread: Moving Zimbra

  1. #1
    nadia007 is offline Intermediate Member
    Join Date
    Sep 2006
    Rep Power

    Default Moving Zimbra

    I'm trying to move zimbra from it's current location. I'm following these instructions from the wiki to make a backup and then restore it into it's new location.

    I've followed the instructions of stopping zimbra and copying the files. When I try run it it doesn't work. When I try to do the upgrade as stated on the wiki, it gives me the "UPGRADE FAILED - exiting" error. I'ved tried restarting the script and I continue to receive the same error. Any suggestions?


  2. #2
    KevinH's Avatar
    KevinH is offline Expert Member
    Join Date
    Aug 2005
    San Mateo, CA
    Rep Power


    Any clues in the install/upgrade logs? /tmp/zmsetup* and /tmp/install*
    Looking for new beta users -> Co-Founder of Acompli. Previously worked at Zimbra (and Yahoo! & VMware) since 2005.

  3. #3
    nadia007 is offline Intermediate Member
    Join Date
    Sep 2006
    Rep Power


    Sry, I don't mean to give such a vague description. Here is what's happening.

    I'm adding a new hdd. I've partitioned it and have used LVM to set the logical volume on it. Now that I have added the drive to my PC, I wanted to simply mount my new drive to /opt/zimbra so that I can have all my zimbra files in a seperate drive.

    - First things first. I sudo su zimbra and did a zmcontrol stop. Made sure everything was stopped before doing anything.
    - I then mounted the new drive to a new folder called /opt/zimbra2, then did a sudo cp -rp /opt/zimbra/* /opt/zimbra2
    - This did move all the files from the working /opt/zimbra folder to the new hdd.
    - I then unmounted my new hdd and renamed my original /opt/zimbra to /opt/zimbra-original and renamed my /opt/zimbra2 to /opt/zimbra and remounted the drive to the new /opt/zimbra dir.
    - I added the mounting parameters on my /etc/fstab.
    - I then restarted my PC, when I tried switching to sudo su zimbra and typed zmcontrol start, it would tell me that it didn't recognize that command.
    - Since that didn't work, I considered doing the "Upgrade" to see if that would correct the problem, but all I get shortly after it tries to stop services for the second time doing the upgrade it throws a "UPGRADE FAILED - exiting" error. I've checked the logs and it says the exact same thing.

    Is there an easier way that I can move my zimbra to the new drive?


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. QUE Failure
    By tbullock in forum Administrators
    Replies: 31
    Last Post: 07-30-2008, 12:17 PM
  2. Replies: 16
    Last Post: 09-07-2006, 06:39 AM
  3. Services stopped working
    By lilwong in forum Administrators
    Replies: 4
    Last Post: 08-15-2006, 09:19 AM
  4. Fedora Core 3, Clean Install - Not working!
    By pcjackson in forum Installation
    Replies: 17
    Last Post: 03-05-2006, 07:38 PM
  5. Monitoring : Data not yet avalaible
    By s3nz3x in forum Installation
    Replies: 7
    Last Post: 11-30-2005, 07:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts