Results 1 to 10 of 10

Thread: Help to sent email to external accounts

  1. #1
    clerma is offline Member
    Join Date
    Jan 2011
    Posts
    10
    Rep Power
    4

    Default Help to sent email to external accounts

    Hi Forum,

    I am pretty new with Zimbra, I started a few days ago to prepare and install a small lab on my laptop:

    - Using a VmWare, create a VM with Debian5.
    - Installed the Release 6.0.10_GA_2692.DEBIAN5 DEBIAN5 FOSS edition

    After some issues mainly with the DNS (i had to install dnsmasq) and some port conflicts; everything works perfect but just only inside of my debian system or domain (all inside oy my laptop).

    I can send and receive emails between the accounts that I created and manage all the accounts with zimbra server and the console.

    Now I want to test to send and receive emails from out (hotmail, gmail, etc...)

    Due to I am not an expert on DNS I would like your help do that.

    I pasted my config files in order to receive any recommendation or a good link to read:


    zimbra@zimbra:~$ cat /etc/hosts
    127.0.0.1 localhost
    192.168.49.130 zimbra.zimbra-local.com zimbra

    zimbra@zimbra:~$ cat /etc/hostname
    zimbra

    zimbra@zimbra:~$ cat /etc/resolv.conf
    search zimbra-local.com
    nameserver 127.0.0.1

    zimbra@zimbra:~$ cat /etc/dnsmasq.conf
    server=8.8.8.8
    server=208.67.222.222
    domain=zimbra-local.com
    mx-host=zimbra-local.com,zimbra.zimbra-local.com,5
    listen-address=127.0.0.1

    I appreciate your help!
    Regards,
    Carlos L.

  2. #2
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,505
    Rep Power
    57

    Default

    Your hosts file is incorrect, I'd suggest you go to the Split DNS article and read-up on what's needed for the hosts file and the required DNS A & MX records. When you've configured them correct you can run all the commands in the 'Verify...' section of that article to check the settings - full details are in there of what's required.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  3. #3
    clerma is offline Member
    Join Date
    Jan 2011
    Posts
    10
    Rep Power
    4

    Default

    Bill, thanx....I followed the Split DNS, that helped me to setup my lab....everthing works fine if I send email from any_acct@zimbra-local.com to any account under my local lab domain zimbra-local.com

    Now that I saw how it works I want to send mails to external and that is my issue.

    again I'm not an expert on DNS stuff...
    regards.

  4. #4
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,505
    Rep Power
    57

    Default

    Quote Originally Posted by clerma View Post
    Bill, thanx....I followed the Split DNS, that helped me to setup my lab....everthing works fine if I send email from any_acct@zimbra-local.com to any account under my local lab domain zimbra-local.com

    Now that I saw how it works I want to send mails to external and that is my issue.
    Please post the output from the commands you ran from the 'verify..' section of the Split DNS article.
    Last edited by phoenix; 02-06-2011 at 11:19 AM.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  5. #5
    clerma is offline Member
    Join Date
    Jan 2011
    Posts
    10
    Rep Power
    4

    Default

    Here the results from verify section.

    One thing is that the zimbra-local.com domain is a dummy domain that I invented to set my lab on my laptop...sure that not work from internet.

    here the responses:

    zimbra@zimbra:~$ dig zimbra-local.com mx

    ; <<>> DiG 9.6-ESV-R3 <<>> zimbra-local.com mx
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 54578
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;zimbra-local.com. IN MX

    ;; ANSWER SECTION:
    zimbra-local.com. 0 IN MX 5 zimbra.zimbra-local.com.

    ;; ADDITIONAL SECTION:
    zimbra.zimbra-local.com. 0 IN A 192.168.49.130

    ;; Query time: 7 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Sun Feb 6 12:02:50 2011
    ;; MSG SIZE rcvd: 89

    zimbra@zimbra:~$ dig zimbra-local.com any

    ; <<>> DiG 9.6-ESV-R3 <<>> zimbra-local.com any
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 4605
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

    ;; QUESTION SECTION:
    ;zimbra-local.com. IN ANY

    ;; ANSWER SECTION:
    zimbra-local.com. 0 IN MX 5 zimbra.zimbra-local.com.

    ;; ADDITIONAL SECTION:
    zimbra.zimbra-local.com. 0 IN A 192.168.49.130

    ;; Query time: 0 msec
    ;; SERVER: 127.0.0.1#53(127.0.0.1)
    ;; WHEN: Sun Feb 6 12:02:59 2011
    ;; MSG SIZE rcvd: 89

    zimbra@zimbra:~$ host $(hostname)
    zimbra.zimbra-local.com has address 192.168.49.130

    regards,

  6. #6
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,505
    Rep Power
    57

    Default

    What does you hosts file and resolv.conf contain?
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  7. #7
    clerma is offline Member
    Join Date
    Jan 2011
    Posts
    10
    Rep Power
    4

    Default

    here:

    zimbra@zimbra:~$ cat /etc/hosts
    127.0.0.1 localhost
    192.168.49.130 zimbra.zimbra-local.com zimbra

    zimbra@zimbra:~$ cat /etc/hostname
    zimbra

    zimbra@zimbra:~$ cat /etc/resolv.conf
    search zimbra-local.com
    nameserver 127.0.0.1

    zimbra@zimbra:~$ cat /etc/dnsmasq.conf
    server=8.8.8.8
    server=208.67.222.222
    domain=zimbra-local.com
    mx-host=zimbra-local.com,zimbra.zimbra-local.com,5
    listen-address=127.0.0.1

  8. #8
    clerma is offline Member
    Join Date
    Jan 2011
    Posts
    10
    Rep Power
    4

    Default

    Any idea??

    Thanks in advance.

  9. #9
    phoenix is online now Zimbra Consultant & Moderator
    Join Date
    Sep 2005
    Location
    Vannes, France
    Posts
    23,505
    Rep Power
    57

    Default

    Quote Originally Posted by clerma View Post
    Any idea??

    Thanks in advance.
    Your hosts file is incorrect, got o the Split DNS article and see what the correct format is and what should be in that file.
    Regards


    Bill


    Acompli: A new adventure for Co-Founder KevinH.

  10. #10
    clerma is offline Member
    Join Date
    Jan 2011
    Posts
    10
    Rep Power
    4

    Default

    Bill

    I double check the Split DNS I also changed my host files as:

    zimbra:~# cat /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    192.168.49.130 zimbra.zimbra-local.com zimbra

    One important point is that sending emails between @zimbra-local.com domain works perfect, that is the dummy domain that I have in my laptop (local, not work from internet).

    Maybe over a laptop enviornment I can not send external email or I require a server and Internet provider to set the DNS stuff...

    If somebody had setup on a lap I appreaciate your comments, due to next week I will show to IT Director the zimbra capabilities in order to stop using exchgange

    best regards

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 12-28-2010, 08:43 AM
  2. Zimbra Desktop External Email & Unified Inbox
    By juanfermin in forum Developers
    Replies: 1
    Last Post: 04-08-2008, 05:12 PM
  3. need advice on configuring zimbra to work with fax server
    By pheonix1t in forum Administrators
    Replies: 0
    Last Post: 07-11-2007, 07:46 PM
  4. upgrade to 4.0.3 antispam does'nt work
    By lucanannipieri in forum Administrators
    Replies: 14
    Last Post: 11-07-2006, 03:56 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •